Lyricator v1.5.2 (2021-07-15)

Download and get help for different MediaMonkey Addons.

Moderators: Peke, Gurus

jaygould
Posts: 5
Joined: Fri Jul 31, 2020 9:33 am

Re: Lyricator v1.5.1 (2020-03-22)

Post by jaygould »

dsmall@comporium.net wrote: Sun Nov 01, 2020 8:17 pmI keep getting the following screen when I right click a file and run Lyricator. Occasionally I get the real search presentation.
Getting the exact same thing. Found out the following: Clicking "Search for lyrics" breaks Lyricator, workaround: Restart MediaMonkey.
Once I click "Search for lyrics" when listening to a song, Lyricator is broken again, another restart fixes this. Annoying but works for me.
dsmall@comporium.net
Posts: 3
Joined: Tue Aug 11, 2020 12:32 pm

Re: Lyricator v1.5.1 (2020-03-22)

Post by dsmall@comporium.net »

Thanks for the suggestion. I have tried so many combinations and non work consistently. Sometimes it works and sometimes it does not. I also get a ton of immediate screen blinks when I start Lyricator. I have learned to open properties and then close it before starting Lyricator. For some reason, files are not getting in MM directory. MM really has a lot of great functionality but it is complex to use.

Dave
jaygould
Posts: 5
Joined: Fri Jul 31, 2020 9:33 am

Re: Lyricator v1.5.1 (2020-03-22)

Post by jaygould »

For me it also seems to make a difference if I start Lyricator from the Extras - Scripts-Menu compared to right-clicking on marked files and then Lyricator - All configured files (the latter works more reliably, starting it from the menu often just "loads" forever without actually fetching any lyrics).
dsmall@comporium.net
Posts: 3
Joined: Tue Aug 11, 2020 12:32 pm

Re: Lyricator v1.5.1 (2020-03-22)

Post by dsmall@comporium.net »

If there is someone out there who does technical support, I have noticed a pattern on this error. It seems to occur after opening Lyricator successfully and either closing or saving the result to close the service. It is acting like there is a code remnant remaining in memory that is causing a failure when Lyricator attempts to open it again. It may be a system service, a Lyricator code service or even a MediaMonkey service - not sure. Just a thought. I am also having problems with songs being resident in the Media Monkey library resulting in Lyricator opening quickly and closing. When this happens, I have to open the songs properties, close the song and then open Lyricator. I rescanned the specific hard drive directory and then rescanned the complete music library to the MediaMonkey library and this only seems to work once (if at all).

I looked in Task Manager under details and found I was running Media-Monkey (non-skinned). Does this make a difference?

I ran another test. Opened MediaMonkey, selected a file, ran Lyricator: quick open and close. Used properties to open the file and then did a close. Opened Lyricator (using the icon) and it worked. Selected a second file and opened lyricator (quick fail again) and repeated opening/closing properties. Opened Lyricator and got the white box with data previously reported and then nothing. Closed MediaMonkey and reopened it after checking task manager to insure mediamonkey was gone. Selected file and opened Lyricator - fast failure again. Opened/closed properties and then ran lyricator (from icon) and got the white box again. Closed / opened media monkey and ran the same test with initiating lyricator from the right click option. Again got the white box. Rebooted the machine, opened mediamonkey, selected a file, ran lyricator - quick open and close again. Used properties to open/close, ran lyricator (as above) and it worked. After closing the lyricator box, selected another file, and following tests all resulted in a white box.

I do have the new Edge installed.

I hope this helps.
TekGamer
Posts: 58
Joined: Sun Jul 22, 2007 5:33 am
Location: Chicago, IL

Re: Lyricator v1.5.1 (2020-03-22)

Post by TekGamer »

dsmall@comporium.net wrote: Tue Nov 03, 2020 7:02 am If there is someone out there who does technical support, I have noticed a pattern on this error. It seems to occur after opening Lyricator successfully and either closing or saving the result to close the service. It is acting like there is a code remnant remaining in memory that is causing a failure when Lyricator attempts to open it again. It may be a system service, a Lyricator code service or even a MediaMonkey service - not sure. Just a thought. I am also having problems with songs being resident in the Media Monkey library resulting in Lyricator opening quickly and closing. When this happens, I have to open the songs properties, close the song and then open Lyricator. I rescanned the specific hard drive directory and then rescanned the complete music library to the MediaMonkey library and this only seems to work once (if at all).

I looked in Task Manager under details and found I was running Media-Monkey (non-skinned). Does this make a difference?

I ran another test. Opened MediaMonkey, selected a file, ran Lyricator: quick open and close. Used properties to open the file and then did a close. Opened Lyricator (using the icon) and it worked. Selected a second file and opened lyricator (quick fail again) and repeated opening/closing properties. Opened Lyricator and got the white box with data previously reported and then nothing. Closed MediaMonkey and reopened it after checking task manager to insure mediamonkey was gone. Selected file and opened Lyricator - fast failure again. Opened/closed properties and then ran lyricator (from icon) and got the white box again. Closed / opened media monkey and ran the same test with initiating lyricator from the right click option. Again got the white box. Rebooted the machine, opened mediamonkey, selected a file, ran lyricator - quick open and close again. Used properties to open/close, ran lyricator (as above) and it worked. After closing the lyricator box, selected another file, and following tests all resulted in a white box.

I do have the new Edge installed.

I hope this helps.
I have the same behavior with Lyricator, and I have the save issue when MM4 is running skinned.
TekGamer
TekGamer
Posts: 58
Joined: Sun Jul 22, 2007 5:33 am
Location: Chicago, IL

Re: Lyricator v1.5.1 (2020-03-22)

Post by TekGamer »

Does anybody have a fix for having to always run Lyricator twice to get it to work?
TekGamer
thehammer
Posts: 145
Joined: Wed Dec 15, 2004 2:15 pm

Re: Lyricator v1.5.1 (2020-03-22)

Post by thehammer »

jaygould wrote: Tue Aug 04, 2020 4:34 pm In MMW 4.1.29.1910 the Lyricator-windows looks like this for me all the time - somehow I can't post an image or include an images from a free image hoster, but it's all white, in the upper left corner there a small "X"-icon, below that something that looks like an unchecked checkbox, next line: "0", next line "<band>", next line "<album>". That's it.

Anybody knows how to fix this? Using the latest versino of Edge (Version 84.0.522.52), is there some setting I'm missing? Or do I need to make some change to the Windows firewall (using Windows 10)?

Kind regards
The only time I have seen this is when searching for a song that is not actually part of the MM music library. It hasn't been added yet.
ImageSpoon!
thehammer
Posts: 145
Joined: Wed Dec 15, 2004 2:15 pm

Re: Problems with Musixmatch

Post by thehammer »

gibbon wrote: Mon Jun 22, 2020 3:42 am I am experiencing problems with the Musixmatch-Source.

I made some tests with this album that is listed on Musixmatchg but isn't found with Lyricator:
https://www.musixmatch.com/album/Courtn ... -Your-Side

The artists tag is: Courtney Hartman & Taylor Ashton.
As you can see Musixmatch uses "Courtney-Hartman-Taylor-Ashton" in the URL listed above.

So I tested some changes in the Artist tag and one change worked:
Courtney Hartman Taylor Ashton

The created search-string of the Lyricator for Musixmatch is apparently wrong if a "&" is in the artist tag. A solution seems to be to simply drop the "&" in the search string.
The variations that Lyricator creates during the search (i.e. dropping everything after &) don't work.

So I suggest to add an additional search-variation where the "&" is simply dropped.
Putting in converstion for & character to - in the next release.
ImageSpoon!
thehammer
Posts: 145
Joined: Wed Dec 15, 2004 2:15 pm

Re: Lyricator v1.5.1 (2020-03-22)

Post by thehammer »

dsmall@comporium.net wrote: Mon Nov 02, 2020 2:49 pm Thanks for the suggestion. I have tried so many combinations and non work consistently. Sometimes it works and sometimes it does not. I also get a ton of immediate screen blinks when I start Lyricator. I have learned to open properties and then close it before starting Lyricator. For some reason, files are not getting in MM directory. MM really has a lot of great functionality but it is complex to use.

Dave
This is usually a sign that Lyricator has been installed two different ways (for all users and not for all users). Files get installed in two places and MM gets confused when loading the plugin. As in a previous post these are install locations:

Program Files or Program Files (x86) and/or Users/<your user/AppData/Roaming then MediaMonkey/Scripts
Lyricator Directory
Auto/lyricator.vbs
As far as the old Lyricator preferences, they would need to be cleaned out of the MediaMonkey/Scripts/Scripts.ini and MediaMonkey/MediaMonkey.ini files.

Also, if you have MediaMonkey installed as Portable then I don't know what will happen but it may not support that type of install. If you uninstall, manually cleanup Lyricator from all locations and reinstall it usually stablizes. Not sure where standalone installs go.
ImageSpoon!
thehammer
Posts: 145
Joined: Wed Dec 15, 2004 2:15 pm

Re: Lyricator v1.5.1 (2020-03-22)

Post by thehammer »

TekGamer wrote: Sun Nov 22, 2020 3:27 pm
dsmall@comporium.net wrote: Tue Nov 03, 2020 7:02 am If there is someone out there who does technical support, I have noticed a pattern on this error. It seems to occur after opening Lyricator successfully and either closing or saving the result to close the service. It is acting like there is a code remnant remaining in memory that is causing a failure when Lyricator attempts to open it again. It may be a system service, a Lyricator code service or even a MediaMonkey service - not sure. Just a thought. I am also having problems with songs being resident in the Media Monkey library resulting in Lyricator opening quickly and closing. When this happens, I have to open the songs properties, close the song and then open Lyricator. I rescanned the specific hard drive directory and then rescanned the complete music library to the MediaMonkey library and this only seems to work once (if at all).

I looked in Task Manager under details and found I was running Media-Monkey (non-skinned). Does this make a difference?

I ran another test. Opened MediaMonkey, selected a file, ran Lyricator: quick open and close. Used properties to open the file and then did a close. Opened Lyricator (using the icon) and it worked. Selected a second file and opened lyricator (quick fail again) and repeated opening/closing properties. Opened Lyricator and got the white box with data previously reported and then nothing. Closed MediaMonkey and reopened it after checking task manager to insure mediamonkey was gone. Selected file and opened Lyricator - fast failure again. Opened/closed properties and then ran lyricator (from icon) and got the white box again. Closed / opened media monkey and ran the same test with initiating lyricator from the right click option. Again got the white box. Rebooted the machine, opened mediamonkey, selected a file, ran lyricator - quick open and close again. Used properties to open/close, ran lyricator (as above) and it worked. After closing the lyricator box, selected another file, and following tests all resulted in a white box.

I do have the new Edge installed.

I hope this helps.
I have the same behavior with Lyricator, and I have the save issue when MM4 is running skinned.
See my recent response. I have seen similar behavior when people have installed the plugin over time with different settings (for all users, not for all, as standalone). The only way people have stabilized the plugin was to uninstall, clean up all remnants of Lyricator from all locations, then re-install.
ImageSpoon!
thehammer
Posts: 145
Joined: Wed Dec 15, 2004 2:15 pm

Re: Problems with Musixmatch

Post by thehammer »

gibbon wrote: Mon Jun 22, 2020 3:42 am I am experiencing problems with the Musixmatch-Source.

I made some tests with this album that is listed on Musixmatchg but isn't found with Lyricator:
https://www.musixmatch.com/album/Courtn ... -Your-Side

The artists tag is: Courtney Hartman & Taylor Ashton.
As you can see Musixmatch uses "Courtney-Hartman-Taylor-Ashton" in the URL listed above.

So I tested some changes in the Artist tag and one change worked:
Courtney Hartman Taylor Ashton

The created search-string of the Lyricator for Musixmatch is apparently wrong if a "&" is in the artist tag. A solution seems to be to simply drop the "&" in the search string.
The variations that Lyricator creates during the search (i.e. dropping everything after &) don't work.

So I suggest to add an additional search-variation where the "&" is simply dropped.
I will be pushing version 1.5.2 out that fixes the & issue. It will be available in MediaMonkey Add-ons (soon) and happymonkeying.com (currently unable to update here because of a login issue I reported. unfortunately, this is where the automatic extension updates are pointing).
ImageSpoon!
thehammer
Posts: 145
Joined: Wed Dec 15, 2004 2:15 pm

Re: Lyricator v1.5.1 (2020-03-22)

Post by thehammer »

thehammer wrote: Sun Jun 07, 2020 9:25 am
gibbon wrote: Sun Jun 07, 2020 2:13 am Good News:
Genius works again.
Bad News:
I don't know exactly why.
Problem:
It does not work reliable.

I made some tests and changed some parameters. So I switched the standard browser to edge and back to chrome, deleted cookies ...
Always after changing 1 of these parameters I tested Genius each time. The problem was, that I tested it with "Beatles - Yesterday" and because before Genius was not working at all, I had not noticed that Genius also needs "The Beatles" as artist to find the song.
So I don't know which change or whether a change at all made it work again.

So I made some more tests and choose the Album: "Queen - Queen II". This album is listed on Genius and the lyrics of all songs are available. The writing of the tracks are the same as in my tags.
These songs gave no results:
Father to Son
Never More
Funny How Love Is
Seven Seas of Rhye

The others of the album did.

And to make the unpredictable behaviour of the Genius-source complete:
Before taken the album "Queen II" I tested with another album not really systematic. There the song "Queen - Bohemian Rhapsody" did not work. After some time I tested it again and the song worked. After a restart and some time again it did not work.
So now I tested (about 1 hour later) the above mentioned songs again and "Funny How Love IS" and "Never More" worked this time.

In the past I already wrote here that I often find lyrics at Genius manually with my browser that Lyricator did not find.
Thanks for the update. The reason I ask about Edge is because Lyricator is written in both Visual Basic and Javascript and uses Edge as the browser when launching the lyrics search window. As far as the inconsistency of success with Genius, it could be some throttling or IP blocking that has happened in the past with other lyrics sites. They sometimes have some mechanism that they use to determine if the lookup is robot based or an actual user on a browser. I'm not sure what the mechanism is but some of them are based on how many lookups per minute come from an IP address. There are waits built into Lyricator that keep it from bombarding a site with searches and thus getting throttled by the lyrics sites, and maybe Genius needs to be increased. It is currently set to a 1 second delay between requests.
I am pushing version 1.5.2 to fix Genius. It will be available on MediaMonkey add-ons first the later happymonkeying.com (trying to get login issues fixed to upload the update).
ImageSpoon!
boober
Posts: 16
Joined: Sat Mar 11, 2017 4:44 pm

Re: Lyricator v1.5.1 (2020-03-22)

Post by boober »

@thehammer

After installing 1.5.2, searching for lyrics on Genius results in a "test placeholder" plus HTML code for all songs. Are you seeing the same results?
thehammer
Posts: 145
Joined: Wed Dec 15, 2004 2:15 pm

Re: Lyricator v1.5.1 (2020-03-22)

Post by thehammer »

boober wrote: Fri Jul 23, 2021 2:09 pm @thehammer

After installing 1.5.2, searching for lyrics on Genius results in a "test placeholder" plus HTML code for all songs. Are you seeing the same results?
Yes, they have managed to break Lyricator yet again. I'll see if I can fix it yet again today. ☹️
ImageSpoon!
boober
Posts: 16
Joined: Sat Mar 11, 2017 4:44 pm

Re: Lyricator v1.5.2 (2021-07-15)

Post by boober »

Ah, frustrating. Thank you for your work on this!
Post Reply