Page 1 of 1

MM service: Error 5, access denied

Posted: Fri Mar 24, 2017 11:58 am
by surfer
Media Sharing Service will not work on my PC: win10-x64, MM It has never worked. It seems installed but is not working.

When MM is started syncing/sharing to MMA is no problem.

When i try to install the service by the button 'Install service' an error pops up: [SC] StartService: OpenSevice ERROR 5: Access denied.
I klick "OK" on this error message and the label of the service button changes - despite of the error - to "uninstall service".

No i klick on the button "uninstall service" and the button label changes to "install service".

Now, the second time, i klick on the button "install service" and only now i get the the confirm window: Service successfully installed.
And the service button label changes again to "uninstall service".

It looks now as though the service is installed. But it is not working: i do not see the media server in MMA neither by upnp nor by sync.

Sync/upnp work only with MM started. Rebooting or restarting/closing MM does not solve the issue.

What could i try to do to get it working?

Re: MM service: Error 5, access denied

Posted: Fri Mar 24, 2017 12:03 pm
by surfer
I've already tried the following approach without success:

Start secpol.msc
1. Open Local Security Policy app
2. Expand Local Policies, and then click User Rights Assignment
3. In the right pane, right-click Log on as a service, and then click Add User or Group.
4. In the User and Group Names box, type the name that you want to add to the policy, and then click OK. (in my case this was the admin user account I log in with)
5. Quit the Local Security Policy app ... 0&start=15