Access violation with Play to

Beta Testing for Windows Products and plugins

Moderator: Gurus

Andre Gosselin
Posts: 16
Joined: Mon Sep 17, 2012 4:13 pm

Access violation with Play to

Post by Andre Gosselin »

I would like to report the following issue with MM when "Play to .." is set to an external UPnP renderer. If no track is being played by MM, and something is sent for playing to this renderer through an independent UPnP controller (say controller B), MM starts after about a minute to throw a flurry of "access violations" error windows every second or so. Impossible then to reset the "Play to ..." settting to the internal player, and one has to shut off controller B, or to kill MM with the task manager. If MM is restarted, with "Play to ..." still set to the external player, and this player is still controlled by controller B and playing a track, access violation errror windows start to pop up immediately.

I agree that trying to manage a given renderer through two different controllers (MM and controller B) is certainly not a thing to do and a sure road to chaos. But it is something which is somewhat easy to provoke by mistake. For ex., you start MM and play a playlist to the external player. Once the playlist is done, you go away and leave MM running. After a while, you pick up your mobile device where you have a control point app and start sending tracks to your renderer, forgetting that MM still has the "Play to" feature set to this renderer. The still running MM application will soon start to throw error windows to the screen, becoming unusable, making you somewhat nervous when you come back to the PC running MM, trying to undersyand what is going wrong.

I think that MM should try to react to this situation in a nicer and more helpful way for the user. Would it be possible for ex. to post a *single* dialog window telling explicitely about a conflict with an external upnp controller currently accessing the "play to" device ?

Regards,
dtsig
Posts: 3431
Joined: Mon Jan 24, 2011 6:34 pm

Re: Access violation with Play to

Post by dtsig »

Have you created a debug log. That would give the devs a good view of what is happening upto the errors
Where's the db and ini stored
Reporting Bugs
Where tags are stored

Not affiliated with MediaMonkey ... just a RABID user/lover
DTSig
Andre Gosselin
Posts: 16
Joined: Mon Sep 17, 2012 4:13 pm

Re: Access violation with Play to

Post by Andre Gosselin »

dtsig wrote:Have you created a debug log. That would give the devs a good view of what is happening upto the errors
I installed the debug version and tried all day to replicate the problem, without success. No idea what happened. I will keep trying in the next few days.
Post Reply