Page 1 of 2

Script Errors when loading/playing tracks

Posted: Sat Jan 26, 2008 12:08 pm
by judas

since v. i've been getting errors when opnening the monkey...the installation was done over errors I get are:

Code: Select all

Error #429 - Microsoft VBScript runtime error
ActiveX comonent can't create object: 'SongsDB.SDBApplication'
File "C:\Program Files\Mediamonkey\Scripts\Auto\ExternalTools.vbs", Line:20, Column:10
and then

Code: Select all

Error Happened during script execution:
ActiveX comonent can't create object: 'SongsDB.SDBApplication'
This also happens with ScrobblerDJ auto script

The thing is this worked perfectly on if I revert and install that version over the two newer ones it works flawlessly again.

Edit: Changed the topic's subject

Posted: Sat Jan 26, 2008 12:43 pm
by Peke
Check Windows permissions for MediaMonkey as something is Blocking it to access Windows Scripting Host.

Posted: Sat Jan 26, 2008 3:57 pm
by judas
But is it normal that works perfectly but neither .1131 nor .1132 work?

Posted: Sat Jan 26, 2008 4:43 pm
by Peke
Yes, windows phishing can be tricky sometimes and on Vista even more. Also problems can be even more tricky if you have some sort of antivirus app that do not follow MM versions update correctly :) Zone Alarm have Trusted flag so that App is checked only by Filename and Path and not by CRC/MD5/Size/... :)

Posted: Sat Jan 26, 2008 6:17 pm
by judas
I have zonealarm...checked the program permissions and it seems ok to mediamonkey....any ideas on what i can do????

Posted: Sat Jan 26, 2008 9:11 pm
by Peke
Check under "Program Control" What is set for each MediaMonkey version and see if something is different for last two updates?

Posted: Sun Jan 27, 2008 4:45 am
by judas
Hey Peke, thanks for the replies!! (I'm here, 4:45 am supporting your countryman Novak Djokovic on the Aus Open Final!)

I've been playing around with the settings, permissions, etc. on ZoneAlarm and it didn't make any change so far....29 works but .31 and .32 don't. I think I can discard the problem and think ZoneAlarm isn't the culprit, cause even when it's shut off the problem is still happening.

Any ideas where to look from here? Windows settings? will a debug log helo at all? Anything will be appreciated

Posted: Sun Jan 27, 2008 9:28 am
by Peke
THX for supoort. I've been watching also.

I have almost identical setup like yours including Zone Alarm and have no problems at all :(

I don't think that MM debug will be helpful but who knows.

Can you try to do this simple script start outside of MM, but while MM is started and playing (If Need delete all Scripts from Mm folder)?

Code: Select all

Set SDB = CreateObject("SongsDB.SDBApplication")
That way we will see if MediaMonkey is the problem.

Posted: Mon Jan 28, 2008 10:04 am
by judas
Thanks Peke!

So here's what I Did:

1. Deleted The scripts folder,..made a new one which only had an empty scripts.ini file and an empty auto folder.

2. Opened errors appeared on launch, as expected.

3. Placed the example script as example.vbs on the (previously empty) scripts folder.

4. played a song on MM

5. Executed the script from windows explorer

6. Got an error:

Code: Select all

Windows Script Host
Script:      C:\Program Files\MediaMonkey\Scripts\Example.vbs
Line:         2
Char:         1
Error:        ActiveX component can't create object: 'SongsDB.SDBApplication'
Code:         800A01AD
Source:       Microsoft VBScript runtime error
So,...i don't know if that helps, or even if the steps i followed were what i was siupposed to do? or if that means the problem isn't MM related...ideas?

Posted: Mon Jan 28, 2008 11:23 am
by Peke
It helps, your Scripting Host is Damaged Try to reinstall it.
This Simple script checks if WSH can be initialized Correctly.
Search Windows Scripting Host Download on Form I know that there should be links to download.

Posted: Mon Jan 28, 2008 4:38 pm
by judas
Will do reinstall the script host...however, I still don't understand why if i follow the same steps with MM there is no error....the song i'm playing simply restarts and that's all! Very strange, isn't it? do you know what can be happening?

Posted: Thu Jan 31, 2008 8:40 am
by judas
I installed (RC3) and I can confirm I'm still having the same problems. Please Help me!! :-)...also, couldn't find where to download the WSH for Vista (did find v5.7 for Server 2003 and XP though...)

Posted: Thu Jan 31, 2008 8:49 pm
by Guest
I'm having a similar problem with MM 1127. When I launch MM with an external vb script it launches fine. However when I run the same script again I get the above error.

If I launch MM from the explorer then I can run the script as many times as I want with no problems.

Here is the script:

Code: Select all

Dim SDB : Set SDB = CreateObject("SongsDB.SDBApplication")
SDB.ShutdownAfterDisconnect = false
I notice that when I launch it from the script the Parent process is svchost.exe as opposed to explorer.exe. Perhaps there's a clue here?

Process explorer shows the command line for launching MM when under svchost.exe as C:\PROGRA~1\MEDIAM~1\MEDIAM~2.EXE -Embedding


Posted: Wed Feb 20, 2008 10:33 pm
by Peke
Install Debug version and let MM Send us Debug Logs on Crash.

Vista came with 5.7 actually 5.7.18000.

Posted: Sun Mar 09, 2008 1:58 pm
by judas
still lost on this one...canĀ“t find the installer of the wsh for vista, the one for XP won't install...still can't use MM without getting the errors at launch...any help would be greatly greatly appreciated!!