RC3 - Dead links where filename includes '.' or ampersand

Beta Testing for Windows Products and plugins

Moderator: Gurus

joejoe
Posts: 47
Joined: Sun May 13, 2007 6:10 am
Location: Aussie in Switzerland
Contact:

RC3 - Dead links where filename includes '.' or ampersand

Post by joejoe »

I uninstalled RC2 and deleted everything, except my .ini file and .db file
Then reinstalled RC3. (by the way it looks great, many issues I had are now fixed)

I noticed that now I have a few dead links I didn't have before. It seems to be when the artist / song / album name contains period (.) or ambersand (&)

Example:
Hard disk
C:\Users\Public\Music\Village People\Village People - Y.M.C.A.mp3
Media Monkey file properties:
C:\Users\Public\Music\Village People\Village People - Y.M.C.A..mp3

I guess I need to do a rescan and rename. I'm not sure if this would happen to someone who upgraded directly from MM2, perhaps it's caused by a previous beta release that had a bug, and now I need to resacn. But I'm surprised the upgrade changed the filename in the MM database and created the dead link. or perhaps a fix to the 'dead links' node exposed this issue I had all along.
judas
Posts: 572
Joined: Thu Jun 02, 2005 11:26 pm
Location: Bogotá, Colombia
Contact:

Post by judas »

may be caused by this?
3990 Fixed auto-organize sometimes removes '.' from path unnecessarily
Cheers, judas
gege
Posts: 864
Joined: Tue Sep 05, 2006 2:10 pm
Location: Brazil
Contact:

Re: RC3 - Dead links where filename includes '.' or ampers

Post by gege »

joejoe wrote:I guess I need to do a rescan and rename.
Not really:
- Just go to "Files to Edit > Dead Links";
- Select them all;
- Click "File > Locate Moved/Missing Tracks...";
- Select the folder/drive where your tracks are located and press OK.
Post Reply