Gapless WMA playback

Any ideas about how to improve MediaMonkey? Let us know!

Moderator: Gurus

chrisjj
Posts: 4933
Joined: Wed Feb 14, 2007 5:14 pm
Location: UK

Gapless WMA playback

Post by chrisjj »

MM here (Pentium 4 3.20 GHz, 1.00 GB of RAM) suffers a delay of about 1s in starting each WMA track playing, causing a gap between tracks. It would be nice if MM's performance was as good as that of Windows Media Player V9 which here has more like 0.1s delay on the first track and no perceptible gap between subsequent ones.

Thanks.
Chris
Bex
Posts: 6316
Joined: Fri May 21, 2004 5:44 am
Location: Sweden

Post by Bex »

Advanced Duplicate Find & Fix Find More From Same - Custom Search. | Transfer PlayStat & Copy-Paste Tags/AlbumArt between any tracks.
Tagging Inconsistencies Do you think you have your tags in order? Think again...
Play History & Stats Node Like having your Last-FM account stored locally, but more advanced.
Case & Leading Zero Fixer Works on filenames too!

All My Scripts
chrisjj
Posts: 4933
Joined: Wed Feb 14, 2007 5:14 pm
Location: UK

Post by chrisjj »

Thanks Bex.

Others might like to know that steps #6 and 7 are not needed.
Chris
Steegy
Posts: 3452
Joined: Sat Nov 05, 2005 7:17 pm

Post by Steegy »

It is needed sometimes... if the files themselves aren't completely cut correctly.
Extensions: ExternalTools, ExtractFields, SongPreviewer, LinkedTracks, CleanImport, and some other scripts (Need Help with Addons > List of All Scripts).
chrisjj
Posts: 4933
Joined: Wed Feb 14, 2007 5:14 pm
Location: UK

Post by chrisjj »

Silence within the track is not part of the gap.
Chris
chrisjj
Posts: 4933
Joined: Wed Feb 14, 2007 5:14 pm
Location: UK

Post by chrisjj »

Whoops! Others be warned: on short tracks here, that tweak messes up the position slider, puts the Now Playing highlight way out of sync, and breaks Next/Prev!

I stand by my original wish for better MM performance ;) I really think MM has a problem here. E.g. Nexting MP3s is fast, but with WMAs it is takes about 3x as long... presumably due to the chunk of HD access I hear, not present for MP3s. This really slows things down.

Devs, could it just be a case of MM failing to cache some WMA support file?
Chris
Post Reply