[SOLVED] {FIXED IN 2338} MM5 5.0.0.2336 RC-8 White Screen On Startup

Help improve MediaMonkey 5 by testing the latest pre-release builds, and reporting bugs and feature requests.

Moderator: Gurus

dypsis
Posts: 1271
Joined: Wed Apr 30, 2008 9:51 pm

[SOLVED] {FIXED IN 2338} MM5 5.0.0.2336 RC-8 White Screen On Startup

Post by dypsis »

I just installed MM5 5.0.0.2336 RC-8, and I can't get past a white screen.
It briefly flashes to the normal MediaMonkey screen, then it goes to a white screen and I have to end the tasks in Task Manager.

Edit: I just reverted back to 5.0.0.2333, and all is working OK again.
drakinite
Posts: 425
Joined: Tue May 12, 2020 10:06 am
Contact:

Re: MM5 5.0.0.2336 RC-8 White Screen On Startup

Post by drakinite »

That's no good. Could you help us out and record a debug log when that occurs for you, so we can see what's causing it?
Last edited by drakinite on Fri Apr 16, 2021 8:11 pm, edited 1 time in total.
Image
Student electrical-computer engineer, web programmer, part-time MediaMonkey developer, full-time MediaMonkey enthusiast
Peke
Posts: 14167
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: MM5 5.0.0.2336 RC-8 White Screen On Startup

Post by Peke »

Hi,
can you rename persistent.json and see if that fixes the issue? If yes can you send us renamed one for analyze?
Best regards,
Peke
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum
dypsis
Posts: 1271
Joined: Wed Apr 30, 2008 9:51 pm

Re: MM5 5.0.0.2336 RC-8 White Screen On Startup

Post by dypsis »

Hi guys.

After reverting back to 5.0.0.2333, I just re-installed 5.0.0.2336, then ran MM5 as Administrator and it worked fine.
I then shut it down and ran MM5 normally and it still worked fine.

I don't know whether initially running it as Administrator made any difference or not, but it's working now.
Out of all the numerous versions that I've been testing over the months and years, this is the first time that it's happened to me.

I guess it's good news then. 😀
drakinite
Posts: 425
Joined: Tue May 12, 2020 10:06 am
Contact:

Re: MM5 5.0.0.2336 RC-8 White Screen On Startup

Post by drakinite »

That's kinda interesting, because I'd experienced that same type of unresponsive white screen in previous builds of MM5, but not really recently.

I'm glad it's working for you again. :slight_smile:
Image
Student electrical-computer engineer, web programmer, part-time MediaMonkey developer, full-time MediaMonkey enthusiast
dypsis
Posts: 1271
Joined: Wed Apr 30, 2008 9:51 pm

Re: MM5 5.0.0.2336 RC-8 White Screen On Startup

Post by dypsis »

Yes, I am glad too.
You wouldn't expect a bad bug to be getting introduced this late in the game.
z3huti
Posts: 40
Joined: Mon Apr 05, 2021 7:26 am

Re: MM5 5.0.0.2336 RC-8 White Screen On Startup

Post by z3huti »

Same white screen on startup here with none debug version. Clean portable install.

And with debug version got error at first start.

Image

Not gonna test MM anymore, coz I am not gonna use it anyway. IMO building MM next/around chromium was not a good idea.
IanRTaylorUK
Posts: 108
Joined: Fri Dec 27, 2019 4:41 pm

Re: MM5 5.0.0.2336 RC-8 White Screen On Startup

Post by IanRTaylorUK »

Normal install - no problem.

Portable install - white screen until set to Run As Admin as per previous suggestion.
Ian Taylor
MM4W 4.1.29.1919 (Portable 12Feb2021) on Windows 10 Pro 64 Bit (v20H2 Build 19042.928)
Add-Ons:Export / Import Playlists for Child Nodes; Magic Nodes; RegExp Find and Replace; Tagging Inconsistencies
Music library of 32,483 files backed up to OneDrive
MMA 1.4.4.0952 on Sony Xperia XZ with Android 8 & ~14,167 Tracks
MMA 1.4.4.0952 on Samsung Tab S5e with Android 9 & ~14,167 Tracks
Android Devices synchronised with MM4W using USB
Trying MM5W 5.0.0.2401 (Portable & Normal 29Apr2021) on same Windows 10 a copy of media files (and separate library for each version / type installation!)
djasonpenney
Posts: 15
Joined: Tue Jul 05, 2011 8:48 pm

Re: MM5 5.0.0.2336 RC-8 White Screen On Startup

Post by djasonpenney »

Confirming same issues with 5.0.0.2336. After running the COM elevator, the screen is white. Disabling the COM elevator makes the main window look better, but none of the buttons work, and Windows identifies the app is hung.

NON-portable install.

Debug version is better at identifying it's in trouble; debug logs have presumably been sent.
drakinite
Posts: 425
Joined: Tue May 12, 2020 10:06 am
Contact:

Re: MM5 5.0.0.2336 RC-8 White Screen On Startup

Post by drakinite »

Thank you all for helping confirm the issue. Tracked as: https://www.ventismedia.com/mantis/view.php?id=17770
z3huti wrote: Sat Apr 17, 2021 6:53 am Not gonna test MM anymore, coz I am not gonna use it anyway. IMO building MM next/around chromium was not a good idea.
I'm sorry that you've had a bad experience so far. It's true that some builds are hopelessly unstable, because sometimes when you fix one bug, another huge bug appears. Again, thank you all for helping catch these issues. Just remember that it's still in beta, and we're not claiming any builds as stable yet. I hope that you can change your mind about using MM5 in the near future, when we have stable builds.
Image
Student electrical-computer engineer, web programmer, part-time MediaMonkey developer, full-time MediaMonkey enthusiast
sdunnin
Posts: 4
Joined: Sat Sep 11, 2010 1:31 am

Re: MM5 5.0.0.2336 RC-8 White Screen On Startup

Post by sdunnin »

Same issue for me with 2336. Installed as normal (non portable) and imported MM4 database. Briefly opens UI and after a couple of seconds reverts to white screen. Let me know if there is any additional info that I can send to help out.
drakinite
Posts: 425
Joined: Tue May 12, 2020 10:06 am
Contact:

Re: MM5 5.0.0.2336 RC-8 White Screen On Startup

Post by drakinite »

Does it occur only *after* a "MediaMonkey COM elevator" prompt appears?
Image
Student electrical-computer engineer, web programmer, part-time MediaMonkey developer, full-time MediaMonkey enthusiast
sdunnin
Posts: 4
Joined: Sat Sep 11, 2010 1:31 am

Re: MM5 5.0.0.2336 RC-8 White Screen On Startup

Post by sdunnin »

drakinite wrote: Sat Apr 17, 2021 3:48 pm Does it occur only *after* a "MediaMonkey COM elevator" prompt appears?
Yes, that appears to be the case. If I respond 'No' to the elevator the UI will load but is totally unresponsive. Responding 'Yes' leads to the white screen.
nauip
Posts: 36
Joined: Sat Nov 19, 2011 2:46 pm

Re: MM5 5.0.0.2336 RC-8 White Screen On Startup

Post by nauip »

I've just done a new install of MM 5.0.0.2336 non-portable (the system has never seen MM, any version, before) and I get the white screen of blank-do-nothingness immediately upon launch. There is a brief moment where I see there is something to configure but it disappears so quickly. I think it's asking about configuring my library.

There is no elevate prompt as I have never notify enabled. So for fun I set it to default and I see the same if I click Yes or no window or an incomplete window when I click No.

On my Daily Driver PC that has gone through many, many versions of MM I do not see this.
Ludek
Posts: 3911
Joined: Fri Mar 09, 2007 9:00 am

Re: MM5 5.0.0.2336 RC-8 White Screen On Startup

Post by Ludek »

Thanks for reporting, we posted 5.0.0.2337 RC-8 update today with the fix: viewtopic.php?p=480432#p480432
Post Reply