G4 Marshmallow: no playback from SD-Card [#13063][#13130]

Report bugs & feature requests for MediaMonkey for Android and learn about the newest beta build.

Moderator: Gurus

icon
Posts: 31
Joined: Sun Nov 22, 2009 6:21 am

G4 Marshmallow: no playback from SD-Card [#13063][#13130]

Post by icon »

I've just got the Android 6 Update on my LG G4. My files resides on the SDcard in the standard folders (/music /playlist ...). Befor the update, everything was fine, after the OS update, MM asked for permission to external SD card, which I granted. It shows me all files and playlists, however, when I try to play a song, nothing happens. I've already un-/reinstalled MediaMonkey.

I've sent you a debug log, however can no longer see the ID, it was sent a few minutes ago

Regards
Renato
rusty
Posts: 7363
Joined: Tue Apr 29, 2003 3:39 am
Location: Montreal, Canada

Re: After Marshmallow Update on G4, no playback from SD-Card

Post by rusty »

Thanks. Tracked at:
http://www.ventismedia.com/mantis/view.php?id=13095

btw, if you try to access content on the sd card with other apps (e.g. via ES Explorer), do you have any trouble?

Also, are you able to navigate the SD Card via MMA > Folders > Files > SD card ?

-Rusty
icon
Posts: 31
Joined: Sun Nov 22, 2009 6:21 am

Re: G4 w/ Marshmallow update: no playback from SD-Card [#130

Post by icon »

Hi Rusty

Absolutely no problem with File explorer or other music apps.
Now, i've tried to navigate through MMA folder option and i was able to play songs this way!

So I assumed, it could be a problem with the playlists. So I've did a Wifi sync with my pc, but then MM startet to sync all files again to internal folder and not sdcard :/

Let me know if you need any further infos for tracking this problem.

Regards
Renato
bhiefer
Posts: 168
Joined: Fri Apr 12, 2013 6:36 am

Re: G4 w/ Marshmallow update: no playback from SD-Card [#130

Post by bhiefer »

The path to storage was changed after upgrade to 6.0. Unfortunately MMA didn't recognize this change and the tracks behave as on unmounted card - the path is still old and invalid.

We are working on fix that will properly update all paths after upgrade. As workaround, you can remove all tracks and resync :(

It looks like 13095 but it is tracked as:
http://www.ventismedia.com/mantis/view.php?id=13063
icon
Posts: 31
Joined: Sun Nov 22, 2009 6:21 am

Re: G4 w/ Marshmallow update: no playback from SD-Card [#130

Post by icon »

bhiefer wrote:The path to storage was changed after upgrade to 6.0. Unfortunately MMA didn't recognize this change and the tracks behave as on unmounted card - the path is still old and invalid.

We are working on fix that will properly update all paths after upgrade. As workaround, you can remove all tracks and resync :(

It looks like 13095 but it is tracked as:
http://www.ventismedia.com/mantis/view.php?id=13063
Okey, but it doesn't fix it temporary to remove the files and re-sysnc, becaues MM does no longer store them on the SDCARD\MUSIC folder but on the program internal MUSIC folder an d this means, only MM can access it afterwards. So it seems MM has lost the ability again to write fully to the SDCARD.

So I wait for a fix then :)

Regards
bhiefer
Posts: 168
Joined: Fri Apr 12, 2013 6:36 am

Re: G4 w/ Marshmallow update: no playback from SD-Card [#130

Post by bhiefer »

You said you granted the permission so it should write to /SDCARD/Music folder. Could you please add e.g. one album to your synclist, start wifi sync and then immediately send me the log as soon as the sync finishes?
icon
Posts: 31
Joined: Sun Nov 22, 2009 6:21 am

Re: G4 w/ Marshmallow update: no playback from SD-Card [#130

Post by icon »

bhiefer wrote:You said you granted the permission so it should write to /SDCARD/Music folder. Could you please add e.g. one album to your synclist, start wifi sync and then immediately send me the log as soon as the sync finishes?
Hi bhiefer

I just uninstalled MM Beta and installed new Build 1.1.3.550
After the initial start, MM showed the confirmation dialog for SDCARD access, where I proceded.
Then MM crashed immediately, I think it has sent the internal debug log automaticaly, however i've also reported via standard android crash reporting

I've anyway proceeded:
i did a sync with 10 files in one playlist
it copied the files to the right folder SDCARD\MUSIC
What is a bit strange is, that I still see all old Playlist (which I removed to to this test) in MM, but not in the standard music player of LG.
I did a "Check for new/changed media" in MM, but it still shows old playlists. I've created a manual debug log, maybee you see something in there (OLVILWHLJH).

Regards
rusty
Posts: 7363
Joined: Tue Apr 29, 2003 3:39 am
Location: Montreal, Canada

Re: G4 w/ Marshmallow update: no playback from SD-Card [#130

Post by rusty »

Hi Renato (icon),

Build 551 should fix the crash that you experienced immediately after granting access to the SD card. Can you uninstall MMA again and then install build 551? That way we can be sure that access permissions to the SD card have been properly granted/configured.

Thanks.

-Rusty
icon
Posts: 31
Joined: Sun Nov 22, 2009 6:21 am

Re: G4 w/ Marshmallow update: no playback from SD-Card [#130

Post by icon »

rusty wrote:Hi Renato (icon),

Build 551 should fix the crash that you experienced immediately after granting access to the SD card. Can you uninstall MMA again and then install build 551? That way we can be sure that access permissions to the SD card have been properly granted/configured.

Thanks.

-Rusty
Hi Rusty

I've uninstalled Build 550 and installed 551 and yes, it fixed the crash while grant the permisssion. Also synch is working over wifi.
However since 2 or 3 build, I have another nasty issue/bug: 95% of my album art (embedded) is NOT shown in MM

Let me know, if and what information i can give you regarding this bug with album art.

Regards
bhiefer
Posts: 168
Joined: Fri Apr 12, 2013 6:36 am

Re: G4 Marshmallow: no playback from SD-Card [#13063][#13130

Post by bhiefer »

Yes we know about this regression with artworks in Marshmallow, it is already fixed in 551...but resync is needed :(. Let me know...
icon
Posts: 31
Joined: Sun Nov 22, 2009 6:21 am

Re: G4 Marshmallow: no playback from SD-Card [#13063][#13130

Post by icon »

For me its not fixed in build 551.I did a fresh install and resynced everything but still have most artwork not displayed.
icon
Posts: 31
Joined: Sun Nov 22, 2009 6:21 am

Re: G4 Marshmallow: no playback from SD-Card [#13063][#13130

Post by icon »

Also Build 554 still not showing most Artwork.
bhiefer
Posts: 168
Joined: Fri Apr 12, 2013 6:36 am

Re: G4 Marshmallow: no playback from SD-Card [#13063][#13130

Post by bhiefer »

That is strange. So you have cleared and resynced the library completely? Because otherwise MMA doesn't know (due to bug in previous few builds) that the artwork is wrong.

If it won't help, may I ask you to do following ?

1. delete one album with invalid artworks
2. do wifi sync
3. artworks are still invalid for this album? So please send another log immediately.

Thank you for your help!
icon
Posts: 31
Joined: Sun Nov 22, 2009 6:21 am

Re: G4 Marshmallow: no playback from SD-Card [#13063][#13130

Post by icon »

bhiefer wrote:That is strange. So you have cleared and resynced the library completely? Because otherwise MMA doesn't know (due to bug in previous few builds) that the artwork is wrong.

If it won't help, may I ask you to do following ?

1. delete one album with invalid artworks
2. do wifi sync
3. artworks are still invalid for this album? So please send another log immediately.

Thank you for your help!
Hi

I did so many tests, reinstalls etc the past day - especially regarding the first problem with writing to SD Card - that I can not say, when exactly I deleted and resynced.

So I will do again a complete test soon: removing library and resync and let you afterwards know, if the problem with album art is fixed definitevly.

Thanks for you patience

Regards
icon
Posts: 31
Joined: Sun Nov 22, 2009 6:21 am

Re: G4 Marshmallow: no playback from SD-Card [#13063][#13130

Post by icon »

So I tried to check, if album art issue is fixed and run into many other issues:

- Uninstalled MM on the device, assuming that it will remove all data (database)
- Reinstalled
- Immediately after reinstalling, I already had all playlists visible in MM. How is this possible without synchronyzing?
- I have some playslists twice, and most playlist have not all songs (eg 71 on device, but there are 1283 songs in the list)
- When I do a sync, some playslist are still twice and the others still have not all songs
- So I removed the playlists from the device and did a resysnc, it then copied the same wrong playslists again.

So i am stucked, whats going on now. It looks, that MM has a completely wrong database on the device. How can I get remove it? I think it should be deleted, when I uninstall MM, but this strangly seems not to be the case.

I sent a debug log RCSTB9VIRY shortly after a fresh install, when MM aleady displays doubled and wrong playlists, without any physical playlist and mp3 on the phone.
Post Reply