Click/tick sound between songs

Report bugs & feature requests for MediaMonkey for Android and learn about the newest beta build.

Moderator: Gurus

pogosama
Posts: 9
Joined: Wed Jun 18, 2014 12:45 pm

Click/tick sound between songs

Post by pogosama »

Every time MediaMonkey plays a new song I hear inbetween songs a click or a tick sound, in both cases when I clicked on fast forward explicitly or when the previous song ends and a new song begins automatically.

I have Sony Xperia Z1 Compact with Android KitKat (4.4.x) and the latest MMA beta installed (1.0.6.0292).

I think this should be fixed when gapless playback or crossfade feature is added. Is there a plan yet to implement the crossfade feature? I like this feature and it's always enabled in my MM PC version.
pogosama
Posts: 9
Joined: Wed Jun 18, 2014 12:45 pm

Re: Click/tick sound between songs

Post by pogosama »

So I just installed the latest beta (1.1.0.0330) with the gapless playback feature. But when I press forward the click/tick/pop sound is still there. It's as if the current audio channel/file is closed and a new one is opened. Does this only happen on my phone type?
rusty
Posts: 7418
Joined: Tue Apr 29, 2003 3:39 am
Location: Montreal, Canada

Re: Click/tick sound between songs

Post by rusty »

Hi,

I tested playback in build 330 on 2 Nexus devices and don't notice any such clicks between tracks (I tested MP3/OGG/FLAC, Volume Leveling on/off, output to headset/bluetooth).

For each report of this issue, can you confirm:
1) What device you're using / Android version / MMA version ?
2) What audio formats experience this problem ?
3) Have the tracks been auto-converted when they were synced ?
4) Is it specific to any view or other situation?

Thanks.

Note: dtsig related a similar problem at http://www.mediamonkey.com/forum/viewto ... 21&t=78129
1) Device S5, Android 4.4.4, MMA 1.0.7.311
2) ?
3) ?
4) Occurred only when playing in Album view

My guess is that that particular album was encoded in a certain way that resulted in the problem (i.e. could be that the problem is specific to certain formats on certain devices, or an auto-conversion problem).

-Rusty
pogosama
Posts: 9
Joined: Wed Jun 18, 2014 12:45 pm

Re: Click/tick sound between songs

Post by pogosama »

Correction: Since the gapless playback feature is implemented the sound is gone during continuous play (when the current song goes automatically to the next song). So only when I specifically press Forward or Backward.

1) Device: Xperia Z1 Compact, Android 4.4.4, MMA beta 1.1.0.330
2) Audio format: MP3 only, output through the audio jack to speakers/headset
3) During sync the file is just copied to my device, no conversion
4) Only when I press Forward/Backward inside the app or through the widget, view doesn't matter. Maybe the gapless playback feature isn't enabled in this case? The sound happens when the next song is about to be played, not during the pressing of the Forward button.

Note: The pop sound is less audible when using the headset. On speakers it's more audible.
rusty
Posts: 7418
Joined: Tue Apr 29, 2003 3:39 am
Location: Montreal, Canada

Re: Click/tick sound between songs

Post by rusty »

I still can't replicate this by pressing 'Next' or 'Previous'. Perhaps it's device-specific.

Anyone else experiencing this?

-Rusty
pogosama
Posts: 9
Joined: Wed Jun 18, 2014 12:45 pm

Re: Click/tick sound between songs

Post by pogosama »

Yeah looks like it. Anyway I'm happy that the gapless feature is finally implemented. Keep up the good work!
dtsig
Posts: 3374
Joined: Mon Jan 24, 2011 6:34 pm

Re: Click/tick sound between songs

Post by dtsig »

rusty wrote:Hi,

I tested playback in build 330 on 2 Nexus devices and don't notice any such clicks between tracks (I tested MP3/OGG/FLAC, Volume Leveling on/off, output to headset/bluetooth).

For each report of this issue, can you confirm:
1) What device you're using / Android version / MMA version ?
2) What audio formats experience this problem ?
3) Have the tracks been auto-converted when they were synced ?
4) Is it specific to any view or other situation?

Thanks.

Note: dtsig related a similar problem at http://www.mediamonkey.com/forum/viewto ... 21&t=78129
1) Device S5, Android 4.4.4, MMA 1.0.7.311
2) ?
3) ?
4) Occurred only when playing in Album view

My guess is that that particular album was encoded in a certain way that resulted in the problem (i.e. could be that the problem is specific to certain formats on certain devices, or an auto-conversion problem).

-Rusty
Sorry .. been out after knee replacement surgery ..
1) It wasn't just 1 album but any album i was playing .. all encoded at different times (sometimes over years)
2) hadn't had the problem before getting the S5
3) I have not seen the problem in recent releases (currently at 335)

Thanks
Where's the db and ini stored
Reporting Bugs
Where tags are stored

Not affiliated with MediaMonkey ... just a RABID user/lover
DTSig
Peke
Posts: 13972
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: Click/tick sound between songs

Post by Peke »

There i salways good practice to load affected track in any Audio Editor like audiocity, wavosaur, ... and see if there is peak at audio start/end

Even 10ms peak can be heard.
Best regards,
Peke
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum
pogosama
Posts: 9
Joined: Wed Jun 18, 2014 12:45 pm

Re: Click/tick sound between songs

Post by pogosama »

Just to clarify: It's not only on certain tracks but all tracks, when I pressed on next or previous manually. I also check my tracks on a wav editor before adding it to my library, saw no peaks at start/end.

Doing the same on MMW doesn't result on the click sound.
rusty
Posts: 7418
Joined: Tue Apr 29, 2003 3:39 am
Location: Montreal, Canada

Re: Click/tick sound between songs

Post by rusty »

Hi,

Do you have a second Android device on which you can try this out with the tracks in question? I'm curious if perhaps the issue is specific to your device.

But if it occurs on others, can you send me a PM with links to a couple of sample files?

btw, another possibility is that the tracks were auto-converted and the converted format is resulting in this problem. Might that be the case?

Thanks.

-Rusty
pogosama
Posts: 9
Joined: Wed Jun 18, 2014 12:45 pm

Re: Click/tick sound between songs

Post by pogosama »

I don't have another device, but I tried several other players. Some of them also gave the tick sound. Players that have cross-fading don't have this issue, so you can guess what my next feature request is :) (I think it's already a request in the issue tracker).

Also I already checked my files on the phone, they're 1:1 copy from the one from my PC because I turned off the conversion during sync.

But anyway, I now use Bluetooth to play music in my car: no clicks heard when pushing next so far!
rusty wrote:Hi,

Do you have a second Android device on which you can try this out with the tracks in question? I'm curious if perhaps the issue is specific to your device.

But if it occurs on others, can you send me a PM with links to a couple of sample files?

btw, another possibility is that the tracks were auto-converted and the converted format is resulting in this problem. Might that be the case?

Thanks.

-Rusty
rusty
Posts: 7418
Joined: Tue Apr 29, 2003 3:39 am
Location: Montreal, Canada

Re: Click/tick sound between songs

Post by rusty »

I think I'll have to get an Xperia Z1 compact to test this out--just an excuse for me to get that phone :-)

If anyone else observes this issue, _please_ report what device it occurs on. Thanks.

-Rusty
Guest

Re: Click/tick sound between songs

Post by Guest »

Some additional info. The audible tick is happening with my new Galaxy Note 4. Previously used a galaxy s3 and there was no audible tick between tracks.

The tracks have not been changed or re-encoded.

Mediamonkey for android 1.0.7.0311.

I tried rocket player, and I still hear the audible tick. Seems like it is device dependent. Will need to play around in the settings to see if the is a fix.
Guest

Re: Click/tick sound between songs

Post by Guest »

Follow up to the Note 4 comment.

When using my car adapter with the headphone jack, I am hearing the pop before and after every audio tone. This includes notification sounds, and even the beep when adjusting the volume. Perhaps it is when the audio amp is switching on and off?

Some other forums talk about turning OFF touch audio feedback or turning power saving mode OFF. Neither of those settings made any difference with my problem.

Tried it with built in speaker, no pops. Tried it with headphones, no pop. Only hear it when I plug it into my car using the headphone jack.

Since the headphones and the car adapter use the same connection (headphone jack), I am not sure why I am seeing different behavior. Will check some more tonight when I get back to the car. Maybe the car adapter plug does not fully engage, due to case interference or plug problem? I did unplug and reinsert it and that did not fix the pop, but I was not paying close attention.

If it is because the audio amp is turning on/off, the fix seems fairly simple. Just don't ever stop sending an audio signal. The signal could be very low level, just as long as it keeps the jack "on" all the time. That would avoid the switching pops. It seems like a lot of people want a crossfade option. That seems like it might be another way to fix it.
Guest

Re: Click/tick sound between songs

Post by Guest »

Did a more thorough check last night and this morning with my new Galaxy Note 4 .

In my case, it does not seem to be a MediaMonkey for Android issue, but something specific to Android, the Samsung software or the hardware. Really narrowing it down, aren't I. :)

For me, there is ALWAYS an audible tick or pop whenever a sound starts or stops playing. This audible tick/pop is present in in the headphone jack AND the built-in speaker. I hear it anytime a sound is played. This even includes adjusting the volume. Pressing the volume up button will result in a tick/pop, then the volume beep, then after about 1 second, another tick/pop. If I continue to press the button within 1 second, I don't hear the tick/pop. But, 1 second after the last press, I hear the tick/pop.

Again, this is audible with the built-in speaker and the headphone jack.

Last night and this morning, the tick/pop was very quiet, but for whatever reason, yesterday morning, it was very loud and intrusive.

Seems related to the audio output turning on/off. Even though it does not seem to be MMA's problem, MMA could mitigate this by adding a pad onto the end of every played track that would keep the audio outputs from turning off. Don't know how long the pad needs to be, probably dependent on individual preferences. For skipping tracks, the pad could be very short, less than 1 second. But, it might be beneficial to have an option for a longer pad if someone does a lot of stopping and starting of tracks.

Either way, MMA and MediaMonkey for Windows is definitely the best solution I have found for syncing my music and podcasts, which is why I paid my money. There are definitely some areas that could be improved (handling of podcasts comes to mind), but overall, good stuff.
Post Reply