Samsung Galaxy S3 sync

Get answers about syncing the current release of MediaMonkey with iPods and other devices.

Moderator: Gurus

schwinn8
Posts: 17
Joined: Thu Aug 30, 2012 4:02 pm

Re: Samsung Galaxy S3 sync

Post by schwinn8 » Wed Dec 19, 2012 7:37 pm

Turns out, I was using 4.0.6.1501 all this time. It worked, though it wasn't fast. I uploaded the log anyway. (Ticket JOK-422444)

I also collected a log from a portable install for beta 4.1.0.1614. This version has all kinds of other issues, and lags even just starting up. It detected my phone as an "S2" and then scanned and completed in a reasonable time. But when I tried to select a playlist for syncing, it then locked up hard and that was that. I will upload that log file next.

Note, during the logging, I saw some mention of "fatal error" as well. 1614 clearly has major problems.

1614's ticket = LPT-933665

schwinn8
Posts: 17
Joined: Thu Aug 30, 2012 4:02 pm

Re: Samsung Galaxy S3 sync

Post by schwinn8 » Thu Dec 20, 2012 9:04 am

Buruan wrote:
schwinn8 wrote:I have collected the log, and still need to send it in (it's o a different computer. Briefly, what I see is that the scan is fast, until it hits the first .pla file. From there, it takes 4 seconds per song. This is with the release version of the software, which worked ok for me until now (4.0.7.1511 I believe)
A few related questions:
Is there a way to cancel the scan cleanly? I don't want to wait hours for the scan to finish, but there seems to be no way for me to quit out. Ending the task causes problems, requiring me to reboot winows (xp).
Is there a lift of BKPs (best known practices) for this device? I don't want to rehash known/solved problems for no reason.
Fyi, Samsung has newer drivers for MTP than what I had before. These didn't help the problem.

This is exactly how it manifests for me as well on an AT&T S3 with Jelly Bean 4.1.1
It is faster for me to simply wipe my SD card and transfer all songs (~10k) than use the synch function.
I have sumbitted logs on the above, but have not been able to restest with the latest MMW build.
I have tried all drivers i can find, with no improvement on any end.

I do second the request for Terminating the scan cleanly. Currently the only way is to unplug the device, Kill MMW via Task Manager and reboot.

It never worked well, but the problems have gotten worse with the 4.1 builds.
Now many times when i try to synch, it doesnt identify prior synchs and wants to re-synch the entire library again....
I also have a S2, will try to test with this one to see if there are differences.

MMA currently doesnt work for me either (separate thread in the MMA forum) as it doesnt recognize the SD card vs. Phone Memory properly....

I am one more setback away from rooting the S3 to be able to use it in UMS mode.
The weird thing for me is that in my case, I apparently have been using 4.0.6 all this time, and it functioned. Only recently has my wife's pbone had the scanning problem. Very weird.

I also think I may have a bad usb port on my tower case. XP doesn't seem to recognize mtp there, but it does on other ports. Of course, this doesn't fix these syncing issues either.

Buruan
Posts: 96
Joined: Sun Nov 04, 2012 6:26 pm

Re: Samsung Galaxy S3 sync

Post by Buruan » Thu Dec 20, 2012 10:56 am

For me it was always this slow, but 4.0.7 it worked as it should.

With 4.1. it is simply not going anywhere, I connect the device the entire OS comes to a grinding halt for 5 minutes, then it doesnt identify prior synchs, and always wants to re-synch all songs.
Trying to open the device configuration page from the library browser also takes over a minute.

Lowlander
Posts: 47362
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Samsung Galaxy S3 sync

Post by Lowlander » Thu Dec 20, 2012 11:35 am

Capture this in a debug log (step 4b) and send it to support so the developers can look into fixes this: http://www.mediamonkey.com/forum/viewto ... ?f=6&t=341
Lowlander (MediaMonkey user since 2003)

schwinn8
Posts: 17
Joined: Thu Aug 30, 2012 4:02 pm

Re: Samsung Galaxy S3 sync

Post by schwinn8 » Sat Dec 22, 2012 7:33 am

Just tested 4.0.7.1511, to see if that improves the problem (I had hopes since the fix-list mentions Android and PLA issues were fixed.) Unfortunately, this behaves the same as 4.0.6.1501.

Log file generated, ticket GRW-178392 created.

schwinn8
Posts: 17
Joined: Thu Aug 30, 2012 4:02 pm

Re: Samsung Galaxy S3 sync

Post by schwinn8 » Sat Dec 22, 2012 6:30 pm

Found something interesting. I disabled the option to "Scan when connected", and then connected the phone. From here, it manually scanned when I clicked on the storage location (ie "SCH-I535 Card"). Interestingly enough, this was actually the card, which was good to see.

More importantly, scanning the device, though it's still slow, it worked better. It didn't take 4-seconds per song, and didn't stall on the PLA as it had before. At least that's nice to see.

The bad news is that sync still doesn't work. It tries to sync everything again (even after "seeing" all the songs on the device).

Worse yet, now MM won't even transfer songs to the device. Basically, I tried to transfer some new albums over with "Send To" and all I got was errors for all of them. Nothing actually transferred.

Updated the original JOK-422444 ticket with this information, and the log file from it.
Last edited by Lowlander on Sun Dec 23, 2012 3:12 pm, edited 1 time in total.
Reason: Language

Lowlander
Posts: 47362
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Samsung Galaxy S3 sync

Post by Lowlander » Sun Dec 23, 2012 3:11 pm

schwinn8 wrote:Just tested 4.0.7.1511, to see if that improves the problem (I had hopes since the fix-list mentions Android and PLA issues were fixed.) Unfortunately, this behaves the same as 4.0.6.1501.
Did you remove the Device Profiles? Only then will it behave differently for the S3, S2 users will need to upgrade to MediaMonkey 4.1 (in beta) and also remove existing Device Profiles.
schwinn8 wrote:and all I got was errors for all of them.
What do the errors state?
Lowlander (MediaMonkey user since 2003)

schwinn8
Posts: 17
Joined: Thu Aug 30, 2012 4:02 pm

Re: Samsung Galaxy S3 sync

Post by schwinn8 » Sun Dec 23, 2012 4:55 pm

Device profiles: yes, I deleted those with each revision I tried.

The errors were access denied issues. That being said, I ran into that same issue when copying music to a flash drive. In that case, I saw that MM decided to add the copied files to the library, which then couldn't find the songs when the device was removed. I don't understand why it added these to the library, but when I removed the copied files from the library, the proper files were identified and available. Again, it doesn't make sense to add copied files to the library.

Lastly, I used Winamp to see if I could copy files with that. It sent files via wifi with zero issues. At least I have the songs transferred, but I don't understand why MM is having so much trouble. Sad, to say the least.

Lowlander
Posts: 47362
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Samsung Galaxy S3 sync

Post by Lowlander » Sun Dec 23, 2012 5:07 pm

How did you copy the files to the flash drive?

You can use MediaMonkey for Windows 4.1 with MediaMonkey for Android to do WiFi sync from MediaMonkey (both in beta).
Lowlander (MediaMonkey user since 2003)

schwinn8
Posts: 17
Joined: Thu Aug 30, 2012 4:02 pm

Re: Samsung Galaxy S3 sync

Post by schwinn8 » Sun Dec 23, 2012 6:43 pm

File copy was being done by MM (send to).

I have read that MM for Android can do wifi, but others in this thread said it isn't quite there. Since MM 4.1 won't run properly in the first place (see my experience above) I can't even begin to go down that road. Again, note that others are reporting issues with 4.1 too...

Lowlander
Posts: 47362
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Samsung Galaxy S3 sync

Post by Lowlander » Mon Dec 24, 2012 12:21 pm

I'm not aware that anyone had MediaMonkey 4.1 grind to a halt so you should create a debug log for that and send it to support.
Lowlander (MediaMonkey user since 2003)

Buruan
Posts: 96
Joined: Sun Nov 04, 2012 6:26 pm

Re: Samsung Galaxy S3 sync

Post by Buruan » Wed Dec 26, 2012 10:31 am

I have the same issue and submitted a log.

Given that this is one of the most popular phones out there, I am really surprised not more people have the same issue.

Being a iphone convert, and *mostly* using the device as a music player, it is somewhat frustrating to see how well this works on the Apple side, and how tedius it is on the Samsung side...

Again, I dont think its solely MM's fault, it seems the entire USB support for the S3 is, bluntly said, crap.

Though I do hope once 4.1 is stable that it gets back to synching properly, even if tediously slow.....

schwinn8
Posts: 17
Joined: Thu Aug 30, 2012 4:02 pm

Re: Samsung Galaxy S3 sync

Post by schwinn8 » Fri Dec 28, 2012 10:38 am

Since Buruan has already submitted, I won't bother collecting data again. Note that my crash did trigger an email to "wherever" about the crash, so you should have it already.

That being said, I tried the sync again in 1614, and I let it finish everything before continuing to do anything in the program. A few problems I noticed immediately:
1) "Scanning" keeps showing on the device, even if Debugview shows no real activity. I see it's doing SOMETHING, because I see folder names from the device go by, but it takes about 15 seconds for each folder, so it's going quite slow.
2) Deleted the "Card" profile, but it won't let me delete the "Phone" profile
3) Both are still detected as Galaxy S2 (this is a S3)... not a big deal, but still
4) When scanning finally finished on the card, I clicked over to the phone, and then could not get back to the card "page" as it was scanning... so I had to wait until that was done. 20 minutes of just waiting around for scanning... yeesh.
5) I noticed afterwards, when it got near the end of the "scanning" time on the card, that it finally recognized my files as "Music"... and not "Other"... though it still wanted to sync ALL 13.9GB of songs over again?! I did not want to waste anymore time on this, so I stopped here...

I have logs for this, if you really want them...

Aralvor
Posts: 88
Joined: Fri Jan 04, 2013 10:32 am

Re: Samsung Galaxy S3 sync

Post by Aralvor » Fri Jan 04, 2013 11:04 am

replying to get notifications, i've got some of the problems described here too..

hope it gets resolved, i'm starting to miss my iphone sync :/

rovingcowboy
Posts: 14162
Joined: Sat Oct 25, 2003 7:57 am
Location: (Texas)
Contact:

Re: Samsung Galaxy S3 sync

Post by rovingcowboy » Fri Jan 04, 2013 11:10 am

Aralvor wrote:replying to get notifications, i've got some of the problems described here too..

hope it gets resolved, i'm starting to miss my iphone sync :/
glad to have you join in the mm forum.

just so you know though you don't have to post to get notified of replys.
in the bottom of the thread page you will see a subscribe switch just click it and you will be subscribed to get notified of that thread.

but your always welcome to post 8)
roving cowboy / keith hall. My skins http://www.mediamonkey.com/forum/viewto ... =9&t=16724 for some help check on Monkey's helpful messages at http://www.mediamonkey.com/forum/viewto ... 4008#44008 MY SYSTEMS.1.Jukebox WinXp pro sp 3 version 3.5 gigabyte mb. 281 GHz amd athlon x2 240 built by me.) 2.WinXP pro sp3, vers 2.5.5 and vers 3.5 backup storage, shuttle 32a mb,734 MHz amd athlon put together by me.) 3.Dell demension, winxp pro sp3, mm3.5 spare jukebox.) 4.WinXp pro sp3, vers 3.5, dad's computer bought from computer store. )5. Samsung Galaxy 5 Android 5) 6. amd a8-5600 apu 3.60ghz mm version 4 windows 7 pro bought from computer store.

Post Reply