Flac/Sqrsoft

Post a reply

Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: Flac/Sqrsoft

Re: Flac/Sqrsoft

by Peke » Sun Aug 01, 2021 4:40 pm

Hi,
MM is moving off Winamp infrastructure to more multi platform functionality and SQR is really old (I bought and used it along SQR ACF in late 90s and early 00's).

Here is how I use now:
1. I created Specific Collections that lists all of my Jingles (Mix of Genre [Radio Jingle], length, Artist, ...), another one with all my ads/promotions/commercials/... (with similar criteria for collection)
2. Selected all tracks in those collections -> Properties -> Changed Type to "Video Podcast" (I choose that as I do not have them and that type have Crossfading disabled.
3. Now when I put my radio Jingle in between two tracks it does not crossfade, but tracks (Music) crossfade normally

Now I can easily access those files only directly in dedicated collections.

True MM crossfading algorithm should be configurable like in SQR (one and only that filly worked correctly is set correctly), but it is outdated. I have added quick feature to MM Playback rules options https://www.ventismedia.com/mantis/view.php?id=18181 to partially address that.

Unfortunately SQR also works clunky on newer Sound cards and 24Bit output. Too bad as it was/is the greatest output plugin ever made.

Flac/Sqrsoft

by typecrazy789 » Sun Aug 01, 2021 1:16 pm

I've posted recently about my journey trying to get LMS (to use MusicIP/Spicefly Sugarcube) to the old SqrSoft crossfader. The Foobar2k one won't crossfade anything less than 12 seconds, and for the online radio station I'm trying to put together, I need to do quick segues.

I'd had the epiphany a month or so ago that using a bridge into MM5 might work since it could load the old (and I mean 20-year-old) SqrSoft crossfader, which to my ears still is about the best we've ever had.

I've been in touch with tech support as initially the bridge caused audio to only play about 10 seconds then drop out, even though the track appeared to still be playing. I just recently discovered that, by changing the HTTP mode in the LMS bridge to fixed, I could get tracks to play all the way through.

Except now I can't get the SqrSoft crossfader to work with my flac files (my entire library is flac) as it fades out the track about halfway through and moves to the next track. If I set the bridge in LMS to transcode to mp3 it works as it should with no other changes, but the added lag/buffer issues is causing the crossfade to eventually fail when there's too much a lag on shorter tracks.

Using Winamp 5.8 playing the same FLAC tracks with the same crossfader everything works perfectly, so I'm thinking it must have to do with MM5's FLAC decoder. (I guess?) I tried switching out the old flac-related dlls from MM4, where the plug-in used to work, and those too now exhibit the odd behavior. I also tried to remove the internal FLAC engine and install the in_flac.dll from Winamp, but it doesn't recognize it.

Does anybody else have MM5 and also have one of the old SqrSoft versions they could test to see if it does the same on another machine? I am using 1.6, but 1.4 and 1.78 did the same thing.

Thanks in advance!

Top