Inconsistent display within All Tracks [#15110]

Post a reply


In an effort to prevent automatic submissions, we require that you complete the following challenge.
Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: Inconsistent display within All Tracks [#15110]

Re: Inconsistent display within All Tracks [#15110]

by PetrCBR » Mon Oct 01, 2018 3:42 am

I've reproduced on large database and fixed.

Re: Inconsistent display within All Tracks [#15110]

by JimPa » Sun Sep 30, 2018 4:19 am

My library is about half your size - around 23,000 tracks.

Re: Inconsistent display within All Tracks [#15110]

by Barry4679 » Fri Sep 28, 2018 10:06 pm

I can replicate it using steps given.
https://www.dropbox.com/s/pzoiy694fkpif ... 1.png?dl=0
https://www.dropbox.com/s/1yv97p318wm53 ... 2.png?dl=0

Maybe it is a size of library thing. I have 45896 tracks. ... Have many tracks you have JimPa?

The only things that I notice are:
* it keeps album tracks together in groups; I suppose that is not surprising because I rip whole albums
* albums don't seem to be duplicated, just out of sequence
* as JimPa says, it seems to have much of the library in expected sequence, but past the half way point there are groups of whole album blocks out of sequence ... lots of them

ps: I am on the latest (2124)

Re: Inconsistent display within All Tracks [#15110]

by Peke » Fri Sep 28, 2018 6:01 pm

Hi,
I can't replicate also.

Re: Inconsistent display within All Tracks [#15110]

by PetrCBR » Tue Sep 25, 2018 7:22 am

Still happens ? Strange as i can no longer reproduce ... will check again.

Re: Inconsistent display within All Tracks [#15110]

by JimPa » Tue Sep 25, 2018 6:54 am

The bug is marked as fixed in Mantis but still happens for me in latest build 5.0.0.2124

I can reproduce by:

1) Click "Music>All Tracks" with column header disabled and sort view by "Date added". Result: it shows all tracks sorted correctly including the last track added at the very top of the list (as expected).
2) Turn on Column browser
3) Click away onto any other node, e.g. "Video"
4) Click back on "Music>All Tracks" and it's no longer sorted in the correct order of date added (though that column is still marked as the sorted column). For some reason they're now listed vaguely in order until you start to reach maybe 2/3 near the bottom of the list, at which point the "Date added" is all over the place and the most recent track I added is wrongly placed at the very bottom of the list. If you toggle the "Added" column twice it displays in the correct order again until you go back to step 3.

Re: Inconsistent display within All Tracks

by PetrCBR » Mon Sep 17, 2018 3:45 pm

I've reproduced with enabled column browser. Tracked as 15110.

Re: Inconsistent display within All Tracks

by Ludek » Mon Sep 17, 2018 3:19 pm

I still cannot replicate (even with Column Browser enabled), but I see that this: viewtopic.php?f=30&t=91100
issue is now reproducible (when 'Column Browser' is enabled), tracked as https://www.ventismedia.com/mantis/view.php?id=15109

Re: Inconsistent display within All Tracks

by JimPa » Mon Sep 17, 2018 2:55 pm

Actually, forget that, the bug is still there but it only happens if the column browser is enabled. Try doing what I said but make sure column browser is enabled and the bug comes back (for me). As soon as I disable column browser it works as expected.

Re: Inconsistent display within All Tracks

by JimPa » Mon Sep 17, 2018 2:46 pm

Tried deleting my install and reinstalling and all is fine now - strange. Will double check against the other bugs I've raised to see if they're also false.

Re: Inconsistent display within All Tracks

by PetrCBR » Mon Sep 17, 2018 2:10 pm

Hmm ... just tried and cannot reproduce. Can you send your database (MM.DB from portable folder ... to petr <att> mediamonkey <dott> com) ?

Re: Inconsistent display within All Tracks

by JimPa » Mon Sep 17, 2018 2:05 pm

I'm using List View with the column browser enabled. It doesn't seem to do it when I switch to 'Album & Tracks' view.

** Are you sure that you are returning to the same collection?
Yep, definitely.

** Are you using navigation back button on the toolbar or clicking the 'All Tracks' node directly?
Clicking the 'All Tracks' node directly.

** If you press F5, does it re-orders itself correctly or not?
When I'm looking at 'All Tracks' and press F5 (or select Refresh from the menu) the whole track list disappears and it says "0 files, 0B, 00:00" in the Statusbar. Also the column browser then has 0 Genres, 0 Artists and 0 Albums displaying in it. If I then click the All Tracks node again it all comes back (apart from the missing entries at the top). Very odd.

Re: Inconsistent display within All Tracks

by Ludek » Mon Sep 17, 2018 1:51 pm

I cannot seem to replicate.

Which view + subviews are you using in the 'All Tracks' node?
'List View' or 'Album + Tracks' ? 'Column Browser' enabled?

Are you sure that you are returning to the same collection?
Are you using navigation back button on the toolbar or clicking the 'All Tracks' node directly?
If you press F5, does it re-orders itself correctly or not?

Inconsistent display within All Tracks [#15110]

by JimPa » Mon Sep 17, 2018 1:05 pm

Bit hard to describe this one but I'll do my best... In the media tree on the left I have these 2 nodes displaying (with music sorted by date 'Added'):

Music>All tracks
Playlists

If I click directly onto the 'All tracks' node, it's missing the first 7 tracks which should be at the top as they were added most recently (don't know why it's 7 that are missing). If I click the 'Added' column again to reverse the order and then click it once more to again reorder by date added, those missing 7 tracks come back to the top. But if I then click away (e.g. click on the Playlists node) and then click back onto 'All tracks' then those 7 most recent tracks are gone again unless I click 'Added' 2 more times.

It's not just 'Added' that this happens with. With All Tracks displayed try ordering by 'Artist', then click away onto Playlists and then back into All Tracks. Now the first 2 of my tracks have disappeared unless I reorder again by clicking twice on 'Artist'. I think it does it on most of the columns.

So basically, choose a sort order in All Tracks, click away onto Playlists and then click back into All Tracks - is it the exact same list of tracks you're seeing?

Top