request for a skip-without-crossfade button

Post a reply

Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: request for a skip-without-crossfade button

Re: request for a skip-without-crossfade button

by rovingcowboy » Mon Apr 16, 2012 11:09 pm

4.0.5 is just new so might be a new bug. hang on they should fix it 8)

Re: request for a skip-without-crossfade button

by oddBeat » Sun Apr 15, 2012 7:27 pm

I guess this script is not working on Windows XP SP3, MM 4.0.5, or Im doing something wrong.

I got an error:
  • Error happened during script initialization:
    A script engine for the specified language can not be created
Any clue?


Thnx,
Roger

Re: request for a skip-without-crossfade button

by benimble047 » Mon Nov 02, 2009 1:22 am

hey all!! ok, ok... i've got a similar problem. i know how to turn crossfade off and on. but i really don't feel like using SQRsoft's crossfading plug-in. is there a way to add a button the the standard menu for those using MM's direct sound output device?

i presume it would be the same code but to replace "SDB." with something else. Am I correct?

Thanks

Re: request for a skip-without-crossfade button

by rovingcowboy » Tue Feb 17, 2009 6:43 am

thats right beemer but the post you answered is 3 years old and for mm 2.5.5
but now you got it in the thread so others that find it in the search will know.
thanks for updating the thread. 8)

Re: request for a skip-without-crossfade button

by Beemer » Tue Feb 17, 2009 5:01 am

Source: http://www.wanderings.net/notebook/Main ... rossfading

I love the MediaMonkey player, but it bugged me that the beginning of the next track always plays over the end of the last track. This feature is called "crossfading," but it was not clear to me how to adjust it. Here's the path to the crossfading settings...
Tools | Options | Output plug-ins | MediaMonkey DirectSound output | Configure
OR to turn crossfading off entirely, go to the Play menu and uncheck the option Crossfade.

by wallstreetwalker » Mon May 15, 2006 5:38 am

works perfect again!

i also added a button myself, i edited your script now i also have a button to stop crossfade (in case i already clicked skip (with crossfade) )

Code: Select all

Sub OnStartup 

    SDB.UI.AddMenuItemSep SDB.UI.Menu_TbStandard, 0, 0 
    
    Dim TBItem : Set TBItem = SDB.UI.AddMenuItem(SDB.UI.Menu_TbStandard, 0, 0) 
    TBItem.Caption = "Stop Crossfade" 
    TBItem.OnClickFunc = "StopCrossfade" 
    TBItem.UseScript = Script.ScriptPath 
    TBItem.IconIndex = 4 

End Sub 


Sub StopCrossfade(TBItem) 
 
    SDB.Player.PlaybackTime = 0 

End Sub

by Steegy » Sun May 14, 2006 8:15 pm

Yes, adding

Code: Select all

TBItem.ShortCut = "Ctrl+B"
behind "TBItem.IconIndex = 4" should do the trick.

I say should because there were problems with shortcut keys some time ago. I don't know if it works now.

If it doesn't work, then use the following:


NextSongWithoutCrossfade.vbs (for in the Scripts\Auto folder)

Code: Select all

Sub OnStartup 

    SDB.UI.AddMenuItemSep SDB.UI.Menu_TbStandard, 0, 0 
    
    Dim TBItem : Set TBItem = SDB.UI.AddMenuItem(SDB.UI.Menu_TbStandard, 0, 0) 
    TBItem.Caption = "Next Song Without Crossfade" 
    TBItem.OnClickFunc = "NextSongWithoutCrossfade" 
    TBItem.UseScript = Script.ScriptPath 
    TBItem.IconIndex = 4 

End Sub 




Sub NextSongWithoutCrossfade(TBItem) 

    Call NextSongWithoutCrossfade_DoIt

End Sub



Sub NextSongWithoutCrossfade_DoIt

    SDB.Player.Next 
    SDB.Player.PlaybackTime = 0 

End Sub
Entry for Scripts.ini:

Code: Select all

[NextSongWithoutCrossfade] 
FileName=Auto\NextSongWithoutCrossfade.vbs 
ProcName=NextSongWithoutCrossfade_DoIt 
Order=15 
DisplayName=NextSongWithoutCrossfade 
Description=NextSongWithoutCrossfade
Shortcut=Ctrl+B 
Language=VBScript 
ScriptType=0
Cheers
Steegy

by wallstreetwalker » Sun May 14, 2006 8:04 pm

ow, one more thing

is there an easy way to assign a key tot it like
'ctrl + b' or something.

would be great (er) :D

thank you

by wallstreetwalker » Sun May 14, 2006 7:10 pm

thanks alot steegy !

it works perfect! :lol:

i'm using it all the time

if i want to skip a song i don't like i use this button so i don't have to hear the intro crossfading


...and sorry for late reply

by Steegy » Tue May 09, 2006 1:27 pm

Sorry, you wanted a button. The following code will add a new "play next song" button to the standard toolbar.


NextSongWithoutCrossfade.vbs (for the Scripts/Auto folder)

Code: Select all

Sub OnStartup 

    SDB.UI.AddMenuItemSep SDB.UI.Menu_TbStandard, 0, 0
	
    Dim TBItem : Set TBItem = SDB.UI.AddMenuItem(SDB.UI.Menu_TbStandard, 0, 0) 
    TBItem.Caption = "Next Song Without Crossfade"
    TBItem.OnClickFunc = "NextSongWithoutCrossfade" 
    TBItem.UseScript = Script.ScriptPath 
    TBItem.IconIndex = 4

End Sub 




Sub NextSongWithoutCrossfade(TBItem)

    SDB.Player.Next
    SDB.Player.PlaybackTime = 0

End Sub
Cheers
Steegy

by Steegy » Tue May 09, 2006 1:19 pm

i click 'next track', crossfading starts, now i move the timeslider like one second and crossfading stops (because crossfade on seek is disabled) so the songs starts playing immediately (in stead of having a crossfade).
This simple 2 lines script does exactly what you do manually:

NextSongWithoutCrossfade.vbs (for in the Scripts folder)

Code: Select all

Sub NextSongWithoutCrossfade

    SDB.Player.Next
    SDB.Player.PlaybackTime = 0

End Sub

Entry for Scripts.ini:

Code: Select all

[NextSongWithoutCrossfade]
FileName=NextSongWithoutCrossfade.vbs
ProcName=NextSongWithoutCrossfade
Order=15
DisplayName=NextSongWithoutCrossfade
Description=NextSongWithoutCrossfade
Language=VBScript
ScriptType=0

What DirectSound crossfading playback does when the script (or the manual workaround) is started (both things at the same time):
- currently playing song fades out
- next song starts playback immediately (at the full volume)
However, I just want to say that "crossfade on play" and "crossfade on pause/stop" must be enabled, and "crossfade on seek" must be disabled.


What SQRSoft crossfading playback does when the script (or the manual workaround) is started (both things at the same time):
- currently playing song stops immediately (volume 0)
- next song starts playback immediately (at the full volume)

Conclusion: this workaround only works with SQRSoft crossfading. On DirectSound crossfading, it only works partially.

Cheers
Steegy

by wallstreetwalker » Mon May 08, 2006 10:18 am

by Lowlander » Mon May 08, 2006 10:00 am

I'm not too familiar with the SQRSoft, but I think you can set skip to next track seperatly. So I think you can take the crossfading out of it. I advice you to check the website for help (don't know if it has any) and play with the configuration.

by trixmoto » Mon May 08, 2006 6:14 am

You could say which plugin!

by wallstreetwalker » Mon May 08, 2006 6:02 am

well it's just a plugin, what more can i say. :-?

Top