Custom Report 3.2 - Updated 29/07/2014

Post a reply


In an effort to prevent automatic submissions, we require that you complete the following challenge.
Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: Custom Report 3.2 - Updated 29/07/2014

Re: Custom Report 3.2 - Updated 29/07/2014

by arvo » Fri Apr 24, 2020 3:15 am

I get two errors when i try and create a report.

After clicking on custom report I get the following errors.
First Error message
Error #9 - Microsoft VBscript runtime error
Subscript out of range: '[number:3]
"File: C:\users\Brett\AppData\Roaming\MediaMonkey\Scripts\CustomReport.vbs" ,Line 24B, column: 4

then it comes up with the following error message
Error happened during script execution:
Subscript out of range: "[Number 3]'

and the script window doesn't open. anyone know what causes this and how to resolve it.

cheers Brett

Re: Custom Report 3.2 - Updated 29/07/2014

by Onweerwolf » Sun Mar 08, 2020 9:25 am

RCBAudio wrote:
Thu May 24, 2018 8:12 am
I have installed Media Monkey and Custom Report 3.2 on a new laptop and when I execute the Custom Report Script I am seeing this same error:
Error #70 - Microsoft VBScript runtime error
Permission denied
File: "E:\MediaMonkey\Scripts\CustomReport.vbs", Line: 3187, Column: 4
I read through the thread but must have overlooked the resolution. How was this resolved?

Thanks in Advance.
I am getting a very similar problem every now and then:

Image

edit: actually just found out what causes this. When I make a custom report and have it export as a .csv file and then immediately open that in Excel, then do another custom report with the same settings that opens into the same .csv but the former file is still open in Excel this error results. If I close the former file in Excel it works.

[SOLVED] Custom Report 3.2

by cyberlarson » Fri Feb 21, 2020 4:12 pm

Error #7 Microsoft VBScript runtime Error
Out of memory fso.folder exists
error line 2177 column 2

I've used Custom Reports for years and it is wonderful. I just switched to Windows 10. Custom reports worked fine the past two weeks and yesterday I got the above message. I have uninstalled and reinstalled it and the message continues. I have tried different formats and the same message. The line referenced is about creating a new folder

The USB drive that it was going to write to, was not plugged in. Working now

Re: Custom Report 3.2 - Updated 29/07/2014

by adrock0211 » Sat Sep 01, 2018 8:31 am

Great script, however, there are a few missing columns that I need. These columns certainly exist in the main window viewer. I am using MediaMonkey to view information about my movie files and the columns that seem to be missing are Resolution and File size.

You can see these columns exist here:

https://imgur.com/a/DcHeuXs

However, when I use the custom script and hit the columns drop down, these fields do not exist. Any way to bring them in?

Thanks, in advance.

Re: Custom Report 3.2 - Updated 29/07/2014

by slvbeard » Fri Aug 31, 2018 5:07 am

Is there a way to export a list of all Aritsts without duplicates?

Re: Custom Report 3.2 - Updated 29/07/2014

by havoc » Thu Aug 23, 2018 7:41 am

Hey I love this script, but when my file name has a - in it goes into the Title column, when the title is blank on the tag. Is there a way to fix this? so only the title column shows the titles?

Re: Custom Report 3.2 - Updated 29/07/2014

by havocuk » Tue Jun 19, 2018 2:37 pm

Sorry, just found about MediaMonkey 2 days ago and love. But I love this script even more! is there any plans on developing it further?

Re: Custom Report 3.2 - Updated 29/07/2014

by RCBAudio » Thu May 24, 2018 8:12 am

I have installed Media Monkey and Custom Report 3.2 on a new laptop and when I execute the Custom Report Script I am seeing this same error:
Error #70 - Microsoft VBScript runtime error
Permission denied
File: "E:\MediaMonkey\Scripts\CustomReport.vbs", Line: 3187, Column: 4
I read through the thread but must have overlooked the resolution. How was this resolved?

Thanks in Advance.

Re: Custom Report 3.2 - Updated 29/07/2014

by sullydks » Sun Mar 04, 2018 6:23 pm

The report processed at about 10K titles per hour. Completed successfully... so all is good.
An Observation
At the final stage, it displayed a window about Xcel compatibility, with the prompt to "CONTINUE" . However, this window was behind main, and the banner bar/status in the main screen still showed the penultimate track being processed, Meaning, it sits there waiting for a user input but the user is unaware that input is required. Wasted 30 mins waiting, even though I had a Task window open that was showing MM using CPU... I didnt see the user prompt window.
When you finally realise and click on the 'Continue' button, THEN the status bar changes to show finished etc.... WRONG WAY AROUND !!!

Also frustrating that the XLS output has 65K limit. I got around this by re-running the report for the final records only. AFTER saving the initial output into XLSX which support more then 5K sheets.

Just some observation/feedback.

Custom Report Addon - performance question

by sullydks » Sun Mar 04, 2018 1:41 pm

Question about performance. First time user of this add-on. I was trying to get an extract of full library.
I have a straight listing report of 19 items. No sort, tums etc. to XLS.
Tested on selection of the library. All good.
Running full report but it seems to be taking about 1 hour per 7,000 tracks, Is this about right ?
I've restarted twice to reset everything. Reboot, etc.. But still same speed.
I've got 69000 in the collection (Mp3 and FLAC). That's almost 10 hours to run a report ? That's 1990's mainframe DB2 speed :-)
Surely I'm doing something wrong.
Ideas ?

Re: Custom Report 3.2 - Updated 29/07/2014

by cryptus939 » Thu Dec 07, 2017 1:22 pm

This script has just today started returning the error "Excel not found" whenever I try to create a report. I haven't changed anything about the script at all; any ideas on how to fix this please?

Re: Custom Report 3.2 - Updated 29/07/2014

by JOOP » Mon Oct 30, 2017 11:46 am

Hi,

Custom Report 3.2. seems to be a very powerful tool and it offers nearly all that I was looking for.

However, is there a possibility to run it by "albumartist/album" only WITHOUT including "Titles" (I can not uncheck the box "includes") ?

http://www.directupload.net/file/d/4891 ... mz_jpg.htm

Edit: It would be very helpful if if there was a function like "Group by" e.g. "Albumartist" in order that only one line per album appears.

Re: Custom Report 3.2 - Updated 29/07/2014

by AllenW » Wed Jul 05, 2017 9:57 am

Ya, I can't find a way either, but at least I have a start, thanks much!

Al

Re: Custom Report 3.2 - Updated 29/07/2014

by MMFrLife » Fri Jun 30, 2017 10:28 pm

AllenW wrote:but is there a way to just copy/paste the artists and album?
Not that I know of. Not easily anyway (maybe looking into the database; SQLite maybe, but format would likely inhibit listing out from being practical).

Re: Custom Report 3.2 - Updated 29/07/2014

by AllenW » Fri Jun 30, 2017 9:24 pm

MMFrLife wrote:Bizarre. You're clicking the download link or save button to download and getting that?
Or, after download, you click on it to install and get that?

Are you downloading from CustomReport32.mmip?
The link is just under the script name.
Evidently I was on the wrong page/site/? as this link worked fine.

I'll try and figure it out now, but is there a way to just copy/paste the artists and album?
Thanks a bunch!

Al

Top