[ISSUE] NO DLNA VSX-921

Beta Testing for Windows Products and plugins

Moderator: Gurus

mr.greywater
Posts: 5
Joined: Sat Aug 06, 2011 1:45 pm

[ISSUE] NO DLNA VSX-921

Post by mr.greywater » Sat Aug 06, 2011 2:53 pm

I cant access my MM-DLNA Server with my Amp Pioneer VSX-921. It always says "not authorized".
I always use the settings without any security... and its fine with other computers. they can access the library without problems.

my settings:
Image
Image
Image
Image

Any suggestions?
(No Firewall except from Router but with other Computers its fine, so I dont think that this is a problem)

Ludek
Posts: 2964
Joined: Fri Mar 09, 2007 9:00 am

Re: [ISSUE] NO DLNA VSX-921

Post by Ludek » Tue Aug 16, 2011 6:08 am

From the screenshots it really looks that your server is running and there is no attempt to access it by the Amp Pioneer VSX-921, only by WMP from the same machine (localhost). Do you see the server by the Amp Pioneer VSX-921?
Are you sure that it is not a firewall problem? i.e. is MM trusted app in your firewall/AV settings? UPnP is enabled? If you access the same MM server by WMP client from another computer, does it work?

In case it is not a security problem then debug log (generated using DbgView) should tell us more, there is how to generate the log: http://www.mediamonkey.com/forum/viewto ... ?f=6&t=341

rob de bruin

Re: [ISSUE] NO DLNA VSX-921

Post by rob de bruin » Fri Dec 16, 2011 1:02 pm

I own a pioneer sc-lx72 and I seem to have the same problem. Playing directly from my mediamonkey collection would be a great benefit. Has this issue been resolved already?

kind regards,
Rob de Bruin

Ludek
Posts: 2964
Joined: Fri Mar 09, 2007 9:00 am

Re: [ISSUE] NO DLNA VSX-921

Post by Ludek » Fri Dec 23, 2011 9:35 am

Hi, yes this is resolved as http://www.ventismedia.com/mantis/view.php?id=8875, but the build has not been released yet.

Please find MediaMonkey install folder and there is file called UPnP.dll, replace the file by this one:
ftp://spolehlivasit.cz/8875/UpNp.dll
and give a try.

Let us know whether it solves the problem for you.

sialivi
Posts: 26
Joined: Tue Aug 09, 2011 3:18 pm

Re: [ISSUE] NO DLNA VSX-921

Post by sialivi » Sun Dec 25, 2011 10:11 pm

I have a Pioneer VSX-921-K (firmware 1-151081111031) and I'm still having problems.
Unlike the original poster though, I'm not getting a "Not Authorized" message but instead an "Access Denied".

I've downloaded MediaMonkey 4.0.2.1462 which is supposed to have fixed the problem.
I've also tried downloading the UPnP.dll from the previous post and replaced the one included with 1462 but that didn't help either.

For the record: Windows 7's built in DLNA support works fine with my setup.

OS: Windows 7 x64
Reciever: Pioneer VSX-921-K (firmware 1-151081111031)
PC to Reciever Connection: HDMI

Image

GreenOnyx
Posts: 11
Joined: Mon Jun 23, 2008 11:33 am

Re: [ISSUE] NO DLNA VSX-921

Post by GreenOnyx » Mon Dec 26, 2011 12:45 pm

Ludek: Do you know if that upnp.dll is supposed to replace that file even with the latest beta? I couldn't tell if it was or if it was a temp fix until that beta was out.

sialivia: I noticed you don't have Accept External IP Addresses checked, does that make any difference? I can't see the entire IP of what's being denied, but if it starts with 21 I think MM might being seeing it as external. Just a thought.

Ludek
Posts: 2964
Joined: Fri Mar 09, 2007 9:00 am

Re: [ISSUE] NO DLNA VSX-921

Post by Ludek » Mon Dec 26, 2011 3:42 pm

The "Not Authorized" issue should be fixed in build 4.0.2.1462 (already released) and the "Access Denied" seems to be really problem related to MediaMonkey settings. Check out the [Access Control] page and as suggested check [x] Accept external IP address as the IP seems to be in an external form.

rob de bruin

Re: [ISSUE] NO DLNA VSX-921

Post by rob de bruin » Mon Dec 26, 2011 5:13 pm

I Have just downloaded and installed version 4.0.2.1462 and I can now play music from my MediaMonkey library through the dlna server. Thank you very much for making this functionality available!

(and (a late) merry cristmas!)

sialivi
Posts: 26
Joined: Tue Aug 09, 2011 3:18 pm

Re: [ISSUE] NO DLNA VSX-921

Post by sialivi » Mon Dec 26, 2011 10:44 pm

Ludek wrote:The "Not Authorized" issue should be fixed in build 4.0.2.1462 (already released) and the "Access Denied" seems to be really problem related to MediaMonkey settings. Check out the [Access Control] page and as suggested check [x] Accept external IP address as the IP seems to be in an external form.
Ah, that fixed it. Thanks for the help.

I did experience one glitch though:
Just as I selected the MediaMonkey Server on my reciever (after fixing the incorrect setting) a popup appeared on my PC, saying something about an array index out of bounds. However, I haven't been able to recreate the bug and perhaps it was just a coincidence that it happened just as I selected the MediaMonkey DLNA server. *shrugs*

amz

Re: [ISSUE] NO DLNA VSX-921 - NAD C446

Post by amz » Sat Dec 31, 2011 9:25 am

Hi,

just tried to get my NAD C446 working and don't get a selection for the MM server - probably due to the server port setting is incorrect...
Tried 4000 and some other but no luck, any idea which port to use?

PC Win XP SP3
MM 4.02 with upnp.dll replaced

TIA

jebdida

Re: [ISSUE] NO DLNA VSX-921

Post by jebdida » Mon Dec 10, 2018 12:59 pm

I am using a VSX-932 and experiencing the same problem with at least two other DLNA-servers. Minidlna and the DLNA server from my FRITZ!box router.

So this seems to be a problem caused by Pioneer.

When disconnecting and reconnecting the device from power, it can find the DLNA servers. But it can lose the connection at any random moment.

Post Reply