DLNA server running but disappears from some clients

Get answers about how to share with different devices.

Moderator: Gurus

DLNA server running but disappears from some clients

Postby CubsWin » Mon Jan 08, 2018 11:28 pm

I have used MediaMonkey for several years and haven't had this issue until the past few weeks. My DLNA server is visible to some devices on my network, but not others. I am currently unable to see it from either the MediaMonkey app or BubbleUPNP on my Android phone. After a reboot, it usually appears again and I can connect to it, but then it eventually disappears from the list again. The same problem occurs using certain other devices on my network as well, like my Panasonic smart TV. On the other hand, my Yamaha AV Receiver still sees the DLNA server and can connect and play music from it without issue. Nothing has changed in my configuration over the past few weeks that I am aware of. Does anyone have any idea what could cause this sort of behavior? Is there any debugging I can do or log I can access which might tell me why some devices can't consistently see the server anymore?
CubsWin
 
Posts: 8
Joined: Tue Jan 28, 2014 11:32 pm

Re: DLNA server running but disappears from some clients

Postby Lowlander » Mon Jan 08, 2018 11:48 pm

Lowlander (MediaMonkey user since 2003)
Lowlander
 
Posts: 44062
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: DLNA server running but disappears from some clients

Postby CubsWin » Tue Jan 09, 2018 4:19 pm


I have gone through all the steps on that list, but was unsuccessful in resolving the issue.

I tested/verified the following:
    I am running the latest version of MMW (4.1.19.1859)
    I reset my router
    I verified that my Windows network connection is set to private
    I verified the media server port is open on my network using a network scanner
    I temporarily disabled my firewall, which made no difference
I did discover something interesting while using my Android phone as a client. Running MediaMonkey for Android, I am unable to see the MediaMonkey server on my UPnP server list (I do see my Windows Media Server 100% of the time without issue). If I open MediaMonkey on my Windows PC and change the port of the MediaMonkey server in options, the server immediately becomes visible again on my phone. It remains visible for an indeterminate amount of time and can be accessed as normal while it is visible, but it will soon disappear again from the list. I can repeat the process by changing the port number again, rinse and repeat.

I am thinking maybe this is an Android issue, as the same issue occurs when using the BubbleUPNP client on Android. BubbleUPNP can see my Windows Media server at all times, but the MediaMonkey server disappears until I change the port, and then disappears again.

Do you have any further recommendations? Has anyone else seen this type of behavior before?

Edit: The issue is not specific to Android, as I reproduced the same behavior using my Panasonic TV as a DLNA client. And now the same thing is occurring on my Yamaha AV receiver as well. So what could be preventing the MediaMonkey server from being visible to all devices on my network? And then when I change the port why does it temporarily appear again prior to going away? And why does this occur for the MediaMonkey server, but my Windows Media server is unaffected?
CubsWin
 
Posts: 8
Joined: Tue Jan 28, 2014 11:32 pm


Return to Need Help with UPnP / DLNA ?

Who is online

Users browsing this forum: Peke and 5 guests