Backup 6.0 - Updated 01/07/2014

Download and get help for different MediaMonkey Addons.

Moderators: Peke, Gurus

H08590
Posts: 10
Joined: Thu Aug 29, 2013 7:09 pm

Re: Backup 5.8 - Updated 27/10/2010

Post by H08590 » Fri Sep 06, 2013 7:12 pm

thank you for this suggestion. However, the notes for the example note that it would be different if I am on Win 64--which I am. Do you know how it would be modified in my case?

gpzbc
Posts: 1226
Joined: Sat Sep 13, 2008 12:02 am
Location: Colorado, USA

Re: Backup 5.8 - Updated 27/10/2010

Post by gpzbc » Fri Sep 06, 2013 10:44 pm

Whoops, I actually advised you incorrectly, that is assuming you are now using MM 4.XX rather than MM3.XX. The instructions I gave were for MM 3.XX. Now on MM 4.XX, your dll is stored at "C:\Users\XXXX\AppData\Roaming\MediaMonkey\Scripts\XZip.dll"

So, on MediaMonkey 4.XX, the new instructions are:

a. Open command prompt by typing cmd.exe into start menu.
b. right-click on the command prompt shortcut and select "Run as administrator"
c. Input this command: regsvr32 "C:\Users\XXXX\AppData\Roaming\MediaMonkey\Scripts\XZip.dll"

I hope that helps!
--
The gpzbc

jdoiii
Posts: 2
Joined: Thu Sep 26, 2013 12:40 am

Re: Backup 5.8 - Updated 27/10/2010

Post by jdoiii » Sat Sep 28, 2013 10:46 am

I had been using Backup without issue, but just recently been getting the following error messages when starting MM (4.0.7.1511):

===============
Error #70 -Microsoft VBScript runtime error
Permission denied
File: "c:\Users\Me\AppData\Roaming\MediaMonkey\Scripts\Auto\Backup.vbs", Line: 1693, Column: 2

===============
Error happened during script execution:
Permission denied

===============

Backup would not run on exiting, and any changes made to a) tags and b) Auto-Organize rules during the MM session were not kept.

I uninstalled Backup and the problems were fixed. I re-downloaded and re-instaleld Backup 5.8 and got the Error #70 message again.

As best I can tell, this is line 1693 in Backup.vbs:
===============
Sub CleanUp(par,del) '0=ask 1=yes 2=all
===============

Any help? Thanks.

trixmoto
Posts: 10024
Joined: Fri Aug 26, 2005 3:28 am
Location: Hull, UK
Contact:

Re: Backup 5.8 - Updated 27/10/2010

Post by trixmoto » Sun Sep 29, 2013 4:30 pm

The script is being blocked from deleting certain files. It's either because these files are locked (open in another application) or because your anti-virus-type software has decided my script is up to no good and therefore blocked it.
Download my scripts at my own MediaMonkey fansite.
All the code for my website and scripts is safely backed up immediately and for free using Dropbox.

dtsig
Posts: 3061
Joined: Mon Jan 24, 2011 6:34 pm

HELP: restored db not usable

Post by dtsig » Wed Oct 09, 2013 10:56 am

I have been running your script for some time now. This morning MMW went all squirly while running another script (count images) and MMW simply froze. I had to shut it down.

When started I got the following ...

Image

So wow i thought glad i do a backup. I ran the restore script through windows scripting host and all appeared to be okay. But now when i try to start MMW i get the same message.

How can I restore? Thoughts on what might be wrong? Help :cry:
Where's the db and ini stored
Reporting Bugs
Where tags are stored

Not affiliated with MediaMonkey ... just a RABID user/lover
DTSig

dtsig
Posts: 3061
Joined: Mon Jan 24, 2011 6:34 pm

Re: Backup 5.8 - Updated 27/10/2010

Post by dtsig » Wed Oct 09, 2013 11:21 am

In order to get this to work I had to uninstall MMW (no not just using uninstall because that left LOTS of bits and it appeared to interfer with the restore). Then Reboot. Then install mmw again. THEN restore.

Hope this helps anyone else who gets stuck restoring.
Where's the db and ini stored
Reporting Bugs
Where tags are stored

Not affiliated with MediaMonkey ... just a RABID user/lover
DTSig

gpzbc
Posts: 1226
Joined: Sat Sep 13, 2008 12:02 am
Location: Colorado, USA

Re: Backup 5.8 - Updated 27/10/2010

Post by gpzbc » Wed Oct 09, 2013 11:52 am

Thank you for sharing this.
--
The gpzbc

dtsig
Posts: 3061
Joined: Mon Jan 24, 2011 6:34 pm

Re: Backup 5.8 - Updated 27/10/2010

Post by dtsig » Wed Oct 09, 2013 12:01 pm

No problem. I hope it helps someone.
Where's the db and ini stored
Reporting Bugs
Where tags are stored

Not affiliated with MediaMonkey ... just a RABID user/lover
DTSig

natakk
Posts: 83
Joined: Wed Jan 16, 2013 9:20 am
Location: Switzerland

Backup DB Script (5.8)

Post by natakk » Sun Nov 03, 2013 4:31 am

hello

i took a second attempt to integrate a backup method for my database.
target is to save database even if i start MM.

so i tried it with backup 5.8 extension
but i get allways an error

Image

on the target line:

Image

is there a new version out for this addon? can i solve this script self?
or are other addons available to backup the database?

i use MM as portable installation on a windows 2008 r2 server.
MM is on the newest beta release.
Last edited by Lowlander on Sun Nov 03, 2013 2:41 pm, edited 1 time in total.
Reason: Merged with existing post

Lowlander
Posts: 46262
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Backup DB Script (5.8)

Post by Lowlander » Sun Nov 03, 2013 2:38 pm

Lowlander (MediaMonkey user since 2003)

natakk
Posts: 83
Joined: Wed Jan 16, 2013 9:20 am
Location: Switzerland

Re: Backup 5.8 - Updated 27/10/2010

Post by natakk » Mon Nov 04, 2013 1:04 pm

allready tried out. can't solve the problem :(

why does the the activeX object can't be created?

trixmoto
Posts: 10024
Joined: Fri Aug 26, 2005 3:28 am
Location: Hull, UK
Contact:

Re: Backup 5.8 - Updated 27/10/2010

Post by trixmoto » Thu Nov 07, 2013 4:00 am

Sometimes it's because it's not properly registered, sometimes it's blocked by anti-virus or other protection software, in my experience.
Download my scripts at my own MediaMonkey fansite.
All the code for my website and scripts is safely backed up immediately and for free using Dropbox.

dtsig
Posts: 3061
Joined: Mon Jan 24, 2011 6:34 pm

Re: Backup 5.8 - Updated 27/10/2010

Post by dtsig » Thu Nov 21, 2013 12:02 am

So today I got the infamous "can't open db .. create new local". But not to worry, I thought, I backup every shut down and if doing lots of edits a couple times a day. To make a long story short I tried the 'current' backup in the backup directory and the registry came up with error message about invalid keys. So i went to the last backup and was told something like invalid compression. So went to the previous ... I ended up back to the 28th of last year. In looking at the attached image you can see there is some problem going on. The 500K archives do not work at all.

So after the early restore I scanned my nas for the large music upload i did over the weekend and can work on the edits later. I then did a Backup and watched it .. Below is also the message from the end of the backup. At first glimpse it looks like it was successful .. but the devil is in the details. towards the end of course it says there was some errors. So I have 1 Question and 1 Suggestion

Q: How do i figure out what is causing the problem? I tried zipping with winzip and it works find. As there is no info reported this is a problem to debug

S: When there is an error Please put out a different display. Like i said at first blush it looks like it was correct. How about adding a button to the message box that displays errors and possible solutions.

Thanks .. when it works it works great.

Image of Backup Archive directory:
Image

Image of Backup message:
Image
Where's the db and ini stored
Reporting Bugs
Where tags are stored

Not affiliated with MediaMonkey ... just a RABID user/lover
DTSig

Lowlander
Posts: 46262
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Backup 5.8 - Updated 27/10/2010

Post by Lowlander » Thu Nov 21, 2013 10:17 am

This Addon can't create large ZIP archives (limitation of zip library used) something that has been discussed a long time ago (I ran into that issue some years ago). I don't remember the max size supported, but it isn't more than a few 100MB.
Lowlander (MediaMonkey user since 2003)

gpzbc
Posts: 1226
Joined: Sat Sep 13, 2008 12:02 am
Location: Colorado, USA

Re: Backup 5.8 - Updated 27/10/2010

Post by gpzbc » Thu Nov 21, 2013 10:48 am

Trixmoto has tested it up to 660 mb. http://www.mediamonkey.com/forum/viewto ... ze#p266977

Lowlander has confirmed that 800 mb is too big. http://www.mediamonkey.com/forum/viewto ... ze#p263377
--
The gpzbc

Post Reply