exported opml file not correct [#14609]

To get bugs in the current release fixed, please report them here.

Moderator: Gurus

gerundium

exported opml file not correct [#14609]

Post by gerundium » Thu Jan 04, 2018 6:01 pm

When exporting the podcasts as an opml file, (using the default-script at "Extras>Scripts>Export Podcasts"), special characters from podcast Title in MediaMonkey (like "") will be copied to the Text-Attribute in the OPML-File.

The resulting OPML looks like this for example:

Code: Select all

...
<outline id = "67" text="ZDF - "Neues aus der Anstalt"" type="rss" xmlUrl="http://www.zdf.de/ZDFmediathek/podcast/222630" />
...
Trying to open this file using other programs results in an error.

Peke
Posts: 11449
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: exported opml file not correct

Post by Peke » Thu Jan 04, 2018 10:27 pm

Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add Images to forum

Peke
Posts: 11449
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: exported opml file not correct [#14609]

Post by Peke » Tue Jan 16, 2018 9:56 pm

Bug should be fixed as of MMW 4.1.20.1864 where correct escaping characters are used according to XML standard https://www.liquid-technologies.com/XML ... gData.aspx
Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add Images to forum

Post Reply