Auto Tag From Web (Bad Request)

To get bugs in the current release fixed, please report them here.

Moderator: Gurus

neronerd
Posts: 1
Joined: Sat Jan 13, 2018 12:20 pm

Couldn't show results - Bad request - Auto-Tag

Post by neronerd » Sat Jan 13, 2018 12:28 pm

PROBLEM:
Unable to auto-tag
Get error "Couldn't show results - HTTP/1.1.400 Bad Request

VERSION:
MM v4.1.19.1859
OS Windows 10 (fully patched)

WHATS BEEN DONE:
Uninstalled all scripts
Turn off FW
Placed PC outside of FW
AV disabled

Still unable to auto-tag
Only thing I haven't done is uninstall and reinstall

Anyone have any other ideas?
Do I need to change freedb settings? Is Amazon changing things again?

realhowto
Posts: 1
Joined: Thu May 02, 2013 7:25 pm

Re: Auto Tag From Web (Bad Request)

Post by realhowto » Sun Jan 14, 2018 7:47 pm

Amazon Japan is still working for unknown reason :o

Anonym

Re: Auto Tag From Web (Bad Request)

Post by Anonym » Mon Jan 15, 2018 5:33 am

Amazon Japan is still working for me too

Glass Joe

Re: Auto Tag From Web (Bad Request)

Post by Glass Joe » Thu Jan 18, 2018 3:53 pm

Same problem; Went to download folder, reinstalled 4.1.18.1853 Problem fixed.
Wait for update, or search for beta release.

woodchip

Re: Auto Tag From Web (Bad Request)

Post by woodchip » Fri Jan 19, 2018 6:55 am

I have the same problem!!

Gary S

Re: Auto Tag From Web (Bad Request)

Post by Gary S » Fri Jan 19, 2018 12:36 pm

same problem here..I guess we wait until MM fix it. I just upgraded to latest version and then error... not sure how long this has been a problem as Ive not used mm in a while until today. :-?
HTTP/1.1 400 Bad Request :o

TLD
Posts: 24
Joined: Sat Jun 27, 2009 6:11 pm

Re: Auto Tag From Web (Bad Request)

Post by TLD » Sat Jan 20, 2018 11:26 pm

I'm curious...
The resultant pages for the searches for Amazon based on (for example) album or artist are the same. Why can't those be parsed for the information for autotag?

I don't have details on the backend results that the APIs were returning before - was there a specific format that they were being returned in that could be "built", perhaps, from the item page(s) instead of relying on the API?

This could then be called through the OS browser, and be just another web page being pulled up rather than a call to the API.

...Or am I missing something because I lack the information about the API calls or resultant data?

Just a thought ...

Lowlander
Posts: 44261
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Auto Tag From Web (Bad Request)

Post by Lowlander » Mon Jan 22, 2018 12:51 pm

1) There are no plans to "fix" Amazon tagging, it has been disabled by Amazon.

2) It's far more complex to parse data from a webpage then using an API.

3) You can't just get data from a website without permission to do so.

4) So for now, the Japan variant still works, and there alternative options like the Discogs Tagger: http://www.mediamonkey.com/addons/brows ... ta-lookup/

5) MediaMonkey 5 (in testing) will has other sources build in.
Lowlander (MediaMonkey user since 2003)

TomValenz

Re: Auto Tag From Web (Bad Request)

Post by TomValenz » Thu Mar 08, 2018 10:01 pm

I use the discogs addon and it works ok. Finds 9.5/10 i want to tag.

sinbaddylad

Re: Auto Tag From Web (Bad Request)

Post by sinbaddylad » Sun Jun 10, 2018 5:42 am

Hey guys, how are you all tagging your movie files? Discogs only works for music files. Since the Amazon issue kicked in, MM is useless for tagging my movies. Any help?

Lowlander
Posts: 44261
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Auto Tag From Web (Bad Request)

Post by Lowlander » Mon Jun 11, 2018 11:57 am

MediaMonkey 5 (available as Alpha) can do Movie (and TV and Music) tagging natively.
Lowlander (MediaMonkey user since 2003)

sinbaddylad

Re: Auto Tag From Web (Bad Request)

Post by sinbaddylad » Thu Jun 14, 2018 7:02 pm

I've tried v5, same Bad Request. "HTTP/1.1 400 Bad Request"

marvda1
Posts: 4
Joined: Thu Jan 01, 2015 7:35 pm

auto tag search

Post by marvda1 » Fri Jun 15, 2018 3:59 pm

will only search in amazon japan and not search any of the other amazons.

TLD
Posts: 24
Joined: Sat Jun 27, 2009 6:11 pm

Re: Auto Tag From Web (Bad Request)

Post by TLD » Sat Jun 16, 2018 12:04 am

If you read the whole thread, it's because of changes Amazon made. MediaMonkey is working right.
Amazon.co.jp is the only one which has retained the API.

Peke
Posts: 11043
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: Auto Tag From Web (Bad Request)

Post by Peke » Sat Jun 16, 2018 6:16 am

sinbaddylad wrote:
Thu Jun 14, 2018 7:02 pm
I've tried v5, same Bad Request. "HTTP/1.1 400 Bad Request"
If you are searching for TV Series then Video Files needs to be set to Type TV in order to do specific search for the type. But that is in MM5 as it have more sophisticated search
Best regards,
Pavle
MM Core Developer and Admin of free MediaMonkey extensions Hosting
Image
Image
How to add Images to forum

Post Reply