1828: Random stall when modifying several tags at once

To get bugs in the current release fixed, please report them here.

Moderator: Gurus

1828: Random stall when modifying several tags at once

Postby AnthonyM1229 » Tue Feb 21, 2017 10:32 pm

Twice this evening, 4.1.15.1828 stalled on me when I was modifying the tags of several songs at once. I wasn't even modifying that many--it was a batch of around 20 each time. Previous versions have let me handle 100+ at a time with only a very rare crash (like maybe once every few months on average).

I'd make changes in the "Edit Properties" window for a modest batch of tracks, and then I'd see the progress bar come up and gradually fill, as each tag gets saved. But then, somewhere in the middle, the progress bar stops, and then the whole MediaMonkey window becomes unresponsive. My current playing song will finish to the end, but then it won't advance to the next one, and will just loop the final 10 seconds or so (since I have it set to buffer a crossfade)--that's when I know for sure MediaMonkey is frozen. I end up having to kill it from my task manager, because it won't let me close properly from the menu bar or close button.

Because of this, and my other issue with the jump list media buttons missing for me, I've reverted to 1813 (I'm glad I backup my current installs before updating). I don't think I've ever had to backtrack before, but this issue definitely affects my productivity.

I'm running Windows 7 x64, with MediaMonkey in portable mode. If it matters, I deal exclusively with OGG files.

If further info is needed, I'll do my best to give it. I could also attempt to run a debug build if requested.
AnthonyM1229
 
Posts: 40
Joined: Fri Oct 14, 2011 2:59 pm

Re: 1828: Random stall when modifying several tags at once

Postby Lowlander » Wed Feb 22, 2017 1:16 am

Start with running File > Maintain Library with complete optimization checked.
Lowlander (MediaMonkey user since 2003)
Lowlander
 
Posts: 43467
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: 1828: Random stall when modifying several tags at once

Postby AnthonyM1229 » Wed Feb 22, 2017 10:02 am

Thank you, but I already do periodic complete optimization of my library, so I have a feeling that's not it, unless there were changes in 1828 that specifically affect the database? But if so, shouldn't it have prompted a DB upgrade or something like that upon install? I've seen that during a few upgrades, I guess with more major ones, though, like from 4.0.X to 4.1.X, perhaps.

Regardless, I won't be able to test that right now anyway, until my other issue with the missing media buttons is addressed, because I've gone back to using 1813 for now.
AnthonyM1229
 
Posts: 40
Joined: Fri Oct 14, 2011 2:59 pm

Re: 1828: Random stall when modifying several tags at once

Postby Lowlander » Wed Feb 22, 2017 12:39 pm

You're the only one reporting either issue right now. A debug log (step 4b) send to Support for either may be necessary to get it resolved: viewtopic.php?f=7&t=69
Lowlander (MediaMonkey user since 2003)
Lowlander
 
Posts: 43467
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: 1828: Random stall when modifying several tags at once

Postby AnthonyM1229 » Wed Feb 22, 2017 6:07 pm

I might have uncovered the cause for at least my other issue with the missing jump list media buttons. 1828 is detecting my Windows 7 install as Vista. I already submitted debug logs to the help desk. You can check that out at http://www.mediamonkey.com/support/inde ... -624-71246.
AnthonyM1229
 
Posts: 40
Joined: Fri Oct 14, 2011 2:59 pm

Re: 1828: Random stall when modifying several tags at once

Postby rusty » Wed Feb 22, 2017 10:10 pm

Hi Anthony,

The devs will have a look at the logs tomorrow, but fyi I tried to replicate for some time and was unable to. I tried as follows:

Play ogg file X
Select 60 tracks (including file X) and modify the Artist & Album Artist for all of them
--> success

Is there anything in particular that you were doing that you can think of that might help me replicate?

Thanks.

-Rusty
rusty
 
Posts: 7075
Joined: Tue Apr 29, 2003 3:39 am
Location: Montreal, Canada

Re: 1828: Random stall when modifying several tags at once

Postby AnthonyM1229 » Wed Feb 22, 2017 11:48 pm

Thanks, rusty.

I have a large number of albums from my early years of music collecting, that I had mistakenly tagged with no track numbers. So, I've been little by little, doing Auto Tag from Web to get the track numbers from Amazon, or Discogs, iTunes, or MusicBrainz (the latter three sources coming from extensions I added). I've also been gradually updating the genre on some of my songs (some of which may also have missing track numbers too). The genre changes, I do manually from the File Properties dialog--just pressing Shift+Enter on the song(s) I need to edit.

Let's say I modify the genre of 20+ songs. If I then select another set of songs and modify their genre and/or auto tag missing track numbers, while a previous operation is still ongoing (progress bar for synchronizing tags still active), that for me substantially raised the probability of the stalling behavior I describe. Such stalling was very rare before 1828. It would happen maybe once every few months or so, and usually would involve me prematurely aborting an Auto Tag from Web operation that I see is not returning any results at all or something wildly incorrect. However, 1828 stalled on me even when just doing genre modifications (again though, it's happened when I've modified a second set of songs while a previous set's tags are still synchronizing.)

I've previously been able to have 100+ pending synchronized tags with no issue. But to get a lock up twice in one evening when modifying far fewer songs at a time was disheartening.

I hope that helps. If you have any further questions, just let me know! Thanks for taking the time to look into this issue.
AnthonyM1229
 
Posts: 40
Joined: Fri Oct 14, 2011 2:59 pm

Re: 1828: Random stall when modifying several tags at once

Postby rusty » Thu Feb 23, 2017 12:33 pm

Hi Anthony,

I've still been unable to replicate the tag stall problem even by following the guidelines you wrote (thanks for that btw). Can you generate a debug log for that particular issue (or are the logs that you submitted via eSupport meant to cover both this issue and the Windows recognition bug)?

Thanks.

-Rusty
rusty
 
Posts: 7075
Joined: Tue Apr 29, 2003 3:39 am
Location: Montreal, Canada

Re: 1828: Random stall when modifying several tags at once

Postby AnthonyM1229 » Thu Feb 23, 2017 2:10 pm

Thanks for the reply. I'm currently running the debug build of 1829 linked in the thread of my other issue (which is fixed now by the way--my Windows 7 is detected correctly and I have my thumbnail preview and media buttons back), and have a log generating in the background.

I'll see throughout the rest of the day, if I run into any issues with stalling. I'm hoping it got taken care of in the process of addressing the OS validation issue, though.
AnthonyM1229
 
Posts: 40
Joined: Fri Oct 14, 2011 2:59 pm

Re: 1828: Random stall when modifying several tags at once

Postby AnthonyM1229 » Fri Feb 24, 2017 1:34 pm

After a full afternoon and evening of testing yesterday, I did not run into the stalling issue. At one point, I had 60+ tags pending synchronization, following maybe 3 or 4 genre and/or track number modifications in quick succession, and MM handled them like a champ, even with the overhead of gathering a debug log going on in the background. I guess this issue disappeared once the OS validation issue got fixed.
AnthonyM1229
 
Posts: 40
Joined: Fri Oct 14, 2011 2:59 pm

Re: 1828: Random stall when modifying several tags at once

Postby rusty » Sat Feb 25, 2017 7:32 pm

Great! Thanks for the update.

-Rusty
rusty
 
Posts: 7075
Joined: Tue Apr 29, 2003 3:39 am
Location: Montreal, Canada


Return to Bug Reports (mmw)

Who is online

Users browsing this forum: No registered users and 14 guests