Play from Windows Explorer slow [#12838]

To get bugs in the current release fixed, please report them here.

Moderator: Gurus

Play from Windows Explorer slow [#12838]

Postby Superk » Thu Nov 15, 2012 4:25 pm

I've found out what's causing the problem, but i'm not sure why. Originally it was the "Windows Select App", but when I told Windows to have MediaMonkey handle it the problem was fixed. The next problem I have - when attempting to open a new song (with MediaMonkey already running) it takes ~ 28 seconds. [Example: With MediaMonkey minimized (or in the background) I double click a song on my Desktop]. If I close out of MediaMonkey, and start the song it takes ~ 2 seconds (Normal - Waiting for program to start). I've disabled everything I could think of. Firewall, Antivirus, and I started going through all the processes and stopping them, including the audio process. So I was looking through the options and found Output Plug-ins (upon doing searching it seems plugins could cause this - I tried this after a complete uninstall / reinstall - same problem).
The current selection is MediaMonkey DirectSound output (out_MMDS.dll), I picked MediaMonkey WASAPI output (out_WASAPI.dll) [WITHOUT exiting out of MediaMonkey] problem was fixed. Once MediaMonkey is closed and reopened (even though the output is still WASAPI) the problem came back. I decided to retest the DirectSound, switched back and without exiting out of MediaMonkey problem was solved again. Once MediaMonkey is closed and reopened problem comes back. There's no issues if I drag the song onto MediaMonkey, or if I select the song within MediaMonkey.

Another weird thing, if I select a song (when it takes about 28 seconds), and exit out of the app, and start it normally (without opening a song), it starts right up and starts playing the song. If I try starting it with another song it seems like its polling something and takes ~30 seconds to start up, and then there's what ever songs I selected in the now playing list.

I don't know if any of this made any sense, but I figured i'd try and provide as much info as possible..

System Information:
Running Antivirus - Kaspersky PURE 2.0 (Even if disabled problem is still present)
Processor: Intel i7 2.67 GHz (No big change when problem is present)
Memory: 2.7 / 6GB (No big change when problem is present)
Hard Drive (2x 1.0TB - RAID 0, 7200rpm)
OS: Windows 8 x64
Sound Card: Creative Sound Blaster X-Fi Titanium Fatal1ty Professional Series
Sound Driver: High Definition Audio Device [7/25/12] [6.2.9200.16384] [Microsoft Windows]
* I keep this driver, as if I upgrade to Creatives driver (or the updated driver from microsoft) I lose audio on restart, and have to re-install the driver.*

Another update:
If I start MediaMonkey without a song, the problem doesn't happen.
I tried disabling all the enhancements, problem still occurs (if I open MediaMonkey by double clicking a MP3).


Problem does NOT occur in Windows Media Player.
Superk
 
Posts: 3
Joined: Thu Nov 15, 2012 4:21 pm

Re: Slow Media Changing - Windows 8

Postby Lowlander » Thu Nov 15, 2012 4:29 pm

Make sure you're running MediaMonkey 4.0.7.1511: http://www.mediamonkey.com/news/2012/11 ... -released/

If it still occurs it is a good idea to capture this in a debug log (step 4b) and send it to support: viewtopic.php?f=1&t=69
Lowlander (MediaMonkey user since 2003)
Lowlander
 
Posts: 43168
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Slow Media Changing - Windows 8

Postby Superk » Thu Nov 15, 2012 4:44 pm

Lowlander wrote:Make sure you're running MediaMonkey 4.0.7.1511: http://www.mediamonkey.com/news/2012/11 ... -released/

If it still occurs it is a good idea to capture this in a debug log (step 4b) and send it to support: viewtopic.php?f=1&t=69


First thing I tried was updating - Did a complete uninstall and re-install using the latest version 4.0.7.1511 - problem still happens. I've also submitted a debug log following the instructions provided.

Thanks!
Superk
 
Posts: 3
Joined: Thu Nov 15, 2012 4:21 pm

Re: Slow Media Changing - Windows 8

Postby mjh8815 » Sat Dec 15, 2012 12:52 pm

fix for me was always running Mediamonkey as administrator..this problem even exists with the latest verson 4.0.7.115. Also very wonky results with file association
mjh8815
 

Re: Slow Media Changing - Windows 8

Postby Superk » Mon Dec 17, 2012 2:19 am

mjh8815 wrote:fix for me was always running Mediamonkey as administrator..this problem even exists with the latest verson 4.0.7.115. Also very wonky results with file association


Awesome! That fixed it. Thanks! :D
Superk
 
Posts: 3
Joined: Thu Nov 15, 2012 4:21 pm

Re: Slow Media Changing - Windows 8

Postby rovingcowboy » Mon Dec 17, 2012 3:38 am

You have to remember win 8 is new and mm 4 is being updated to work on it, mm 4 was released to work on win 7, so they are in catchup mode like every other third party software company is. 8)
roving cowboy / keith hall. My skins viewtopic.php?f=9&t=16724 for some help check on Monkey's helpful messages at viewtopic.php?p=44008#44008 MY SYSTEMS.1.Jukebox WinXp pro sp 3 version 3.5 gigabyte mb. 281 GHz amd athlon x2 240 built by me.) 2.WinXP pro sp3, vers 2.5.5 and vers 3.5 backup storage, shuttle 32a mb,734 MHz amd athlon put together by me.) 3.Dell demension, winxp pro sp3, mm3.5 spare jukebox.) 4.WinXp pro sp3, vers 3.5, dad's computer bought from computer store. )5. Samsung Galaxy 5 Android 5) 6. Proscan tablet Android 4.3 ) 7. amd a8-5600 apu 3.60ghz mm version 4 windows 7 pro bought from computer store.
rovingcowboy
 
Posts: 14146
Joined: Sat Oct 25, 2003 7:57 am
Location: (Texas)

Re: Slow Media Changing - Windows 8

Postby rajusaha » Sun Jan 13, 2013 1:11 am

I am also having more or less similar kind of problem with adding a new file to the existing "Now Playing" list. Whenever I try to add a new file with the "Play Next In Mediamonkey" or "Play Last In Mediamonkey" option, the program freezes and after 30 seconds or so, the file finally gets added. Even running the programe as an administrator does not address this issue. Any help?
rajusaha
 
Posts: 2
Joined: Sat Jan 12, 2013 12:12 am

Re: Slow Media Changing - Windows 8

Postby Lowlander » Sun Jan 13, 2013 1:51 am

Run File > Maintain Library with complete optimization.

Do you have Auto-DJ enabled?
Lowlander (MediaMonkey user since 2003)
Lowlander
 
Posts: 43168
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Slow Media Changing - Windows 8

Postby rajusaha » Mon Jan 14, 2013 11:32 am

Lowlander wrote:Run File > Maintain Library with complete optimization.

Do you have Auto-DJ enabled?

Thanks for your reply, No, I don't have Auto-DJ enabled. And running File> Maintain Library with Optimize complete (database), doesn't solve the problem. I didn't have that problem in Windows 7.
rajusaha
 
Posts: 2
Joined: Sat Jan 12, 2013 12:12 am

Re: Slow Media Changing - Windows 8

Postby Lowlander » Mon Jan 14, 2013 11:50 am

If it still occurs it is a good idea to capture this in a debug log (step 4b) and send it to support: viewtopic.php?f=1&t=69
Lowlander (MediaMonkey user since 2003)
Lowlander
 
Posts: 43168
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Slow Media Changing - Windows 8

Postby Scully » Fri Jul 04, 2014 6:42 am

I have the same issue in Windows 8. If you start MediaMonkey via the start menu, then double click on files from within Windows Explorer, there is no issue.

However, if (with MM not running) you double click on an MP3 within Windows Explorer (which opens MM), then double click on another file from within Windows Explorer, it takes ages for MM to open it.

It's been ages since Windows 8 came out now, so this problem should have been fixed. I'm running no plug-ins and have deleted my app data directories. I've just updated to the latest version today and the issue persists. Even though I have a gold membership, I generally use VLC these days as I can't stand the dreaded wait to change playing song.
Scully
 
Posts: 1
Joined: Fri Jun 26, 2009 3:19 am

Re: Slow Media Changing - Windows 8

Postby mbvandeventer » Sun Sep 07, 2014 2:39 pm

I Have the same problem, when opening files from windows explorer I find that I'm waiting up to 3 minutes for the file to play - however when mediamonkey is already running the files play immediately.


any thoughts on this error? My old pc running windows 7 is immediate every time.

PC Specs:
New Asus
i7 Haswell
16gb Ram
windows 8 professional
mbvandeventer
 

Re: Slow Media Changing - Windows 8

Postby Anyone? » Sat Sep 13, 2014 4:49 pm

DOES ANYBODY REPLY TO THESE POSTS???
Anyone?
 

Re: Slow Media Changing - Windows 8

Postby Ghostkeeper » Mon Sep 15, 2014 6:10 pm

I had the same problem and found this topic. I tried letting the program always run as administrator, but that completely broke OS integration for me altogether. Tracks wouldn't even play when I double-clicked them while MM was closed. I disabled the always-run-as-administrator thing again.

I've found a solution though! One that worked for me at least.

Go to tools -> Options and then OS Integration.
The "Show context-menu actions for:" things were all off for me, but when I right-click an MP3 file it would still show these three options. I turned them on, clicked on OK, accepted the COM elevator dialogue.
Then I went to tools -> Options again and turned them back off, clicked OK.
These 3 context-menu options are gone now (I didn't like them there anyways).

And then it worked!

I hope this helps future users and perhaps gives the developers an idea where the problem lies. I'm on windows 8.1.
Ghostkeeper
 

Re: Slow Media Changing - Windows 8

Postby Hamp » Sat Nov 15, 2014 1:38 am

Ghostkeeper, you are a genius! Thank you. this was driving me crazy! I have Windows 8.1 and Mediamonkey with Gold Lifetime license.

Blessings!

Hamp
Hamp
 

Next

Return to Bug Reports (mmw)

Who is online

Users browsing this forum: No registered users and 7 guests

cron