Play from Windows Explorer slow [#12838]

To get bugs in the current release fixed, please report them here.

Moderator: Gurus

Pally

Re: Slow Media Changing - Windows 8

Post by Pally » Sun Dec 28, 2014 11:03 am

Ghostkeeper wrote:I had the same problem and found this topic. I tried letting the program always run as administrator, but that completely broke OS integration for me altogether. Tracks wouldn't even play when I double-clicked them while MM was closed. I disabled the always-run-as-administrator thing again.

I've found a solution though! One that worked for me at least.

Go to tools -> Options and then OS Integration.
The "Show context-menu actions for:" things were all off for me, but when I right-click an MP3 file it would still show these three options. I turned them on, clicked on OK, accepted the COM elevator dialogue.
Then I went to tools -> Options again and turned them back off, clicked OK.
These 3 context-menu options are gone now (I didn't like them there anyways).

And then it worked!

I hope this helps future users and perhaps gives the developers an idea where the problem lies. I'm on windows 8.1.
Awesome. Worked for me too. Thank you

Bbrock

Files slow loading

Post by Bbrock » Sat May 02, 2015 12:54 pm

I have Windows 8.1 and downloaded the most recent version of MMG, when I select a file MMG will bring up the file and play quickly, but then when I select another file from my desktop it takes about 15-20 seconds to load before it will play the song. Anyone know how this can be fixed?

rpsgc
Posts: 37
Joined: Fri Aug 07, 2009 4:29 pm
Location: Portugal

Re: Slow Media Changing - Windows 8

Post by rpsgc » Sun Aug 09, 2015 12:41 pm

I had this problem in Windows 8.1... and now I also have this problem in Windows 10! Ghostkeeper's tip seems to have fixed the issue but I don't know for how long. Bottom line, though, is that it's been almost 3 years since this has been reported and not even a peep from the developers.
"MediaMonkey Gold: Lifetime" user, since Oct 2011

Anesthesiologist
Posts: 8
Joined: Mon Aug 02, 2010 7:59 am
Location: Phoenix, AZ

Playing of music files hang on double click in file explorer

Post by Anesthesiologist » Sun Aug 30, 2015 9:18 am

Hi!

I am running Windows 10 on both my Desktop and Laptop. I noticed something odd. On my old computer, people I decided to import a song into media monkey, I would double click on it, Media Monkey would open it immediately and it would play. Now, all of a sudden, I double click on the song, and file explorer hangs (with the blue circle) for a good 15 seconds before Media Monkey plays it.

I tried setting the song to open with other media players to see if the issue is the same and it's not. It only happens with media monkey. This definitely wasn't happening under Windows 7.

Additionally, this issue doesn't persist once the song is actually imported in the library. In this instance, the song plays right away. :roll:
Last edited by Lowlander on Mon Aug 31, 2015 10:18 am, edited 1 time in total.
Reason: Merged with existing post

MMFrLife
Posts: 2774
Joined: Fri Oct 26, 2012 9:04 pm

Re: Playing of music files hang on double click in file expl

Post by MMFrLife » Sun Aug 30, 2015 1:09 pm

What happens if you right-click it in explorer and click on Play Now (provided you have MM set to use context menu)?
MM user since 2003 (lifetime since 2012) "Trying to imagine life without music gives me a headache"
track properties; dir/fn mask configurations; check out ZvezdanD's scripts
MMW 4.1.18.1842b; fav scripts > RegExp Find & Replace 5.1.0; Magic Nodes 5.1.0; Advanced Duplicate Find & Fix 3.8.2;
Backup 6.0; Clear Now Playing Button 1.2
...always back it up, especially before doing anything major!!!
Win. explorer alt. for power users [free]; great file/folder renamer [used by nasa]

Lowlander
Posts: 44736
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Play from Windows Explorer slow

Post by Lowlander » Mon Aug 31, 2015 10:22 am

Lowlander (MediaMonkey user since 2003)

PracticalIllusion

Re: Play from Windows Explorer slow [#12838]

Post by PracticalIllusion » Fri Oct 09, 2015 9:46 am

All of you, there is a solution, which has been published here: http://www.mediamonkey.com/forum/viewto ... =7&t=68586

Thanks to GhostKeeper who posted:
"Go to tools -> Options and then OS Integration.
The "Show context-menu actions for:" things were all off for me, but when I right-click an MP3 file it would still show these three options. I turned them on, clicked on OK, accepted the COM elevator dialogue.
Then I went to tools -> Options again and turned them back off, clicked OK.
These 3 context-menu options are gone now (I didn't like them there anyways)."

This seems to work perfectly!

oneway23

Re: Play from Windows Explorer slow [#12838]

Post by oneway23 » Tue Oct 27, 2015 12:44 pm

PracticalIllusion wrote:All of you, there is a solution, which has been published here: http://www.mediamonkey.com/forum/viewto ... =7&t=68586

Thanks to GhostKeeper who posted:
"Go to tools -> Options and then OS Integration.
The "Show context-menu actions for:" things were all off for me, but when I right-click an MP3 file it would still show these three options. I turned them on, clicked on OK, accepted the COM elevator dialogue.
Then I went to tools -> Options again and turned them back off, clicked OK.
These 3 context-menu options are gone now (I didn't like them there anyways)."

This seems to work perfectly!
Just wanted to say a direct and hearty thanks to GhostKeeper for resolving this issue for us. It had been driving me absolutely bonkers since I upgraded to Windows 10 at the end of July. Cheers!

rmk12

Re: Play from Windows Explorer slow [#12838]

Post by rmk12 » Fri Nov 06, 2015 3:56 pm

Thank you ghostkeeper. Your fix works with Windows 10

torinohito

Re: Play from Windows Explorer slow [#12838]

Post by torinohito » Thu Jan 21, 2016 3:57 pm

I had this problem and now mine is fixed as well. Those pesky context menus!!!

kisetsu1024

Re: Play from Windows Explorer slow [#12838]

Post by kisetsu1024 » Thu Mar 17, 2016 9:25 am

Ghostkeeper, I have been having this problem on WIndows 10 v. 4.1.11.1783 standard, and turning off the context menus also fixed this for me! Thanks!

schoofi

Re: Play from Windows Explorer slow [#12838]

Post by schoofi » Sat Sep 03, 2016 9:50 am

September 2016 and issue still exits (under Windows 7 though!). Issues resolved by ticking options off and on ;-)

M0nk3yBoy
Posts: 6
Joined: Wed Nov 23, 2016 12:12 am

Re: Play from Windows Explorer slow [#12838]

Post by M0nk3yBoy » Thu Feb 23, 2017 5:27 am

Would be nice if the context menus worked, this is the only reason I returned my lifetime gold license....

Peke
Posts: 11203
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: Play from Windows Explorer slow [#12838]

Post by Peke » Sat Feb 25, 2017 9:25 pm

Hi,
This should be finally fully fixed in 4.1.15.1830 and above.

Thank you all for reports that wasa really strange one as Windows constantly tried to forcefully start full MMW instead of just sending command line for playback.

Context Menu included.
Best regards,
Pavle
MediaMonkey lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add Images to forum

dtsig
Posts: 2833
Joined: Mon Jan 24, 2011 6:34 pm

Re: Play from Windows Explorer slow [#12838]

Post by dtsig » Sat Feb 25, 2017 10:00 pm

Just tried this on win10 and it was within a second or 2 .. pretty sweet. This is when mmw was not running ..

With mmw running an playing it appears to still be taking 25+ seconds for a track to start playing or to be added to playlist

Using 1830
Where's the db and ini stored
Reporting Bugs
Where tags are stored

Not affiliated with MediaMonkey ... just a RABID user/lover
DTSig

Post Reply