MMW Playlist problem

Beta Testing for Windows Products and plugins

Moderator: Gurus

spikerweb
Posts: 7
Joined: Sun Mar 14, 2010 11:10 am
Location: Toronto, Canada

MMW Playlist problem

Post by spikerweb » Fri Dec 06, 2013 3:51 pm

MMW Playlist problem, I have had this problem since 2008. Not sure if it gets reported here. When selecting a single track > properties > classification, MMW would appear to freeze (not respond). I never reported the problem, but know it has something to do with the playlists, I backed up my database and delete the playlists the freeze does not occur. I went as far as to create a batch file that kills MMW and mini lyrics then restarts MMW. I became used to not selecting classification with only one track selected. Works fine with multiple selections.
Today while testing MMW 4.1, I thought I would try it out and instead of the freeze the classification window opened and the playlists section displayed "Loading..." 15 minutes later it displayed the 10 or so playlists related to the selected track.
I have never counted my playlists but it's 100 or so. Most are auto which search other playlists and criteria before they are generated. I tried deleting groups of them to try and pinpoint the problem, but I must be creating some sort of maze for it to take 15 minutes to display the Playlists results. Has anyone reported this problem? is there a fix without deleting my playlists?

Note: I tried it with a recently added track and it only took 2 minutes to display the list of 6 playlists.

Lowlander
Posts: 46194
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: MMW Playlist problem

Post by Lowlander » Fri Dec 06, 2013 6:29 pm

Have you tried File > Maintain Library with complete optimization?
Lowlander (MediaMonkey user since 2003)

spikerweb
Posts: 7
Joined: Sun Mar 14, 2010 11:10 am
Location: Toronto, Canada

Re: MMW Playlist problem

Post by spikerweb » Fri Dec 06, 2013 8:37 pm

Yes, I have used it numerous times and did it again after 4.1 install. At least with 4.1 I can select other property tabs and close properties without the program appearing to freeze. It only happens with my main DB which was created on 4/5/08. It might be time rebuild my playlists because most of my playback devices have changed since 08.

rovingcowboy
Posts: 14153
Joined: Sat Oct 25, 2003 7:57 am
Location: (Texas)
Contact:

Re: MMW Playlist problem

Post by rovingcowboy » Sat Dec 07, 2013 4:26 pm

just change the options settings for sync'ing the devices that should work 8) instead of redoing all the playlists.

but since you have tons of list's are they all auto lists? you know the static playlists are kept in the database file and will increase the size of the database file, this has the effect of making mm take longer to read the database., if you have a fast system it doesn't hurt much but one core is slow and takes forever with static playlists.
if you need the static lists i suggest giving the page file more room and also use a third party program to manage the prioritys and set the mm exe one on higher or realtime, then set the decoder.exe in mediamonkey's program files folder to higher or realtime, this will allow it to run faster too. think of it like a lumber yard saw mill.
the exe is the motor, the process code is the saw blade and the data is the log. the slower the motor and blade run the less logs get cut. speeding up the motor and blade will cut them faster and clear out the log jam backing up at the mill entrance.

just don't speed up any windows system files or programs they don't like it. 8)
roving cowboy / keith hall. My skins http://www.mediamonkey.com/forum/viewto ... =9&t=16724 for some help check on Monkey's helpful messages at http://www.mediamonkey.com/forum/viewto ... 4008#44008 MY SYSTEMS.1.Jukebox WinXp pro sp 3 version 3.5 gigabyte mb. 281 GHz amd athlon x2 240 built by me.) 2.WinXP pro sp3, vers 2.5.5 and vers 3.5 backup storage, shuttle 32a mb,734 MHz amd athlon put together by me.) 3.Dell demension, winxp pro sp3, mm3.5 spare jukebox.) 4.WinXp pro sp3, vers 3.5, dad's computer bought from computer store. )5. Samsung Galaxy 5 Android 5) 6. Proscan tablet Android 4.3 ) 7. amd a8-5600 apu 3.60ghz mm version 4 windows 7 pro bought from computer store.

spikerweb
Posts: 7
Joined: Sun Mar 14, 2010 11:10 am
Location: Toronto, Canada

Re: MMW Playlist problem

Post by spikerweb » Sat Dec 07, 2013 9:25 pm

Computer speed does not seem to be an issue. The 2 computers I have tested on are miles apart in terms of performance and speed. Both took the same time to display the results.
I have always synced by playlist selection and have never had an issue with syncing if the device was supported by MM.
I didn't realize that I have closer to 300 playlists, just kept adding over the years and never deleting.. >95% are auto.
When I deleted my biggest tree 85 auto playlists an 3 static playlists. The loading time was reduced to 4 seconds.
Most of the playlists have 4-6 criteria, show 200 at most, and 2 sorts. I remember adding the "show 200 tracks at most" to almost all of the auto playlists when trying to fix the problem. It didn't help.

Ludek
Posts: 3049
Joined: Fri Mar 09, 2007 9:00 am

Re: MMW Playlist problem

Post by Ludek » Tue Dec 10, 2013 5:07 pm

You troubles are caused by complex auto-playlists, if there are many complex auto-playlists (e.g. auto-playlists referencing further auto-playlists referencing further auto-playlists) then the resulted SQL is very complex and it slows things down (especially on large databases).

So the solution is to simplify the auto-playlists as you have already found.

rovingcowboy
Posts: 14153
Joined: Sat Oct 25, 2003 7:57 am
Location: (Texas)
Contact:

Re: MMW Playlist problem

Post by rovingcowboy » Wed Dec 11, 2013 6:49 pm

He must have very compounded auto lists Ludek if he only has 100 and this is happening because i'm up over 500 auto playlists and have no trouble loading them. 8)
roving cowboy / keith hall. My skins http://www.mediamonkey.com/forum/viewto ... =9&t=16724 for some help check on Monkey's helpful messages at http://www.mediamonkey.com/forum/viewto ... 4008#44008 MY SYSTEMS.1.Jukebox WinXp pro sp 3 version 3.5 gigabyte mb. 281 GHz amd athlon x2 240 built by me.) 2.WinXP pro sp3, vers 2.5.5 and vers 3.5 backup storage, shuttle 32a mb,734 MHz amd athlon put together by me.) 3.Dell demension, winxp pro sp3, mm3.5 spare jukebox.) 4.WinXp pro sp3, vers 3.5, dad's computer bought from computer store. )5. Samsung Galaxy 5 Android 5) 6. Proscan tablet Android 4.3 ) 7. amd a8-5600 apu 3.60ghz mm version 4 windows 7 pro bought from computer store.

Post Reply