FiiO X7, MMA , and Google Problems and Solutions

Get answers about the current release of MediaMonkey for Android

Moderator: Gurus

joepet
Posts: 16
Joined: Sun Sep 27, 2009 1:28 pm
Location: Oakland, California

FiiO X7, MMA , and Google Problems and Solutions

Post by joepet » Wed Jan 09, 2019 1:13 pm

MediaMonkey and FiiO X7; Married At Last

But I can’t say it hasn’t been a struggle. If you are the parents of this proposed marriage, you should read every single word of this because it will save you hours of frustration. MediaMonkey is the most fabulous digital media player and media library application I know of. I have been using it for many, many years. I have it now on my Desktop running Windows 10. I have about 50,000 songs and short movie sound bites mostly in flac which takes up about 470 Gigs. Big music collection, not the biggest, however I do have a unique feature….I have about 40, very long playlists of popular music and in between each song I have a very short sound bite from a movie, it is really quite entertaining. I have the music arranged chronologically by year from 1950 to 1990. Some of these playlists are 1000 files long and it took a long time to create them. So when I decided I wanted a mobile digital player, it had to be one I could just sync to incorporate these playlists and definitely NOT recreate them.

I started out many years ago with an iPod classic which had 120 gigs. So right away a problem: Apple did not like flac and so I converted all my files that I wanted to sync into Apple lossless and using itunes I was able to get my complex playlists from MediaMonkey onto the iPod without recreating them, but it was a long, complex process. Before you say there are easier ways to do that now, please remember this was years ago when MediaMonkey was just a young chimpanzee. Let me say at this point that comparing itunes to MediaMonkey is like comparing a Model T to a Lamborghini.

My old iPod finally died while I was taking off on the runway at SFO leaving for vacation! Grrrr! Sooo I searched for a new digital player and finally bought a FiiO X7. Stupid me, I never noticed that the FiiO X7 was not specifically listed on the MediaMonkey website as a supported device….BTW it still isn’t (except as an Android Device). I figured it was Android and so it would work with MediaMonkey….well it does but it was not without some problems. I have been working with desktops for years so I am very comfortable with them. I am not a big portable device guy….I have an iPhone 3 that was given to me and it spends 99.99% of its life in my desk drawer…turned off…. so the world of Android is foreign to me and I did not know the key role that Google played in all this….so it really it is not a marriage but rather a Ménage à Trois: MediaMonkey, FiiO X7 and Google!

I could not believe I had to go to the Google Play Store to download MMA. I would have thought I would download it from the MediaMonkey site….just like the desktop version. I thought: I don’t go to the Microsoft site to download the desktop version, why should I have to go to the Google site to download MMA? But that is the way it is. The first problem was I had difficulty syncing using USB. I discovered that syncing with WiFi worked better, so that is what I used. I purchased MMA Pro for 4 dollars to WiFi sync……is that why Google has its fingers in the pie, so they can make money?

I eventually got it all working fine and then FiiO offered an upgraded OS from FW2.0 to 3. something. This also upgraded the Android from 4.4.4 to 5.1 and so I upgraded and just resynced everything….like 180 gigs worth. So great, I upgraded and ran into a curious and fatal problem: My music played fine….but as soon as it played one of the short movie bite files, all subsequent files (no matter short or long or mp3 or flac) would execute but with no sound. If I restarted everything was OK until I played one of the short files again and then the problem reappeared. I went around and around and around and around with FiiO on this (I still have all the emails) and I even sent them the files and they said the files played just fine. The only problem was they were not playing them on MMA. They eventually just ignored me and I don’t blame them….they were not duplicating my situation so they saw no problem.

FiiO encouraged me to use their native music App but I would have to recreate my complex playlists….besides that, their native music player does not begin to compare to MMA, I will spare you the details. If I was FiiO I would dump their native music player and embrace MMA, but I suppose there are reasons to not do that as a company, but as a customer, there is no doubt as to the vast superiority of MMA on the FiiO X7.

So I went back to the FW2.0 FiiO OS and Android 4.4.4, resynced everything and all was well.
BTW FiiO offered several subsequent OS upgrades, I repeated what I just described several times and the fatal flaw was always there, so I am stuck with FW2.0 which works just fine.

All was well for more than a year ….remember the third part of this marriage?: Google. Google who I always had the highest regard for…I use Chrome, my email is .gmail.com etc. All of a sudden about a few months ago (the end of 2018), I start getting this message: “Unfortunately, Google Play Services has stopped. “ That would not be so bad, but Google decided to deliver that message about every 2 or 3 seconds and you would have to click OK before you could do anything else. Soooo I just deleted the Google Play Services app….well no good, MMA requires Google Play Services for some reason which escapes me…maybe it is the 4 dollars . So I reload it and, of course, I am getting the $%#^*%^@ message again. Besides being very frustrating, the odd thing was that MMA kept working….so if what you need stops, why do you keep working?

This was a disaster, my wonderful marriage was destroyed….and for once it was not because of something I did….I did nothing.

BTW if you look on the web there are lots of fixes for “Unfortunately, Google Play Services has stopped. “….I tried them all and none worked. I finally figured out that Google auto updated Google Play Services over WiFi and the new version was having problems with Android 4.4.4 (I guess), which I am locked into as I previously explained. So I finally uninstalled the updated version of Google Play Services and installed a previous version (see P.S.) from the website Uptodown. That worked, no more nasty messages…..then a few hours later the messages returned…sure enough good ole Google updated my Google Play Services. So I repeated the process and once I had the old version installed I shut off my WiFi…..it is not a phone, and the only reason I use WiFi is to sync. BTW if you turn off auto updates in Google Play, it still updates Google Play Services which made me want to strangle someone at Google.

Sooo whenever I synced over WiFi, Google seldom missed a chance to upgrade (ha) Google Play Services and then the frustrating and annoying messages would start again…..so I would uninstall Google Play Services and that would stop the messages but then MediaMonkey would not work, so I would reinstall the old Google Play Services (and quickly turn off WiFi!) and everything would be great.

So I did this several times (whenever I synced) and then one time when I tried to install the old Google Play Services, I got this lovely message: “Parse Error-There was a problem parsing the package.” And so no installation and no MediaMonkey, no nothing. I looked up the possible solutions to this on the internet and the easy solutions did not work and the difficult ones, involving downloading a debugging app and really going into the guts of things, scared the crap out of me. I reasoned that the solution should be simple….It was: It turns out that all my downloads (like 20 of them) of the old Google Play Services apk had accumulated in my downloads folder and that caused the parse problem. I cleared them, downloaded and installed the old Google Play Services and everything is fine…..of course I turned off my WiFi. Having my WiFi off is not a problem, this is a music player, not a cell phone….Also I am about at the limit of my 200 Gig chip and I have all the music and playlists that I want and everything is working perfectly….so my need/capacity to sync is very low, and if I have to sync and Googles does its usual dirty work, I know how to fix things. Besides, as we all know, there has been practically no good music created after 1990. 

I am posting this on the MediaMonkey and the FiiO websites and sent this to Google (no, I don’t expect them to change) and I hope it helps someone avoid the problems and frustrations I have had.

Joe


P.S. This is what works on the FiiO X7:

Google Play Services 12.8.80
Google Play Store 12.9.12-all[0] [PR] 224566662
Google Account Manager 4.0.4-299894
MediaMonkey 1.3.3.0842
MediaMonkey Pro 1.1.0008
FW 2.0
Android 4.4.4