Page 1 of 1

MM8 crashes when trying to connect to MMW UPNP

PostPosted: Mon Jul 27, 2015 2:30 am
by sn0skier
So I have my my library server set up on MMW, and it works when I connect to it inside of MMW. However, everytime I try to connect to it in MM8, MM8 crashes and restarts.
Here are some issues that I think might be relevant:
1. I am trying to connect the MM8 app to a MMW server that is running on the same machine. I am doing this because I want MM8's library to mirror my MMW library (I don't want to have to scan for tracks in MM8).
2. I recently used the Locate Moved/Missing files so that Mediamonkey would use my new drive instead of my old one.
3. My files are now all on an almost full MicroSDXC 128GB card.
4. Before trying to connect to the server I tried to install MMW server as a service using the inbuilt option in MMW. I received this error "The service did not start due to a logon failure." I tried again and got some error, so I deleted the service entry from the registry, and restarted. I tried again to install it as a service and received the same logon error. If someone could help me with this, that would be great, but it is not my main issue. I deleted the registry key again and restarted several times, so I don't know why this would affect MM8, but whatever.
5. My library is too big? I mean I can't imagine that is it with only ~20,000 tracks, but maybe?

I tried to connect to the server while wifi was disconnected, to make sure it wasn't a problem with my router, and I received the same error message.
I'm on a Surface Pro 3 running Windows 8.1

Re: MM8 crashes when trying to connect to MMW UPNP

PostPosted: Wed Jul 29, 2015 12:55 am
by sn0skier
So, I captured the debug from DebugView:

Code: Select all
00000190   34.58538055   [2080] 34.625 [3752] - TSOAPBrowser::DoBrowseAction ControlURL:, ObjectID: 0   
00000191   34.58557510   [2080] 34.625 [3752] - TSOAPBrowser::DoHttpPost: URL:   
00000192   41.60452652   [2080] 41.640 [3752] - TSOAPBrowser::DoBrowseAction: StatusCode = 200   
00000193   41.60472107   [2080] 41.640 [3752] - TSOAPBrowser::DoBrowseAction: Load into parser   
00000194   53.00081253   [3664] CRightPaneView::UpdateLayout: executed in 0.000005 sec   
00000195   56.08315659   [2864] 0.031 [2356] - MediaMonkey for Modern UI (x86) Version   
00000196   56.14830017   [2864] 0.109 [2356] - Launched...   
00000197   56.35464478   [2864] 0.312 [2356] - Application showed

Maybe a mod could tell me if this should be moved to the bugtracker forum?

Re: MM8 crashes when trying to connect to MMW UPNP

PostPosted: Wed Jul 29, 2015 3:58 am
by sn0skier
I guess I should mention that I just tested, and I can connect to DLNA just fine from my android phone. I can also see it inside MMW. I'm only having problems with MM8. Please help?

Re: MM8 crashes when trying to connect to MMW UPNP

PostPosted: Wed Jul 29, 2015 4:06 pm
by sn0skier
Just realizing that while I can see my upnp server in the upnp section, it isn't showing up in the sync servers section. Maybe these problems are related? Also, I got MMW DLNA to run as a service, all I had to do was change the password/user settings in task manager--services tab.

Anyone have an idea why I can't connect to the upnp, and why it doesn't even show up in the sync servers of MM8?