Current Android Auto Bugs/Issues (Build 863, AA: 4.5.592854) [#15679]

Report bugs & feature requests for MediaMonkey for Android and learn about the newest beta build.

Moderator: Gurus

oblivioncth
Posts: 62
Joined: Thu Oct 27, 2016 5:50 pm

Current Android Auto Bugs/Issues (Build 863, AA: 4.5.592854) [#15679]

Post by oblivioncth » Mon Jan 28, 2019 2:44 pm

IMO Severity:
Brown= Minor Issue
Orange = Moderate Issue
Red = Major Issue

Bugs

1) After starting up Android Auto for the first time due to just having plugged into the car, when I switch into MediaMonkey on the head unit there is no meta data whatsoever, similar to the previous bug. Once I change tracks the meta data then starts being loaded correctly. Not a huge issue

Logs:
ZZQLCP81QX - Added 5/25/19

2) Once in a blue moon when booting up AA on my head unit and going into MMA, the now playing shortcut in the tray is gone and replaced with the downvote button. Obviously that's just a coincidence and is more of a matter that if any button is gone one will be pulled out of the 3 dots "more menu" since that's how android handles toolbars.

I think it happens if I haven't used MediaMonkey on my phone for a long time and then plug the phone into my car, so that Android Auto has to launch the process itself. The Now Playing button doesn't appear just when I start playing, but does reappear after I start playing AND switch the head unit focus to some other AA page and then back to MediaMonkey.

You can see this in the same image I used to show the previous bug in which artwork was missing under the "Resolved" section.

Logs:
IUS9RSWJ6Z - Added 5/7/19

Polish/Features

1) It would be nice if there was an option to display a few bits of additional info for the current track, like genre, or at least a button to get to that info like properties option within regular MMA. It could be added within the 'more' button on AA next to the rate and shuffle/loop buttons.

2) Tiny issue. No way to rate songs with half-star precision. Not a big deal since ratings songs while driving is of minimal importance, but I just figured I'd throw it out there since I make heavy use of half-star ratings. So, if I ever did feel like changing a rating while stopped or something, I'd most likely have to pull out my phone.

Android Auto Limitations (Consider MMA Changes to Better Deal With Them)

1) Its impossible to search for songs with weird names (common in EDM). For example, no matter how many ways I try to pronounce it differently, assistant always thinks I'm saying "Iowa" instead of the desired "Aiwa". I know this is more of an assistant issue, but perhaps at some point it would be possible to add an option to spell out a track name (if assistant allows this kind of Intent). I know voice search optimization is already a consideration for 2.0. While I understand that fixing this is more Google's responsibility, it is such a MASSIVE headache that in the meantime it would be cool if this could somehow be improved via different search mechanics on the MMA side of things (such as in 2.0).

Resolved

Confirmation Level:
Green = 100% confirmed to be fixed
Brown= Issue has not occurred for quite some time
Orange = Issue has not occurred for a little while
Red = Only brief testing performed

FIXED AS OF BUILD 856
1) Not sure if its something with my library, but the "Artist" list on AA never loads, just shows the loading circle infinitely. Currently I have 1041 Artists. All other views load in a second or two, including "Albums", of which I have 985 (1000+ issue perhaps? I saw something on the forums with a greater than 500 problem)

Logs:
RZ21AX1B2J - Added 5/25/19
It takes a while to load but it does now seem that the artist view loads in AA for me.

FIXED AS OF BUILD 856
[color=#]4)[/color] This may be a bug with Android Auto, but it also could be that AA handles this automatically yet MM acts thinking it isn't handled automatically and therefore cancels out the effect. Often when I receive or make a phone call when the call ends the music automatically starts playing again only for it to pause itself less than a second later.

Logs:
W21SUTUA5N
11QMUK8R3M - added 5/26/19
FIXED AS OF BUILD 850:
1) No artwork is shown when the app is full screen on the head unit, its just black. Artwork does work in the mini-view when you're on the home screen of AA. You guys are already aware of this, just figured I'd reiterate it here.

Image
Picture is awkward since my phone needed to be plugged into the car.
FIXED AS OF BUILD 850:
1b) As of Android Auto "4.1.590944-release" no meta data is present in the head unit display whatsoever.
Pure limitation of AA, doesn't make sense to show tracks when only 12 or so could be seen:
1) This may not be a bug and just another safety thing that you can't change, I'm not sure. Anyway, when you select the "Tracks" view, it only gives the option to "Play" or "Play (shuffle)" and doesn't actually show any of the tracks.
Finally confirmed this is an AA issue as it also happens with VLC. Very annoying :/
5) Similar to a previous issue on MMA, the artwork showed on the head unit is sometimes incorrect and inconsistent with what is shown in the player on the phone itself. In this example the artwork wasn't even from a previous track or another song in the playlist, it was completely wrong:

Image

There is no correlation between the wrong and correct artwork. Will test if this happens with other media players ASAP, and get more logs of this when I can (hard since its while I'm driving). Like the issue of the "Now Playing" button not being present, if I change app focus on the head unit and then go back to MediaMonkey the artwork will change to the correct artwork; in fact, sometimes you can see it happening if you watch close enough, though other times the artwork is already correct right when the MediaMonkey view pops in.

Logs:
V59MREY15Y - Added 4/25/19
Device Info

MMA: 1.3.4.0856
Android Auto: 4.3.591854
Galaxy S7 Edge 8.0 (Oreo)
Last edited by oblivioncth on Wed Sep 04, 2019 9:36 pm, edited 23 times in total.

Lowlander
Posts: 45993
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Android Auto Bugs/Issues (Build 846)

Post by Lowlander » Mon Jan 28, 2019 2:54 pm

Lowlander (MediaMonkey user since 2003)

oblivioncth
Posts: 62
Joined: Thu Oct 27, 2016 5:50 pm

Re: Android Auto Bugs/Issues (Build 846)

Post by oblivioncth » Mon Jan 28, 2019 5:14 pm

Was aware you were tracking the first one, was not aware of the second. Though, do you believe the same bug to be at fault for the second? Since I have over 500 albums yet that loads fine. Someone in that thread mentioned having double digit thousands so I will guess thats a yes.

oblivioncth
Posts: 62
Joined: Thu Oct 27, 2016 5:50 pm

Re: Android Auto Bugs/Issues (Build 846)

Post by oblivioncth » Wed Jan 30, 2019 2:01 pm

Added one more issue, 8.

Peke
Posts: 12273
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: Android Auto Bugs/Issues (Build 846)

Post by Peke » Wed Jan 30, 2019 7:01 pm

8. should be handled with https://www.ventismedia.com/mantis/view.php?id=15261 as Android Oreo/Pie changed behavior on system level and MMA gets confused Can you try to replicate with 845?
Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum

oblivioncth
Posts: 62
Joined: Thu Oct 27, 2016 5:50 pm

Re: Android Auto Bugs/Issues (Build 846)

Post by oblivioncth » Sat Feb 02, 2019 5:30 pm

Peke wrote:
Wed Jan 30, 2019 7:01 pm
8. should be handled with https://www.ventismedia.com/mantis/view.php?id=15261 as Android Oreo/Pie changed behavior on system level and MMA gets confused Can you try to replicate with 845?
Should probably confirm I am on Oreo (8.0) on an S7 Edge.

Is there a repo I can use to easily roll back to 845 or did you mean something else?

oblivioncth
Posts: 62
Joined: Thu Oct 27, 2016 5:50 pm

Re: Android Auto Bugs/Issues (Build 846)

Post by oblivioncth » Mon Feb 11, 2019 7:34 pm

9th, minor issue added.

oblivioncth
Posts: 62
Joined: Thu Oct 27, 2016 5:50 pm

Re: Android Auto Bugs/Issues (Build 846)

Post by oblivioncth » Fri Mar 22, 2019 3:25 pm

Marked issues 1 and 1b as solved. No strikethrough available so I used quotes instead.

Peke
Posts: 12273
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: Android Auto Bugs/Issues (Build 846)

Post by Peke » Fri Mar 22, 2019 7:50 pm

Please retest with latest beta.
Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum

oblivioncth
Posts: 62
Joined: Thu Oct 27, 2016 5:50 pm

Re: Android Auto Bugs/Issues (Build 846)

Post by oblivioncth » Fri Mar 22, 2019 8:00 pm

Peke wrote:
Fri Mar 22, 2019 7:50 pm
Please retest with latest beta.
You mean the issues other than 1 and 1b? I will certainly go through them all. I'm pretty sure the artist plane not loading is still an issue. Will test each next time I'm in the car, and will work on getting logs for the remaining issues.

oblivioncth
Posts: 62
Joined: Thu Oct 27, 2016 5:50 pm

Re: Android Auto Bugs/Issues (Build 846)

Post by oblivioncth » Thu Apr 25, 2019 12:27 am

Added 10th issue. Added logs for some issues.

Peke
Posts: 12273
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: Current Android Auto Bugs/Issues (Build 855)

Post by Peke » Thu Apr 25, 2019 6:24 am

Hi,
Thx, Analyzing. Can you do a small compare with other apps in order to check debug baseline?
Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum

oblivioncth
Posts: 62
Joined: Thu Oct 27, 2016 5:50 pm

Re: Current Android Auto Bugs/Issues (Build 855)

Post by oblivioncth » Thu Apr 25, 2019 3:05 pm

Do you mean play songs on android auto via another media player and see if the issue with the albumn art occurs there as well?

Peke
Posts: 12273
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: Current Android Auto Bugs/Issues (Build 855)

Post by Peke » Thu Apr 25, 2019 4:02 pm

Hi,
Yes exactly. I tried to replicate on my phones and Car HeadUnit (Android Based) and had no issues with Album Art showing, I am guessing the problem may arise when AA is sent to display as in teh past common issue for that is Album Art format support where PC and some Devices allowed even GIF along with high res PNG and JPG while others do not allow them and limit to 500x500 or less.
Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum

andytij
Posts: 2
Joined: Wed Jul 04, 2018 8:26 pm

Re: Current Android Auto Bugs/Issues (Build 855)

Post by andytij » Thu May 16, 2019 5:08 am

I have issue 2 as well, either connected to the car or just launching media monkey through android auto app sat in my flat, choose artist or Album and you just get a spinning yellow ring.

Post Reply