Page 80 of 98

Re: Backup 5.8 - Updated 27/10/2010

Posted: Mon Feb 10, 2014 5:32 am
by brianon
This script is 'exactly' what I need at the moment. I can't get it to work correctly though.

It only ever pastes the metadata for the first file. Then I get a msgbox with "Error executing script event. Permission denied.".
If i just copy/paste 1 track instead of multiple it copies the metadata but then spits out the msgbox with the error.

Any ideas ?

**Getting the following now when I run MM as admin.
Error #70 Vbscript runtime error. Permission denied. Line 5294, Column 10.

Re: Backup 5.8 - Updated 27/10/2010

Posted: Wed Feb 12, 2014 3:58 am
by trixmoto
I'm not sure you've posted this to the right thread, this script doesn't copy and paste metadata.

Re: Backup 5.8 - Updated 27/10/2010

Posted: Mon Feb 24, 2014 12:18 am
by john hack
I have tried this with MM 4.1 on WIN 8 and nothing seems to happen
Am I doing something wrong

john

Re: Backup 5.8 - Updated 27/10/2010

Posted: Mon Feb 24, 2014 8:41 am
by nohitter151
john hack wrote:I have tried this with MM 4.1 on WIN 8 and nothing seems to happen
Am I doing something wrong

john
Did you set it up at Tools > Scripts > Backup?

Re: Backup 5.8 - Updated 27/10/2010

Posted: Fri Feb 28, 2014 11:48 pm
by john hack
Has this been tested with win 8. It does not seem to do anything for me at all

Re: Backup 5.8 - Updated 27/10/2010

Posted: Fri Feb 28, 2014 11:50 pm
by john hack
sorry. I am asking if backup 5.8 works with win 8 because i cant get anything to happen

john

Restore script incomplete

Posted: Sat Mar 01, 2014 4:34 am
by lizat
I have trixmito's backup utility. However I don't think it;s right since the vb script it produces looks like this:

Set shl = CreateObject("WScript.Shell")
Set fso = CreateObject("Scripting.FileSystemObject")
path = fso.GetParentFolderName(WScript.ScriptFullName)
user = Replace(shl.ExpandEnvironmentStrings("%USERPROFILE%")&"\","\\","\")
user = InputBox("Enter Windows user directory:","Backup 5.8 - Restore",user)
If user = "" Then WScript.Quit
appl = Replace(shl.ExpandEnvironmentStrings("%PROGRAMFILES%")&"\MediaMonkey\","\\","\")
appl = InputBox("Enter MediaMonkey directory:","Backup 5.8 - Restore",appl)
If appl = "" Then WScript.Quit
then many "NULLs"

every one is like this except one from several months ago which looks correct. What might be wrong and how can I correct it?

thank you........................ liz

Re: Backup 5.8 - Updated 27/10/2010

Posted: Sat Mar 01, 2014 4:54 am
by popsmike
Did you try what nohitter151 suggested above your latest posts.

Re: Backup 5.8 - Updated 27/10/2010

Posted: Sun Mar 02, 2014 4:10 pm
by trixmoto
I've not tested it on Windows 8, because I don't have a Windows 8 machine.

Re: Backup 5.8 - Updated 27/10/2010

Posted: Tue Mar 04, 2014 3:51 pm
by lizat
Hi Trix,

I am on Windows 7. I have many backups and almost all have incomplete restore scripts and the MM db is reported as corrupt. What could have caused this? I have used it for years and assumed it was ok, it runs on close and reports completion.

liz

Re: Backup 5.8 - Updated 27/10/2010

Posted: Sat Mar 08, 2014 2:58 pm
by trixmoto
In what way are the scripts incomplete? The database is just file copied, so I don't see how it could be corrupted.

Re: Backup 5.8 - Updated 27/10/2010

Posted: Sat Apr 05, 2014 12:44 am
by MyCsPiTTa
Hi,

I've just done a fresh install of windows and MM, along with backup 5.8.

In backups options Output Archive is greyed out - I remember in the past some zipping file needed to be installed, but that usually gave some error upon back rather than a greyed box.

Re: Backup 5.8 - Updated 27/10/2010

Posted: Sun Apr 06, 2014 10:41 pm
by gpzbc
MyCsPiTTa wrote:Hi,

I've just done a fresh install of windows and MM, along with backup 5.8.

In backups options Output Archive is greyed out - I remember in the past some zipping file needed to be installed, but that usually gave some error upon back rather than a greyed box.
I could be wrong, but the reason why you can't tick the archive boxes is because you need to register your zip dll. Check out this post.http://www.mediamonkey.com/forum/viewto ... 40#p373857

Re: Backup 5.8 - Updated 27/10/2010

Posted: Mon Apr 07, 2014 6:07 am
by MyCsPiTTa
gpzbc wrote:
Gretchen wrote:Okay - new problem :-)
I don't think I have my backup settings setup correctly. I am unable to check "Output Archive."
It sounds like you need to register your dll. See this post:
http://www.mediamonkey.com/forum/viewto ... bc#p258498

But that was the instructions for MM 3.XX. And now on MM 4.XX, your dll is stored at "C:\Users\XXXX\AppData\Roaming\MediaMonkey\Scripts\XZip.dll"

So, on MediaMonkey 4.XX, the new instructions are:

a. Open command prompt by typing cmd.exe into start menu.
b. right-click on the command prompt shortcut and select "Run as administrator"
c. Input this command: regsvr32 "C:\Users\XXXX\AppData\Roaming\MediaMonkey\Scripts\XZip.dll"

I hope that helps!
My problem is exactly the same as Gretchen's, but when I try your suggestion, the "module fails to load", and actually I cannot find xzip.dll in the folder you specify (or, in fact, on my C drive at all) - Is there a was to install this dll?

EDIT: I downloaded XZip.dll from the web and put it in the folder above, then followed your instructions to register it. Now the Output Archive box can be ticked and the backup works perfectly !

Re: Backup 5.8 - Updated 27/10/2010

Posted: Mon Apr 07, 2014 9:58 pm
by DMLCo
I almost fainted with joy when I saw the description of this script, and eagerly downloaded it ... running it produces a MM dialog box that says Backup Was Not Installed. Any ideas?