Page 2 of 3

Re: NEW! AutoRateAccurate 3.0 (22/09/2013) - for MM4

PostPosted: Mon Sep 29, 2014 6:46 pm
by rovingcowboy
john-nicholas wrote:In case you haven't figured it out already, keep your back-up copy of the vbs in a folder far away scripts\auto folder.

Good luck! :D


made a folder in the scripts folder called not used i keep them in there have since day one of starting with scripts in mm. nothing going wrong yet. but i'll go back and change it to a txt file just to make sure it won't run.
8)

strange thing though last night i ran it and found 2500 songs to rate. this morning it started and found 7000 more to rate and nothing played between the two times?

Re: NEW! AutoRateAccurate 3.0 (22/09/2013) - for MM4

PostPosted: Sat Oct 04, 2014 11:23 am
by rovingcowboy
Didn't work. It marked all songs as unrateable. What is wrong with this after 5 yrs? Well I am trying it now with just the one line that pops up the message box being commented out. That keeps the message alert off and it is rating the songs now so we'll see how it works out.

Re: NEW! AutoRateAccurate 3.0 (22/09/2013) - for MM4

PostPosted: Sun Oct 05, 2014 4:53 pm
by rovingcowboy
Yes just putting the. ' in front of the one line that has the command to show the message alert fixed it here. Had to do that to both the message lines.

Re: NEW! AutoRateAccurate 3.0 (22/09/2013) - for MM4

PostPosted: Sun Oct 05, 2014 5:53 pm
by john-nicholas
rovingcowboy wrote:Yes just putting the. ' in front of the one line that has the command to show the message alert fixed it here. Had to do that to both the message lines.


I tried that originally, but it didn't work for me :(

But that's not important right now-- it's working for you :D

Best of luck rating your collection!

Re: NEW! AutoRateAccurate 3.0 (22/09/2013) - for MM4

PostPosted: Mon Oct 06, 2014 12:24 pm
by rovingcowboy
john-nicholas wrote:
rovingcowboy wrote:Yes just putting the. ' in front of the one line that has the command to show the message alert fixed it here. Had to do that to both the message lines.


I tried that originally, but it didn't work for me :(

But that's not important right now-- it's working for you :D

Best of luck rating your collection!

Thank you. Umm ? Didn't work for you. .. must be something to do with the op sys version. Or hardware. Yeah in re rating my songs cause all the rates of the last 5 yrs were reset but the play count wasn't.

Re: NEW! AutoRateAccurate 3.0 (22/09/2013) - for MM4

PostPosted: Mon Oct 06, 2014 6:33 pm
by john-nicholas
RC.

I realized I didn't do what you did...I used a ; instead of a ' on the offending lines :o

Now, I have done what you did-- It worked! Your solution works better than mine did! :D

It's all good here...no issues with ratings, past or present.

Congrats and Thanks!

Re: NEW! AutoRateAccurate 3.0 (22/09/2013) - for MM4

PostPosted: Tue Oct 07, 2014 2:14 am
by rovingcowboy
Wow my own error appears then to have happened in order to get yours fixed. God works in strange and mysterious ways. Doesn't he.
glad you got yours fixed.

Re: NEW! AutoRateAccurate 3.0 (22/09/2013) - for MM4

PostPosted: Wed Jan 14, 2015 10:13 am
by rovingcowboy
posting in this auto rate thread even though I found this on mm 3 auto rate, it might still be doing it on mm 4 auto rate.

if you are using auto rate with the option to rate songs after they have been played, and you are getting strange things to happen like mm just stop playing or closing down, or other programs stopping such as the msagents djamp dj program, on xp or possible win 7 if you got any other programs that run by active x or win script and they are acting up when you play music.

Turn off the option for auto rate to rate the songs after they have been played. only use the option to rate them on start up. for some reason that option to rate after songs have been played is messing with the win script and active x programs and scripts.

8)

Re: NEW! AutoRateAccurate 3.0 (22/09/2013) - for MM4

PostPosted: Fri Jan 23, 2015 9:25 pm
by rovingcowboy
rovingcowboy wrote:posting in this auto rate thread even though I found this on mm 3 auto rate, it might still be doing it on mm 4 auto rate.

if you are using auto rate with the option to rate songs after they have been played, and you are getting strange things to happen like mm just stop playing or closing down, or other programs stopping such as the msagents djamp dj program, on xp or possible win 7 if you got any other programs that run by active x or win script and they are acting up when you play music.

Turn off the option for auto rate to rate the songs after they have been played. only use the option to rate them on start up. for some reason that option to rate after songs have been played is messing with the win script and active x programs and scripts.

8)

have to quote myself here.

in the above last line says ( for some reason, )

I found the reason so it might not be doing it on your systems but keep a look out for this because it is a sign of things to come.
it foreshadowed my pc chips motherboard going out.. could not even boot up. no beep just flashing lights on all the dvd drives and the usb back up as it was trying to find someplace to boot from, it just ignored the backup so something was messed up on the pc chips board. If you look in the my signature a lot you will notice now I'm down one system, I yanked the motherboard from my old work system which was built like a tank and it is now in my jukebox.,
I thought I should just come back to this thread and post what was the reason for my errors in case you all were wondering. 8)

Re: NEW! AutoRateAccurate 3.0 (22/09/2013) - for MM4

PostPosted: Sun Feb 22, 2015 11:07 am
by Tiago.rubio
Hi guys, is there any script that would make the ratings % to applied only within the same Genre?

You I have a lot of Genres so I dont want only some of them to have 5 stars.

I would like to have POP 5 start and the Rock 5 Stars an etc...

Appreciate the help!

Cheers,

Re: NEW! AutoRateAccurate 3.0 (22/09/2013) - for MM4

PostPosted: Sat Sep 12, 2015 12:52 pm
by Big_Berny
Hi guys
I just wanted to let you know that I didn't forget about AutoRateAccurate. I really hop that I find some time again to improve. I learned a lot about recommendation engines the last years so I have a few new ideas. :)

But at the moment I'm very busy with another project – a completely new keyboard app for Android and iOS. If you want to have a look: https://www.kickstarter.com/projects/40 ... o-keyboard

I'll try to release a 3.1 version though where I remove the code which seems to crash MediaMonkey.

Best
Big_Berny

Re: NEW! AutoRateAccurate 3.0 (22/09/2013) - for MM4

PostPosted: Thu Sep 17, 2015 9:37 pm
by rovingcowboy
Good to hear from you. :D

Re: NEW! AutoRateAccurate 3.0 (22/09/2013) - for MM4

PostPosted: Sun Sep 20, 2015 4:49 pm
by umfunix
I've installed the latest AutoRateAccurate with no success. Now my MediaMonkey is just messed up and ARA won't uninstall :(

Re: NEW! AutoRateAccurate 3.0 (22/09/2013) - for MM4

PostPosted: Sun Sep 20, 2015 6:07 pm
by rovingcowboy
So you got auto rate stuck in the computer i read your other post and the script error is the same as we have worked out in one of these 2 threads about a year ago just find those posts and do the fix that I did it should stop that error. Then you just save the script you fixed in a different folder. Reinstall auto rate then copy the fixed script in to the proper folder for auto rate to use it will overwrite the new script with your fixed one so it will work.

Re: NEW! AutoRateAccurate 3.0 (22/09/2013) - for MM4

PostPosted: Mon Sep 21, 2015 9:32 am
by umfunix
rovingcowboy wrote:So you got auto rate stuck in the computer i read your other post and the script error is the same as we have worked out in one of these 2 threads about a year ago just find those posts and do the fix that I did it should stop that error. Then you just save the script you fixed in a different folder. Reinstall auto rate then copy the fixed script in to the proper folder for auto rate to use it will overwrite the new script with your fixed one so it will work.


Thanks. Will check and fix.