Page 17 of 26

Re: Last.fm Scrobbler help

Posted: Mon May 06, 2013 2:20 pm
by jomtones
Ah ok - I'll get rid of that .dll and try again, many thanks.

Re: Last.fm Scrobbler help

Posted: Mon May 06, 2013 9:41 pm
by Peke
Let me know if you have any issues on reinstalling it.

Re: Last.fm Scrobbler help

Posted: Tue May 07, 2013 12:07 pm
by Sh1bby
Hey Peke,
thanks for this awesome plugin.
I set up a media server with MM 4, so my family can access my library. Problem is that all the songs they listen to (by streaming) also get scrobbled. Of course I don't want their songs in my last.fm profile. ;) Is there a way to ignore these songs?
I tried scrobbling with "gen_wa2_scrobbler.dll", which ignores the streamed songs. But I have mostly asian music, so unicode support is a must.

Thank you!

Re: Last.fm Scrobbler help

Posted: Tue May 07, 2013 12:10 pm
by Lowlander
Upgrade to MediaMonkey 4.1 beta from the Beta forum and disable Update Play Counter in the Media Server options in MediaMonkey. This will also stop last.fm scrobbling for the Media Server.

Re: Last.fm Scrobbler help

Posted: Tue May 07, 2013 12:39 pm
by Sh1bby
Woah, that was fast & it's working. Thanks a lot Lowlander!

Re: Last.fm Scrobbler help

Posted: Tue May 07, 2013 4:50 pm
by jomtones
Ok well I deleted any stray lastFM dll's and reinstalled with the .mmip ... general plugins now shows 'gen_LastFMScrobbler.dll' but still - no options :/

Weird.

Re: Last.fm Scrobbler help

Posted: Sun May 12, 2013 10:28 am
by Tetsujin
Over a year later and the native MM scrobbler still doesn't work for me. It randomly scrobbles some songs, and doesn't others. They still show up as "listening now" in my profile but don't get scrobbled once they're finished. Both MM and the scrobbler are the latest version and the log always shows "Submit OK" even though it didn't submit at all.
I have been using the Winamp plugin instead but that one doesn't seem to support Unicode...@.@

Re: Last.fm Scrobbler help

Posted: Sun May 19, 2013 7:20 pm
by Peke
If You do not see options can you try to add/edit this section to Mediamonkey.ini and fill correct info:

Code: Select all

[Last.FM]
Log1=
Log2=
Log3=
Log4=
Log5=
OptionSheetID=1
Enabled=1
OnlyWithAlbumTagged=1
NowPlaying=1
ForceHandshake=0
Status=1
EnableToolbarIcon=1
ScrobbleOnlyLibrary=0
MultipleArtist=0
LogToFile=1
Username=
Password=
CacheOnly=0

Last.fm scrobbling status

Posted: Wed May 22, 2013 9:04 am
by Barry4679
The status of MMW's scrobbling status is confusing IMO.

I have the widget on the tool bar. If I hover over it the tool-tip shows that there are 3 status settings, and I see that each click toggles to the next setting.

There is no way to determine the current status setting, rather than the widget's colour (which isn't documented anywhere I can find).

Trial and error indicates that red indicates No Scrobbling. This is confusing as the widget icon is the LFM Scrobbler icon, and its official colour is red. So red could been seen as active.
see here: http://www.last.fm/download

I see that Tools|Options|Library|Last.fm has a checkbox for LFM submission, so that presumably indicates ScrobbleEnable & ScrobbleDisable, but I can't see any indication or control showing whether scrobbles are being cached. So the only indication seems to be the undocumented and ambiguous colour of the toolbar button

It would be good if the toolbar button tool tip displayed the current status, and the options dbox showed the cache setting.

Also the Clean Cache button is confusing. There is no confirmation that it does anything. ie. there is no indication that the cache has any entries before I press it, and therefore I can't see that it is now clear. The Refresh button still shows the last 5 entries, and the Show Log File facilities is still populated, and the cache clear operation is not logged.

Re: Last.fm scrobbling status

Posted: Wed May 22, 2013 10:11 am
by nohitter151
Barry4679 wrote:The status of MMW's scrobbling status is confusing IMO.

I have the widget on the tool bar. If I hover over it the tool-tip shows that there are 3 status settings, and I see that each click toggles to the next setting.

There is no way to determine the current status setting, rather than the widget's colour (which isn't documented anywhere I can find).

Trial and error indicates that red indicates No Scrobbling. This is confusing as the widget icon is the LFM Scrobbler icon, and its official colour is red. So red could been seen as active.
see here: http://www.last.fm/download
The default is the green icon so its pretty safe to assume that green = active submit. Not to mention it really only takes about a minute of trial and error to figure out what does what.

Re: Last.fm Scrobbler help

Posted: Wed May 22, 2013 10:23 am
by Ashran
Trouble
I have a trouble with mediamonkey 4 and last.Fm . After a few track successfuly scrobbled, it stops scrobbling until I restarts mediamonkey. I recently upgraded my mediamonkey 4 to a beta version (after the problem began a few weeks ago), since then I tried updating my plugin by reinstalling it, by installing an old winamp plugin to use the offical last fm scrobbler software but the symptoms remain the same: a few dozen track get scrobbled, but after a while, it stops all together functionning: in the case with the scrobbler software it looks like mediamonkey stops sending it the change of tracks.

What can I do ?

Re: Last.fm Scrobbler help

Posted: Tue Jun 04, 2013 9:58 am
by stan9980
I'm having the same issue as Ashran. I noticed that MM 4.0.7.1511 wasn't scrobbling music this morning but initially put it down to listening to music (which should be scrobbled) immediately after listening to a podcast (which I don't scrobble). I restarted MM and everything was back to normal.

After leaving MM in the background for a couple of hours doing nothing I started listening to music again. No scrobbles and the log shows nothing since the morning. Again after a restart everything is working.

I've also noticed that the log will say that its skipping the track as it's not in the library, even though it is.

I can't think of any change I've made to my system to cause this, I'm baffled.

stan9980

Re: Last.fm Scrobbler help

Posted: Tue Jun 04, 2013 10:14 am
by Lowlander
Did you add the tracks from an outside source to the Now Playing (even though they're in the Library)?

Re: Last.fm Scrobbler help

Posted: Tue Jun 04, 2013 10:29 am
by stan9980
No, I added them from inside MM after using the MM search box. Right-clicked on the album I was after did one of the play options (I forget which).

Re: Last.fm Scrobbler help

Posted: Tue Jun 04, 2013 1:07 pm
by stan9980
Since my last post everything had been running and scrobbling fine. I paused the track I was listening to so I could answer my phone and come back 20 minutes later. The music plays but the track I had been part way through was not scrobbled when it finished and neither was the track after it. The log shows no activity.

I restarted MM, expecting the problem to go away, continue playing the tracks I had already lined up in the now playing playlist and immediately checked the log, signs of activity (handshaking with last.fm, etc) but the track is being skipped as it's not in the library. Only it is MM shows a last played date of last year and the track has been part of my library for the last 4 years.

Double-clicking on a couple of other files already in the now playing playlist causes the scrobbling to work normally. Clicking on the problem track results in the 'skipping track' entry in the log.

I rescanned the folder containing the track which wasn't in my library. 0 tracks were added but double-clicking on the file again in the playlist causes scrobbling to work properly again.