Page 34 of 37

Re: Custom Report 3.1 - Updated 25/10/2013

Posted: Sun Jul 20, 2014 4:38 pm
by trixmoto
Thanks, I'm glad you've found it useful.

Re: Custom Report 3.1 - Updated 25/10/2013

Posted: Tue Jul 29, 2014 3:50 am
by Wav3481
websrchr wrote:Thank you very much for this Script, Trixmoto.

I just downloaded and installed the newest version 3.01, which I am testing and found some small difficulty.

I just can not figure out how to format a field to get the excel report to display the duration of the songs in the same format as MM does. For example, MM correctly displays a couple of the songs as: "2:49" and "4:37", while the report shows "169096" and "277109" respectively, when using SongLength.

But if I use SongLengthString, the report shows them as: "12:02:49 AM" and "12:04:37 AM".

Do you have any suggestions?

Thanks again.


I have developed this same issue of duration with my win 7 32 bit and using MM version 4.1.3.1708 unregistered...of AM showing up...had no such issues with my XP machine...so,I downloaded & installed custom report version 2.7 and the report is perfect:):)Wav3481

Re: Custom Report 3.1 - Updated 25/10/2013

Posted: Tue Jul 29, 2014 5:47 am
by trixmoto
I think I'm going to have to do some work on this. In version 2.7 "SongLengthString" was just reported unformatted, but there were complaints that this was breaking the Excel report, so I added some code to format it. However, the code that formats it uses your localised time setting, so it will translate "0:00:01" into "12:00:01 AM", if this is how your localisation is set.

I think I'll put "SongLengthString" back to the unformatted value in the next version, and add "SongLengthTime" which is always formatted as "H:MM:SS", ignoring people's localisations, and maybe "SongLengthLocal" as well which does use the localised string. Then you can choose which you prefer.

Re: Custom Report 3.2 - Updated 29/07/2014

Posted: Tue Jul 29, 2014 5:10 pm
by trixmoto
New version (3.2) is now available to download from my website. Changes include...

- Fixed SongLengthString back to unformatted value
- Added SongLengthTime and SongLengthLocal with formatted values

Hopefully this will give people a few different options.

Re:

Posted: Fri Aug 01, 2014 10:35 pm
by Alvaro Mera
Error #2147023741 - File c:\program files\mediamonkey\scripts\customreport.vbs Line 457 Column 6

AFter clicking "ok"

"Error happened during script execution: No application is associated with the specified file for this operation"

Click on "ok" and the error message goes away

**** But I have figured this out..... my error!
I was assigning a file name but not a directory, I thought it would just save to the scripts folder by default. Once I clicked on the /\ and selected a directory the script works perfectly.
I got into the same error, same column 6, but different line when using version 3.2 on MM 4.1.3.1708, under Win 8.1.

I was trying to save in "xlsx" and also tried "xls" without success, but when I tried "csv", the report went through and my problem was solved. Didn't try the other options.

Re: Custom Report 3.2 - Updated 29/07/2014

Posted: Sun Aug 03, 2014 1:33 am
by trixmoto
This means that you don't have an application registered to handle the .xls and .xlsx extensions. Do you have Excel or another spreadsheet software installed?

Re: Custom Report 3.2 - Updated 29/07/2014

Posted: Sun Aug 03, 2014 11:04 am
by popsmike
I'm having a similar problem, I don't use Microsoft but i do use Apache Open Office and it is set to open "XLS" files normally which it does.
when trying to export as an "XLS" through custom report it give an error.

https://www.dropbox.com/s/jxz1evwcpkrcb ... report.JPG

if this helps.

Re: Custom Report 3.2 - Updated 29/07/2014

Posted: Sun Aug 03, 2014 12:02 pm
by Alvaro Mera
trixmoto wrote:This means that you don't have an application registered to handle the .xls and .xlsx extensions. Do you have Excel or another spreadsheet software installed?
Yes, I do have Office 2007 in the same computer and I use Excel regularly, even with the "cvs" format generated by Version 3.2, which I usually file later on in "xls" format. However there may be a related issue, because every time I open any Office application, it always goes into the configuration process, but when it finishes, everything is normal. I will reinstall it soon. Thanks for your reply.

Re: Custom Report 3.2 - Updated 29/07/2014

Posted: Tue Aug 05, 2014 10:42 am
by popsmike
@Trixmoto

FYI I have backtracked to version 2.0 and it is still the same.
Im guessing either Open Office is the problem not associating properly or monkey not recognising the fact its there.

Re: Custom Report 3.2 - Updated 29/07/2014

Posted: Tue Aug 05, 2014 4:31 pm
by trixmoto
It's not MediaMonkey, it's Windows that isn't recognising the extension. It calls an OS command using the WScript Shell object, which is the same as using the "Run" command box.

Re: Custom Report 3.2 - Updated 29/07/2014

Posted: Wed Aug 06, 2014 3:33 am
by popsmike
Okay do you know of a way around this?

Re: Custom Report 3.2 - Updated 29/07/2014

Posted: Fri Aug 08, 2014 2:56 am
by trixmoto

Re: Custom Report 3.2 - Updated 29/07/2014

Posted: Fri Aug 08, 2014 1:43 pm
by popsmike
trixmoto wrote:You could try this... http://superuser.com/questions/587129/h ... -windows-8
Thanks for taking the time to look for this Trixmoto, I went through it methodically but doesn't help, but thanks anyway.

I will spend a few night trolling through the web to see if I can find something.

Re: Custom Report 3.2 - Updated 29/07/2014

Posted: Mon Oct 20, 2014 2:20 pm
by Bernhard
Hi,

I tried to format the date output string but do not manage to get it working..

Some of my taggings have year only, some mm.yyyy and some dd.mm.yyyy.

If I like the output to be:

yyyy
yyyy-mm
yyyy-mm-dd

what kind of date export field and format string I have to use?

thx a lot,
Bernhard

Re: Custom Report 3.2 - Updated 29/07/2014

Posted: Mon Oct 20, 2014 3:14 pm
by trixmoto
If you try "DY-m-d" as the format, what happens for the dates that only have year specified?