Page 33 of 37

Re: Custom Report 3.1 - Updated 25/10/2013

Posted: Mon Nov 11, 2013 3:13 pm
by trixmoto
My pleasure - it works as you expect now?

Re: Custom Report 3.1 - Updated 25/10/2013

Posted: Tue Nov 12, 2013 9:46 am
by Onweerwolf
Yes it does! :D

Error when installing custom report31 addon

Posted: Mon Dec 30, 2013 9:32 pm
by meatsean
I recently up graded to win 8.1. I reinstalled Media Monkey Gold v 4.0.7.1511 with no issues. I tried to install the custom report addon but get the following error message:

cannot create file c:\program files x86\media monkeys\scripts\scripts\scripts.ini. Access is denied.

variant or safe array is locked.

How can I resolve issue? Also how can I post error messages on the board. (typing is not favorite thing)

Thank you

Sean

Re: Error when installing custom report31 addon

Posted: Tue Dec 31, 2013 10:04 am
by nohitter151
When you install the addon, make sure to keep the check box "Install for the current user only" checked to avoid this error.

Re: Error when installing custom report31 addon

Posted: Tue Dec 31, 2013 9:19 pm
by meatsean
The check box "install for current user only" is greyed out so I cannot select the option.

Re: Error when installing custom report31 addon

Posted: Wed Jan 01, 2014 2:39 pm
by nohitter151
meatsean wrote:The check box "install for current user only" is greyed out so I cannot select the option.
I don't know why that is, but to get around that you will need to start MM as the administrator. Right click the MM icon, Run as > Administrator

Re: Error when installing custom report31 addon

Posted: Wed Jan 01, 2014 3:55 pm
by meatsean
I tried running as administrator but check box "install for current user only" is still greyed out.
I reinstall MM Gold but the message below comes up when I try to run custom report:

Error #7 - Microsoft VB script runtime error. Out of memory. fso folder exist.

Re: Error when installing custom report31 addon

Posted: Wed Jan 01, 2014 4:13 pm
by meatsean
Problem seem to be solve now. Went into options, OS integration, and unchecked re associate file types at start up. Don't know what this all means but custom reports is working as it should.

Re: Custom Report 3.1 - Updated 25/10/2013

Posted: Thu Jan 23, 2014 2:23 am
by websrchr
Thank you very much for this Script, Trixmoto.

I just downloaded and installed the newest version 3.01, which I am testing and found some small difficulty.

I just can not figure out how to format a field to get the excel report to display the duration of the songs in the same format as MM does. For example, MM correctly displays a couple of the songs as: "2:49" and "4:37", while the report shows "169096" and "277109" respectively, when using SongLength.

But if I use SongLengthString, the report shows them as: "12:02:49 AM" and "12:04:37 AM".

Do you have any suggestions?

Thanks again.

Re: Custom Report 3.1 - Updated 25/10/2013

Posted: Fri Jan 24, 2014 3:52 am
by trixmoto
That's odd, because I fixed this in version 3.1 - are you sure you have the latest version installed? Excel must be adding the AM/PM bit, because my script doesn't do that - maybe it's something to do with your localisation settings?

Re: Custom Report 3.1 - Updated 25/10/2013

Posted: Mon May 26, 2014 4:55 pm
by JoePublic
I'm in the process of moving to a new PC. I downloaded and installed the current version of MM. (I had been using version 3.2.5 on the old PC). I downloaded and installed Custom Report 3.1. (I had been using version 2.9.)

I attempted to recreate the one & only report I run on a regular basis. It uses the report element SongLengthString, and there is a problem with that element.

In version 2.9, SongLengthString would return the duration of a track as text and would look like 4:10 if the song was 4 minutes 10 seconds long or 13:50 if the track was 13 minutes 50 seconds long. Now in version 3.1 (or perhaps the problem is with the newer MM version?), those same tracks are displaying as 12:04:10 AM in the first case and 12:13:50 AM in the second case. As one can see, the correct value is embedded in the returned text, but for some reason it thinks that the track time is an offset from 12:00:00 AM as a time of day. :(

Can this be fixed? I hope!

Edit: Oops! I just noticed that someone 2 posts earlier also had a problem with the same item. Let me add some additional info. My report exports to HTML (not Excel, as the earlier poster did). The 12:04:10 AM style formatting clearly appears in the resulting htm file. And I did download the current version of the report from trixmoto.net just an hour or so ago.

Re: Custom Report 3.1 - Updated 25/10/2013

Posted: Fri May 30, 2014 5:05 pm
by JoePublic
Following up my post from Monday, I uninstalled Custom Report 3.1 and installed the version I had been using, Custom Report 2.9. Version 2.9 treats the SongLengthString properly, showing the Carpenters' "Top of the World" as "2:58", instead of "12:02:58 AM" as 3.1 shows for me. The report exports to HTM format. I'm using the current MM 4 release on Win 8.1.

Re: Custom Report 3.1 - Updated 25/10/2013

Posted: Fri Jun 13, 2014 9:08 am
by dalarath
JoePublic wrote:Following up my post from Monday, I uninstalled Custom Report 3.1 and installed the version I had been using, Custom Report 2.9. Version 2.9 treats the SongLengthString properly, showing the Carpenters' "Top of the World" as "2:58", instead of "12:02:58 AM" as 3.1 shows for me. The report exports to HTM format. I'm using the current MM 4 release on Win 8.1.
Hi Joe, I've just installed Custom Report 3.1 on MMW 4.1.1.1703 Gold and I don't have the problem you mentioned. I've created reports in .txt .html and .xls and the time (SongLengthString)is displayed correctly in all of them (e.g. 0:03:27). Running on Win 7 x64 Ultimate.

Great work, trixmoto.

Re: Custom Report 3.1 - Updated 25/10/2013

Posted: Fri Jun 13, 2014 10:44 am
by JoePublic
Hmmm. That seems very odd, Dalarath. Thanks for reporting your experience. I also have MMW 4.1.1.1703 Gold, a clean install, non-roaming, running on Win 8.1 x64 Pro. I wonder what might cause you & I to get different results? I'll play with it some more when I get time.

Re: Custom Report 3.1 - Updated 25/10/2013

Posted: Tue Jul 15, 2014 6:38 pm
by Stuart Studebaker
Just want to say THANK YOU for this script. It rocks. verily.