Album Art Tagger 5.2 - Updated 26/10/2013

Download and get help for different MediaMonkey Addons.

Moderators: Peke, Gurus

Re: Album Art Tagger 5.2 - Updated 26/10/2013

Postby Guest » Thu Nov 19, 2015 2:49 am

I have all the images in mediamonkey, what do i need to do to get them in itunes?


Use iTunes.
Guest
 

Re: Album Art Tagger 5.2 - Updated 26/10/2013

Postby macmcd » Wed Feb 24, 2016 9:08 pm

A strange problem that I am hoping Album Art Tagger can help me with. I run two separate libraries, the main one consists of tracks in a variety of formats that I then sync as mp3 files to my NAS library. The problem is that a lot of the FLAC tracks from the original library are synced without their artwork. Sometimes whole albums lose their art and sometimes it is individual tracks within an album that lose it. Normally it would be easy to identify the files with the 'Files to Edit\Unknown Artwork' node but the MediaMonkey NAS library thinks that the tracks have the artwork. By this I mean that if you right click on the Artwork you have the '☑ Image 1: Cover (front)' menu item at the top but upon selecting 'Edit Artwork Properties...' there is no artwork! So these tracks do not show up in either 'Missing Artwork' or 'Inconsistent Artwork' nodes.

If I try to run an Album Art Tagger operation such as 'Remove artwork which is invalid' it correctly identifies that there is no artwork to remove. So Album Art Tagger can tell which tracks don't have artwork but MediaMonkey can't. Therefore, I'd like to run an operation that would reset the MediaMonkey pointer so that it would then identify those tracks without artwork. I'm not sure if it is possible, but it would save an awful lot of time.

Many thanks,
Mac.
macmcd
 
Posts: 91
Joined: Wed Jul 09, 2008 7:22 am

Re: Album Art Tagger 5.2 - Updated 26/10/2013

Postby Peke » Sat Feb 27, 2016 3:51 am

Why do not you sync tags from MMW library to tags anyway?

It is strange that you in art and details see artwork but in properties do not, especially as properties are related to Art and details with only one exception where MMW automatically search for Artwork but do not save it to tags (See options for automatic lookup).
Best regards,
Pavle
MM Core Developer and Admin of free MediaMonkey extensions Hosting
Image
Image
How to add Images to forum
Peke
 
Posts: 10714
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia

Re: Album Art Tagger 5.2 - Updated 26/10/2013

Postby macmcd » Sun Feb 28, 2016 4:56 pm

I only want the embedded artwork synced to the NAS as I generally have a lot of artwork that may be inlays or incorrectly sized that I have edited before embedding.

It is only a problem when converting flac files. The artwork does not show up in the 'Show Art with Details' view, the problem tracks have the generic disc icon instead. When I check the properties of the tracks, there is no artwork associated with them. However, MM appears to think that there is artwork as right clicking on the disc icon gives the menu item '☑ Image 1: Cover (front)' at the top and the tracks do not show show up in the 'Files to Edit\Unknown Artwork' node.

If, having found an album or tracks that are missing the artwork, I then go into 'Properties\Artwork' (which is empty), select 'Apply to all files in the Album/Series' and click 'Okay' those tracks have their tags rewritten and will then show up in the Files to Edit\Unknown Artwork' node. I'm just trying to find a way to automatically go through each track and effectively select 'Apply to all files in the Album/Series' so that all the tags are rewritten and the tracks with the missing artwork will show up in the appropriate node.

I could try resyncing the whole library but there are somewhere over 80,000 tracks and I have a very old computer so it would take days. There is also no guarantee that the artwork would sync next time anyway.

Regards,
Mac.
macmcd
 
Posts: 91
Joined: Wed Jul 09, 2008 7:22 am

Re: Album Art Tagger 5.2 - Updated 26/10/2013

Postby THRobinson » Wed Mar 09, 2016 11:10 am

I've used this a while back when I started organizing my library, but don't know all the ins/outs.

Basically... I'm just about done my library overhaul, and looking back at my albums, finding a problem. They were fine when they were done, now, some have issues, some don't. When completed, I would go to the artwork tab and see 3 images... all the same, and one would be the embedded cover art, then a linked folder art, and lastly the smallalbumart file. Exactly what I wanted, though the small album art I could care less about.

Now when I look at a file, they all have the embedded cover art... but some show only that. Some are missing the folder, some missing the smallalbum, some missing both.

Is there a way to batch correct this using this script? I guess, wipe out all artwork except the cover/embedded art, then copy that cover to the folder as folder.jpg and have the files relink/associate with it? and just have it run through folder after folder?

Not sure why it's doing what it's doing... just know that I went through 12,500 files and I don't want to re-do them all manually. :o
THRobinson
 
Posts: 39
Joined: Fri Apr 30, 2010 11:04 am

Re: Album Art Tagger 5.2 - Updated 26/10/2013

Postby VGC » Wed May 25, 2016 2:48 am

Mine is doing the same....
Some Albums get 2 or more sets of the same artwork. It is frustrating, I don't know what is causing this.
VGC
 
Posts: 15
Joined: Sun Oct 13, 2013 2:08 pm

Re: Album Art Tagger 5.2 - Updated 26/10/2013

Postby plopske » Sun Jun 12, 2016 7:13 am

I'm using this great script but ran into trouble...

My music is structured : drive:\artist\album.
Each album folder has a subfolder named Images
the album art is always named artist - album - front.jpg

[artist would be: Beatles, The
album artist would be: The Beatles
foldername would be Beatles, The]

I use the following mask: <path>\Images\<trackartist> - <album> - front

This works fine except for tracks within an album with multiple artists.
The script tries to find an image named: artist1; artist2 - album - front.jpg

I've tried: <path>\Images\$First(<trackartist>) - <album> - front, but that doesn't work.

Is there a way to make a mask for just the first value of a multiple definition field?

advTHANKSance
plopske
 
Posts: 2
Joined: Wed Feb 19, 2014 2:29 pm

Getting Started- Extracting Images to folder.jpg

Postby colin_e » Sun Jun 12, 2016 6:47 pm

I have just installed Album Art Tagger as I want to do some cleanup. Having trouble with the very first step, so I assume i'm doing something wrong.

Setup
My files are all stored on a Synology NAS in FLAC format with embedded image tags.

File organisation mask is: \\{NAS Name}\music\Library\<Album Artist>\<Album>\<Track#:2> - <Title>
e.g.: \\MyNAS\music\Library\Elvis Costello\The Very Best Of Elvis Costello\29 - High Fidelity.flac

I want to export the Cover image for each album to a file called "folder.jpg" in the folder containing the album.

I ran Album Art Tagger with the option set to "extract" and the the file mask: <path>\folder

Problems
[list=]
[*] Many of the existing image files scattered around seem to have been stored with "Hidden" and/or "System" file attibutes. This meant they weren't visible in Explorer by default, which was confusing at first. I'm guess some program (not MM) tends to do this to hide the cover art from normal display?

[*] I run Album Art Tagger for my 3000+ tracks, and it generates a big listing. However path names in the list are shown in blue, which apparently means "Duplicate or wrong type". A few files called "folder.jpg" do exist already, but not every file AAT is trying to write is a duplicate. Meanwhile the output type is set to jpg, and the write preview listing shows all files as "folder.jpg", which looks fine. My user ID has write access on the NAS (I wrote the files using MM in the first place), so i'm unsure what's going on.
[/list]

Any advice?


(BTW, BBCode formatting in this post isn't working for me a lot of the time. Anyone else seeing this issue?)
Regards: Colin
colin_e
 
Posts: 64
Joined: Thu Dec 28, 2006 6:39 pm

Re: Album Art Tagger 5.2 - Updated 26/10/2013

Postby Faisaleem » Tue Jan 24, 2017 9:52 am

Hi, I am using the latest script. Am having an issue with back cover image not being extracted for option 4.
Front cover is extracted fine and size changed. Kindly advise.
Faisaleem
 

Re: Album Art Tagger 5.2 - Updated 26/10/2013

Postby unknownsoldierx » Tue Feb 13, 2018 6:49 am

Where can this be downloaded? Website and dropbox links are dead. I have 5.1 installed, but MediaMonkey fails to update it to 5.2.
unknownsoldierx
 
Posts: 21
Joined: Thu Dec 03, 2009 9:55 am

Re: Album Art Tagger 5.2 - Updated 26/10/2013

Postby Meander » Tue Feb 13, 2018 9:58 am

Meander
 
Posts: 63
Joined: Fri Jun 06, 2014 8:45 am

Re: Album Art Tagger 5.2 - Updated 26/10/2013

Postby unknownsoldierx » Tue Feb 13, 2018 10:18 am

Meander wrote:
Where can this be downloaded?


https://www.rik.onl/mediamonkey/search.php?all=scripts


I found that. It's not clear if it's legit or not. If it is, why haven't the links here and in those in the MediaMonkey add-ons section been updated?
unknownsoldierx
 
Posts: 21
Joined: Thu Dec 03, 2009 9:55 am

Re: Album Art Tagger 5.2 - Updated 26/10/2013

Postby Meander » Tue Feb 13, 2018 10:47 am

You'll have to wait for a developer (or, possibly, Trixmoto himself) to verify and explain that for you. The site certificate is ok, though, and the webpage is the same as it always was. I've downloaded this file and checked it - it's fine.
Meander
 
Posts: 63
Joined: Fri Jun 06, 2014 8:45 am

Re: Album Art Tagger 5.2 - Updated 26/10/2013

Postby Peke » Tue Feb 13, 2018 9:18 pm

I can confirm that site is OK and I noted him about it, also I updated his signature for now.
Best regards,
Pavle
MM Core Developer and Admin of free MediaMonkey extensions Hosting
Image
Image
How to add Images to forum
Peke
 
Posts: 10714
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia

Previous

Return to Need Help with Addons?

Who is online

Users browsing this forum: No registered users and 18 guests