How to disable "frozen" message?

Get answers about syncing the current release of MediaMonkey with iPods and other devices.

Moderator: Gurus

rednoise
Posts: 29
Joined: Sun May 19, 2013 12:33 pm
Location: Boston

How to disable "frozen" message?

Post by rednoise » Wed Oct 17, 2018 5:35 pm

When syncing my mp3 collection from MM4W with my Motorola X4 phone (Android 8.1) via USB, I almost always get the "error" message, "The media transfer process on moto x4 - Internal shared storage appears to be frozen. If the issue doesn't resolve on its own within a few minutes, please disconnect the device and reboot it. If the problem recurs, please use Wi-Fi Synch instead." The thing is, it's not really frozen, it just seems to take some time to complete the "Preparing list of files" process, and in fact will go on the finish the sync operation while the error message remains on the screen. This seems to happen on on the first time I do a sync in a computer session - if I do another sync soon afterwards, I don't get the error message.

The error message is not useful to me - it doesn't indicate a real problem, it just seems to be triggered by a too-short timeout period. Can I disable the error message completely, or set its trigger interval to be longer than it is out-of-the-box?

Peke
Posts: 12370
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: How to disable "frozen" message?

Post by Peke » Wed Oct 17, 2018 6:03 pm

Hi,
How much files you are trying to sync? I have Moto X4 and around 10k Tracks and dozens of autoplaylists and I do not got the message. Have you updated Moto Drivers?
Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum

rednoise
Posts: 29
Joined: Sun May 19, 2013 12:33 pm
Location: Boston

Re: How to disable "frozen" message?

Post by rednoise » Wed Oct 17, 2018 6:21 pm

I have one playlist of 4606 song files that I sync.

What "updated Moto Drivers" are you referring to?

One thing I just noticed... I sync all files to a 64 GB microSD card, nothing to the phone's internal storage. Yet the error message refers to "Internal shared storage appears to be frozen". In MMW Options |Portable Device Sync | Available Devices, I have the Internal Storage unchecked - only "Moto X4 - SD card" is checked. I would think this would make MMW ignore the internal storage device, but the error message implies that it's looking at it anyway and finding it unresponsive. Could that be a clue?

Peke
Posts: 12370
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: How to disable "frozen" message?

Post by Peke » Wed Oct 17, 2018 7:10 pm

Hi,
Internal Storage needs to be accessible as MMA reads Settings and paths from it.

I think I downloaded drivers from https://support.motorola.com/us/en/solution/MS88481
Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum

rednoise
Posts: 29
Joined: Sun May 19, 2013 12:33 pm
Location: Boston

Re: How to disable "frozen" message?

Post by rednoise » Wed Oct 17, 2018 8:20 pm

Peke wrote:
Wed Oct 17, 2018 7:10 pm
Hi,
Internal Storage needs to be accessible as MMA reads Settings and paths from it.

I think I downloaded drivers from https://support.motorola.com/us/en/solution/MS88481
But is MMA relevant in this scenario? It's MMW that's throwing up the error message. I assumed that MMA was not a part of the equation until it was used to catalog the files in its library and to play them. IOW, MMW syncs via USB with the device, not with MMA. No? As it is, both MMW and MMA remember their various settings and paths.

But if it will make a difference, what do I do now? Re-enable the Internal Storage device in MMW? I won't be syncing any files to that device.

I wonder what the Motorola Device Manager will do for me? USB connection between the phone and computer already seem to be working as expected, except for that misleading "Internal shared storage appears to be frozen" message. Otherwise, the phone seems to be fully accessible from Windows 7 via USB - both the phone's internal storage and the SD card can be browsed from Windows, and it will charge from the computer. And the phone has been receiving system updates via WiFi ever since I got it (regular security updates, and it updated from Android 8.0 to 8.1.)

rednoise
Posts: 29
Joined: Sun May 19, 2013 12:33 pm
Location: Boston

Re: How to disable "frozen" message?

Post by rednoise » Fri Oct 19, 2018 1:13 pm

Well, I enabled the Internal Storage device in MMW (in Tools |Options | Portable Device Sync | Available Devices) but there's no change in behavior - I still get that "Internal shared storage appears to be frozen" error message as I described in my first message.

I'm not going to install that "Motorola Device Manager". It seems to be an old program and I found a number or reports that say that it was designed for and will only work with old phones, not the X4, and that the USB drivers that are built into Windows 7 and later are good enough. And, in fact, the phone seems to connect to the computer just fine - I can browse, transfer files, and charge via USB just as I would expect.

Any other suggestions? I'd be perfectly happy just to disable the error message entirely. It's not accurate and the sync operation proceeds to completion despite the warning. Is it possible to disable the error message?

Peke
Posts: 12370
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: How to disable "frozen" message?

Post by Peke » Fri Oct 19, 2018 8:33 pm

mayne you have Android One X4 Device Mine is still on 8.0 I've seen reports that there was a bug in USB Sync.

See:
https://forum.xda-developers.com/moto-x ... 1-t3784758
https://forums.lenovo.com/t5/Moto-X4/Mo ... -p/3980867

Have you tried searching for upgrade and maybe use https://developer.android.com/studio/run/win-usb.html native USB Driver?
Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum

Post Reply