Strange file insert problem

Get answers about using the current release of MediaMonkey for Windows.

Moderator: Gurus

captain paranoia
Posts: 73
Joined: Wed Jul 07, 2010 1:41 pm

Strange file insert problem

Post by captain paranoia » Tue Jun 26, 2018 1:08 pm

I've just been creating a portable library, and noticed that one of the lossy compressed files didn't have a replay gain tag. This led me to my main library, and I found that the file was missing from my library, but present in the folder. So I re-scanned the folder. Still not found. hmmm...

I renamed it from '03 Deer Dance.flac' to '3 Deer Dance.flac', re-scanned, and the track was found.

Named it back, re-scanned, wasn't found. Missing file detected and removed from library.

Went to my other computer, and the file was present. Did the name change thing, and it found both named files.

Same files (stored on NAS, accessed in same manner, same mapped disk name).
Same OS (Win7 Pro, from same install disk, same patches).
Same version of MM (4.1.20.1884).
Same file scan options.

Any ideas as to what might cause this odd behaviour?

captain paranoia
Posts: 73
Joined: Wed Jul 07, 2010 1:41 pm

Re: Strange file insert problem

Post by captain paranoia » Tue Jun 26, 2018 1:28 pm

Okay, just played with the file insert settings.

I turned off the 'Only for files with changed timestamp or size' option in 'Update file info from tags'.

That then found the 03 version file.

Interestingly, even though I'd added and deleted the file a number of times, the 'added' date is now the same as all the other tracks in that album (i.e. MM doesn't think it's newly added). It's almost as if the file has been lurking somewhere else.

The metadata hasn't changed since it was ripped; all files in the album have consistent timestamps.

Lowlander
Posts: 45995
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Strange file insert problem

Post by Lowlander » Tue Jun 26, 2018 5:46 pm

Might have been a different Collection. When in doubt use Entire Library > Location (enable under File > Manage Collections) to locate files.
Lowlander (MediaMonkey user since 2003)

captain paranoia
Posts: 73
Joined: Wed Jul 07, 2010 1:41 pm

Re: Strange file insert problem

Post by captain paranoia » Tue Jun 26, 2018 8:06 pm

I don't even know what Collections are, so I'm pretty sure I don't have any set up...

The other files in the same directory are all found correctly. I didn't move any files, just added/removed the leading 0.

I checked as you suggested; it's currently set to 'Music' on the computer where there was no problem. So it doesn't look like it needs the 'Entire Library' setting. The only elements of the Media tree I use are Music and Media servers; I don't use Music/Classical Music separation, and I don't have Podcasts, Audiobooks, Music Video, Video or TV in my music library; it's just Music.

Thanks for responding, though.

Lowlander
Posts: 45995
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Strange file insert problem

Post by Lowlander » Tue Jun 26, 2018 8:13 pm

Music is a Collection.
Lowlander (MediaMonkey user since 2003)

Post Reply