Backup 6.0 - Updated 01/07/2014

Post a reply


In an effort to prevent automatic submissions, we require that you complete the following challenge.
Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: Backup 6.0 - Updated 01/07/2014

Re: Backup 6.0 - Updated 01/07/2014

by Stigg » Sat Mar 23, 2019 9:11 pm

Mikey1969 wrote:
Thu Mar 21, 2019 2:42 pm
OK, so in other words, this addon has no support, at least looking at this thread and the age of the addon... I guess I'll just do the backups thru Windows, no big deal.
Hi Mikey.

I still use the Backup Addon, but I never set it to backup at shutdown, as I always used to get errors. I don't use Auto either.
I just click on the Backup icon from time to time, and I never have a problem.

Image

Image

Re: Backup 6.0 - Updated 01/07/2014

by Mikey1969 » Thu Mar 21, 2019 2:42 pm

OK, so in other words, this addon has no support, at least looking at this thread and the age of the addon... I guess I'll just do the backups thru Windows, no big deal.

Back up my media library...

by Mikey1969 » Thu Mar 21, 2019 12:42 pm

Hi all,
I'm running MM 4.1.23.1881, and running the 'Backup' addon (v6.0). I have two issues that I'm running into. All I really want to do is back up my music and settings, so if someone has another recommendation, I'm open to suggestions, since it's entirely possible that I'm doing this the hard way.

Anyway, here are the issues:

1. When trying to configure the 'Backup Archive' (Which I take to be the music itself, but I could be wrong), I can set the floder, but I can't click on the radio button to turn the option on.

2. When shutting down MM (Which is when I have the backups scheduled to happen), "Backup canceled because output folder already exists", which seems kind of silly, since most people want to back things up more than once in their lifetimes.

Anyway, I haven't figured out what I'm doing wrong, and any help would be greatly appreciated.

Re: Backup 6.0 - Updated 01/07/2014

by martialartsguy » Wed Dec 05, 2018 11:51 am

I'm getting a VBScript runtime error:
https://imgur.com/a/nqXnYvq

This is for Line 1724, Column 2, which as far as my limited knowledge of scripting goes, refers to deleting files and folders.

Any ideas on how to fix this?

Backup Instructions

by compupix » Sun Jun 03, 2018 3:59 pm

Is there an instruction manual? I've searched and this 96 page thread is the closest thing I've found.
What is Output Archive? Why does it have a browse feature? Why doesn't it go to the Output Path? Why can't I dot it? What is the purpose of "Second archive?" Why multiple paths?

With answers to those questions, I could probably figure out why I'm getting an error: "Output path currently contains 11Mb which could be deleted. Do you wish to continue?"

Thanks!

Re: Backup 6.0 - Updated 01/07/2014

by gpzbc » Tue Mar 27, 2018 10:56 pm

Thanks for posting the solution. I'm guessing someone else will need it at some point.

Re: Backup 6.0 - Updated 01/07/2014

by Peke » Fri Mar 23, 2018 8:02 am

Just checked and I already have that value set.

Re: Backup 6.0 Common AppData Problem

by Stigg » Fri Mar 23, 2018 1:34 am

I found the problem. The above error message threw me off.
The problem was actually a Windows 64-bit issue in the WOW6432Node. Not sure if it is a Windows 10 only problem, but Backup was the only script that stopped working.

The string "Common AppData" in "HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders" was missing.

String: Common AppData
Value: C:\ProgramData
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders]
"Common AppData"="C:\\ProgramData"

Re: Backup Error

by Stigg » Tue Mar 20, 2018 3:03 am

I have started getting a Backup error every time I try to do a backup.
I have tried reinstalling, but it doesn't help.

Image

Re: Media Monkey backup error

by MMFrLife » Sun Oct 15, 2017 8:50 am

You have two closing brackets at the beginning of the image url format. Take one out.
Also, you can't show an image directly from your computer. You have to have it hosted on
an image hosting site like imgur (free).

Re: Media Monkey backup error

by brendansull » Sun Oct 15, 2017 4:54 am

Ok I don't know how to add a picture, that isn't working. Sorry.

So Image 1 shows that Database, Settings, Script files, Skins, Plugins and Extensions are ticked
The output path is a folder I created in Documents

Image 2 is the error message
'C;\\Users\MyName\AppData\Roaming\MeadiMonkey\Scripts\ABackup.vbs
Line: 1117
Error: Permission denied
Code: 800A0046
Source: Microsoft VBScript runtime error

Media Monkey backup error

by brendansull » Sun Oct 15, 2017 4:49 am

First off,
Sorry for starting a new thread. I found one about this that was from 2014, but it doesn't make much sense to me - I am not very computer literate.
I am running the latest MM.
I want to auto backup the database and settings, just in case I need to do a full reinstall at some point and don't lose that database and playlists etc.
So when I go to run the script I have the following settings ticked, see pic 1 The output path is a new folder I created in documents.
I always get this error - see pic 2

First off, have I all the right boxes ticked in order to get a full backup. (Every day the drive undergoes a scheduled backup to an external drive)
And secondly, what do I change to enable the back to complete properly....for a person who doesn't know much about computers
Thanks
Image
Image

How to set up MMbackup?

by terrypin » Tue Oct 10, 2017 4:03 am

In my attempt to get this working again I used Tools > Extensions, Uninstall then Add to re-install. It reported success. But why does it not display the setup dialog so that I can check if there's some folder or whatever wrongly specified?

Re: Backup 6.0 - Updated 01/07/2014

by terrypin » Tue Oct 10, 2017 1:38 am

Is this thread the right one in which to ask questions about getting Auto Backup working again please? At 96 pages long I don't have time to read the lot!

Yesterday, in the course of trying to get my old playlists imported (thread http://forum.mediamonkey.com/viewtopic. ... 76#p439876 ) the backup process that was running fine whenever MM closed suddenly started giving me this message: "Backup cancelled because output folder could not be created."

Thinking it must be because I changed my folders in pursuit of the playlists, I recreated an empty folder called MMBackup, but the error persists.

It's been a long time since I worked with MM's scripts so I'd much appreciate some no-brainer steps to get automatic backup working again please.

BTW, presumably everyone here backs up? So I'm not clear why this is not a simple built-in feature?

Re: Backup 6.0 - Updated 01/07/2014

by gpzbc » Tue Aug 15, 2017 11:17 pm

JRW wrote:Hi,

I have just had to reinstall Windows & MM and have found that the Output Archive zip option is greyed out. I had been using it OK in my previous installation but now can only backup to a folder, not a zip file. Is there something I need to change to make this work?
The reason why you can't tick the archive boxes is because you need to register your zip dll.
Check out this post. http://www.mediamonkey.com/forum/viewto ... bc#p258498

Note that these instructions could be different if you are using the DotNetZip component. Check out Trixmoto's signature at this post for the DotNetZip componenet.
http://www.mediamonkey.com/forum/viewto ... 15#p391446

Hopefully that helps. Let us know if not.

Top