NEW! AutoRateAccurate 3.0 (22/09/2013) - for MM4

Post a reply

Visual Confirmation

To prevent automated access and spam, you are required to confirm that you are human. Please place a check mark next to all images of monkeys or apes. If you cannot see any images, please contact the Board Administrator.

Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:
BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON
Topic review
   

Expand view Topic review: NEW! AutoRateAccurate 3.0 (22/09/2013) - for MM4

Re: NEW! AutoRateAccurate 3.0 (22/09/2013) - for MM4

Post by ojk12 » Thu Jul 20, 2017 10:42 am

I've been using autorate accurate for a long time and works wonderfull for me, but this time I decided to copy my portable installation of mediamonkey to another computer and when autorate tries to running I only get this message

Error #5 - Microsoft VBScript runtime error
Invalid procedure call or argument
File "C:\Program Files (x86)\MediaMonkey\Scripts\Auto\AutoRateAccStarter.vbs", Line: 0, Column: 0


The portable installation that is working is on a D(non system) drive and the non working is on C(system), I think it's the only thing that could be causing conflicts

I'd love it to work on the new drive

Re: NEW! AutoRateAccurate 3.0 (22/09/2013) - for MM4

Post by bigcebo » Sat Jun 17, 2017 9:07 am

So this doesn't actually affect the stars in the rating field?

Re: NEW! AutoRateAccurate 3.0 (22/09/2013) - for MM4

Post by rovingcowboy » Wed Jan 04, 2017 1:47 pm

Not sure if anyone has done any more. But ms did change something in their script code just not sure what it was but some other programs have been messed-up too on my system.

Re: NEW! AutoRateAccurate 3.0 (22/09/2013) - for MM4

Post by kalowski » Wed Jan 04, 2017 12:06 pm

Would love this to work again.
Is there any kind of automated based on plays out there that I've missed?

Cheers,

K.

Re: NEW! AutoRateAccurate 3.0 (22/09/2013) - for MM4

Post by rovingcowboy » Sun Oct 23, 2016 11:55 pm

It's ms fault they did some new stuff and this needs a rewrite.

Re: NEW! AutoRateAccurate 3.0 (22/09/2013) - for MM4

Post by kalowski » Mon Oct 17, 2016 3:37 pm

Just doesn't work for me.:(
Every time I install and go to set up I get the same problems.

1 - On the advanced page I get no "SUM" for the library ratings
2 - When I try to change a rating value I get Error #13- Microsoft VBScript runtime error Type mismatch '[string: "(null")]'
3 - Whether I enable it or not, clicking OK on options will not allow me to leave the options page. I have to force MM to close thru task manager. I then have to uninstall Auto-Rate.

I'm running MM 4.1.14.1813 on Windows 10.

Re: NEW! AutoRateAccurate 3.0 (22/09/2013) - for MM4

Post by kevtron1991 » Tue Jul 26, 2016 7:55 pm

HELLO,
i tried installing this and it failed to be honest i just want this script to go away period.
does not show up in mediamonkey itself but everytime i play a file it shows sql errors i have tried everything
deleting scripts folder in \appdata\roaming\mediamonkey programfiles\mediamonkey
i even tried clean install it just keeps popping up how do i remove this awful script!!!!!!!



UPDATE=after 3 reinstalls i set appdata\roaming\mediamonkey\extensions\autorateacc folder to HIDDEN
also set appdata\roaming\mediamonkey\scripts\auto folder to HIDDEN

PROBLEM SOLVED desperate yes....but effective no more errors

Re: NEW! AutoRateAccurate 3.0 (22/09/2013) - for MM4

Post by iain2020 » Sun Apr 24, 2016 9:51 am

I'm getting the following error when using autorate accurate

Error #-2147418113 - SongsDB.SDBUIDropDown
Control " has no parent window
File: "C:\Users\Iain\AppData\Roaming\MediaMonkey\Scripts\Auto\AutoRateAccStarter.vbs", Line: 1808, Column: 8

The script is as installed, I haven't edited it.

Image

Re: NEW! AutoRateAccurate 3.0 (22/09/2013) - for MM4

Post by Kanzar » Sat Dec 05, 2015 2:35 am

MMJuno wrote:
Kanzar wrote:My MM4 crashes when it reaches Phase 2, and has been doing so for quite some time. I note BB mentions above he was going to submit a version without the code that crashes MM - is there anything we can do on our end to ensure there are no other reasons for MM to be crashing?


Wondering this as well. I keep seeing this recently too where autorate crashes ntdll.dll in Phase 2. I've considered it may be a corrupt file that it's trying to process, but I'm not aware of a way to tell what file(s) it's trying to process in order to track down the problem file(s). With over 25k tracks, this could take some time to track down manually.

Edit: Seems this might be related to some odd permissions issue... Forcing MM to "Run as Administrator" then forcing an AutoRate didn't crash MM this last time I tried it (even though my account is an Administrator). :-?


Mine still crashes even if I run as admin. :(

Re: NEW! AutoRateAccurate 3.0 (22/09/2013) - for MM4

Post by MMJuno » Fri Oct 30, 2015 9:56 am

Kanzar wrote:My MM4 crashes when it reaches Phase 2, and has been doing so for quite some time. I note BB mentions above he was going to submit a version without the code that crashes MM - is there anything we can do on our end to ensure there are no other reasons for MM to be crashing?


Wondering this as well. I keep seeing this recently too where autorate crashes ntdll.dll in Phase 2. I've considered it may be a corrupt file that it's trying to process, but I'm not aware of a way to tell what file(s) it's trying to process in order to track down the problem file(s). With over 25k tracks, this could take some time to track down manually.

Edit: Seems this might be related to some odd permissions issue... Forcing MM to "Run as Administrator" then forcing an AutoRate didn't crash MM this last time I tried it (even though my account is an Administrator). :-?

Re: NEW! AutoRateAccurate 3.0 (22/09/2013) - for MM4

Post by Kanzar » Sat Oct 03, 2015 6:24 am

My MM4 crashes when it reaches Phase 2, and has been doing so for quite some time. I note BB mentions above he was going to submit a version without the code that crashes MM - is there anything we can do on our end to ensure there are no other reasons for MM to be crashing?

Re: NEW! AutoRateAccurate 3.0 (22/09/2013) - for MM4

Post by rovingcowboy » Mon Sep 21, 2015 10:49 pm

glad it worked for you. 8)

Re: NEW! AutoRateAccurate 3.0 (22/09/2013) - for MM4

Post by umfunix » Mon Sep 21, 2015 9:50 am

Solved, thanks!

Re: NEW! AutoRateAccurate 3.0 (22/09/2013) - for MM4

Post by umfunix » Mon Sep 21, 2015 9:32 am

rovingcowboy wrote:So you got auto rate stuck in the computer i read your other post and the script error is the same as we have worked out in one of these 2 threads about a year ago just find those posts and do the fix that I did it should stop that error. Then you just save the script you fixed in a different folder. Reinstall auto rate then copy the fixed script in to the proper folder for auto rate to use it will overwrite the new script with your fixed one so it will work.


Thanks. Will check and fix.

Re: NEW! AutoRateAccurate 3.0 (22/09/2013) - for MM4

Post by rovingcowboy » Sun Sep 20, 2015 6:07 pm

So you got auto rate stuck in the computer i read your other post and the script error is the same as we have worked out in one of these 2 threads about a year ago just find those posts and do the fix that I did it should stop that error. Then you just save the script you fixed in a different folder. Reinstall auto rate then copy the fixed script in to the proper folder for auto rate to use it will overwrite the new script with your fixed one so it will work.

Top