HELP: can run as admin,but clicking .MMIP launches seperate

Post a reply


In an effort to prevent automatic submissions, we require that you complete the following challenge.
Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: HELP: can run as admin,but clicking .MMIP launches seperate

Re: HELP: can run as admin,but clicking .MMIP launches seperate

by urlwolf » Tue Apr 14, 2009 6:37 pm

sorry to be blunt, but the pain that the entire world is suffering right now with UAC is designed to prevent apps to require admin rights when they don't need them. I think this is the case here. MM devs, this is M$ yelling at you to get MM to work without admin privs :)

Re: HELP: can run as admin,but clicking .MMIP launches seperate

by judas » Tue Apr 14, 2009 9:11 am

I agree it is not very smart to need admin privileges and disable UAC just to install a script...maybe this can be addressed the way Firefox works: a folder that does not need permission or something.

Re: HELP: can run as admin,but clicking .MMIP launches seperate

by bmilner » Mon Apr 13, 2009 8:12 pm

@Judas: Thanks, that actually worked as I was able to get the Scrobbler installed.

Annoyingly, the following also happened:

1. Though tracks were being communicated to last.fm, there was no UI in the Last FM application showing tracks being scrobbled. (they just appeared on the website). Weird, and very annoying as I rather liked that ability to see additional data about tracks currently playing in the last.fm app. It always looked like it was broken... so I quit the app, dragged the DLL out of the plug-in directory and dragged the old Winamp Scrobbler DLL back in.

that's when the trouble started...

2. Now re-launching the program threw a "Problem during player installation" error. It seemed to see my tracks DB ok, but it reset my .INI file and lost all my prefs (grrr... there are LOT of prefs to set in this app from encoding prefs to column prefs etc.). Also, it could no longer see my 3rd party SKin I had installed. It defaulted to the default skin and didn't show my desired skin in the menu to choose from.

3. I QUIT again, and manually dragged a backup up of my INI file to the AppData folder. Restarted and voila, everything was back. So, no idea what was up. I guess you can't just manually drag a DLL in or out without some corruption happening.

By the way, I'm still livid I had disable UAC on my entire PC just to install a plug-in. This is SO not ready for prime time.

Re: HELP: can run as admin,but clicking .MMIP launches seperate

by rovingcowboy » Mon Apr 13, 2009 1:18 am

oh thats bad news then seems he removed them when he split the program in two, but i can't figure why he would do that? unless they did not work in vista? :-? bummer :(

Re: HELP: can run as admin,but clicking .MMIP launches seperate

by judas » Sat Apr 11, 2009 10:06 am

Hi!
I was having the exact same problem yesterday...it is a headache!

Allthough I'm running vista 32 what finally worked for me is:

1. Disable UAC (User Account Control)
2. Restart
3. Open Mediamonkey, tools, extensions and remove the one you're trying to install
4. Close Mediamonkey
5. Open Mediamonkey as administrator (right click, run as admin)
6. Drop the .mmip file on top of the Play Button, a prompt to install should pop up.
7.Close MM and turn UAC back on

It may work without the UAC disabling / enabling...but I think this is what I did yesterday and worked. Please try it and post back!

Re: HELP: can run as admin,but clicking .MMIP launches seperate

by bmilner » Fri Apr 10, 2009 9:58 pm

@Bex: I can't drag and drop the .MMIP file onto the play button. That appears to do nothing.
@NoHitter151: I do have "only allow one instance of MM" checked in the prefs. In fact, check out this groovy screenshot of what appears to be impossible! (non-retouched except to highlight the pref setting) - http://farm4.static.flickr.com/3328/343 ... b633_o.jpg

So I appear to again be stumped. I downloaded the program Roving Cowboy suggested and couldn't make heads or tails of it. Couldn't find any reference to the service tweak you mentioned. I am seriously scared to have to hack into my UAC functionality just to install a dang plug-in. Is this a bug? Thank you all for trying to help by the way.

Re: HELP: can run as admin,but clicking .MMIP launches seperate

by rovingcowboy » Fri Apr 10, 2009 4:00 pm

before i yelled cause you said it was not vista only i thought to check the version number of what i have.
and i am using mz ultimate tweaker 5.1. old one. :(

so i checked his web site and he has now changed it to two different programs, which i did not know he did.

so here is the new page link for the vista version of his program.

http://www.mztweak.com/MzVista.html
try it and see if it still tells you to enable or disable the service that allows two log ons for programs that need that in vista. 8)

Re: HELP: can run as admin,but clicking .MMIP launches seperate

by Bex » Fri Apr 10, 2009 9:00 am

You can try to drag & drop the.MMIP file onto the play-button in MM.

Re: HELP: can run as admin,but clicking .MMIP launches seperate

by nohitter151 » Fri Apr 10, 2009 6:36 am

In the options do you have "Allow one instance of MediaMonkey" checked?

Re: HELP: can run as admin,but clicking .MMIP launches seperate

by bmilner » Fri Apr 10, 2009 1:34 am

I should have mentioned... yes, Vista 64-bit.
I'll try your idea. Very confusing. Why does MM need admin level privileges to install a plug-in anyway? Loopy.

UPDATE: that app you suggest is XP only. I looked for something comparible for Vista and couldn't find a google reference to something allowing 2 simultaneous UAC levels. Still need help here.

Re: HELP: can run as admin,but clicking .MMIP launches seperate

by rovingcowboy » Thu Apr 09, 2009 11:32 pm

you sound like your on vista.

get a tweak program like mz ultimate tweaker from majorgeeks.com its free.

in it there is a very user friendly start up manager. it will show you what is enabled or disabled and which services can be disabled with out causing trouble to the computer.

there is one that is for allowing the use of a second sign on service i think that is what it is called but it should
allow monkey to work as one then. i don't have vista but i read that help on that service in the tweak program and this, is what it said it was for. " allowing a second logon for apps that need it." now if that is what you need then great i got it right. but i am not sure. :-?
still its something to try until you get a solid answer.

lowlander or nohitter151 and peke and some others are using vista they might know just what to do. 8)

HELP: can run as admin,but clicking .MMIP launches seperate

by bmilner » Thu Apr 09, 2009 4:51 pm

I'm trying to install the Last.fm scrobble plug-in and am getting the error that it can't install so I know I need to run Mediamonkey as admin (by the way, how power-usery and confusing is that? Come on, it should request elevation if it needs it... or throw a useful error). Anyway, my issue:

1. I right-click on MM 3.1 and choose "run as administrator" - this launches MM (where it forgets my skin choice I set as a standard user, thanks).
2. I then double click on the .MMIP file for the Last.fm scrobbler. This launches a second instance of MM NOT in admin mode so the installer fails again.

My question: How do I run the .MMIP from the instance of MM running as administrator? Why am I getting two instances of MM running as two seperate User Access levels at once?

Help!

Brandon

Top